make sysutils/py-psutil build on SecBSD
This commit is contained in:
parent
09b3080379
commit
e2e2ced49d
15 changed files with 528 additions and 3 deletions
29
sysutils/py-psutil/patches/patch-setup_py
Normal file
29
sysutils/py-psutil/patches/patch-setup_py
Normal file
|
@ -0,0 +1,29 @@
|
|||
Index: setup.py
|
||||
--- setup.py.orig
|
||||
+++ setup.py
|
||||
@@ -51,6 +51,7 @@ from _common import MACOS # NOQA
|
||||
from _common import NETBSD # NOQA
|
||||
from _common import OPENBSD # NOQA
|
||||
from _common import POSIX # NOQA
|
||||
+from _common import SECBSD # NOQA
|
||||
from _common import SUNOS # NOQA
|
||||
from _common import WINDOWS # NOQA
|
||||
from _common import hilite # NOQA
|
||||
@@ -234,7 +235,7 @@ elif FREEBSD:
|
||||
libraries=["devstat"],
|
||||
**py_limited_api)
|
||||
|
||||
-elif OPENBSD:
|
||||
+elif OPENBSD or SECBSD:
|
||||
macros.append(("PSUTIL_OPENBSD", 1))
|
||||
ext = Extension(
|
||||
'psutil._psutil_bsd',
|
||||
@@ -470,7 +471,7 @@ def main():
|
||||
missdeps("pkg install gcc python%s" % py3)
|
||||
elif which('mport'): # MidnightBSD
|
||||
missdeps("mport install gcc python%s" % py3)
|
||||
- elif OPENBSD:
|
||||
+ elif OPENBSD or SECBSD:
|
||||
missdeps("pkg_add -v gcc python%s" % py3)
|
||||
elif NETBSD:
|
||||
missdeps("pkgin install gcc python%s" % py3)
|
Loading…
Add table
Add a link
Reference in a new issue