use MODPY_COMPILEALL (or drop unneeded runs of compileall) for an initial scattering of ports

This commit is contained in:
purplerain 2024-08-13 19:27:50 +00:00
parent 9105d8e4cb
commit e1f01a6978
Signed by: purplerain
GPG key ID: F42C07F07E2E35B7
18 changed files with 55 additions and 492 deletions

View file

@ -2,7 +2,7 @@ COMMENT= GNU debugger
CATEGORIES= devel
DISTNAME= gdb-9.2
REVISION= 5
REVISION= 6
HOMEPAGE= https://www.gnu.org/software/gdb/
@ -49,6 +49,6 @@ LIB_DEPENDS += ${MODPY_LIB_DEPENDS}
TEST_DEPENDS += devel/dejagnu
post-install:
${MODPY_BIN} -m compileall ${PREFIX}/share/gdb/python
${MODPY_COMPILEALL} ${PREFIX}/share/gdb/python
.include <bsd.port.mk>

View file

@ -6,7 +6,7 @@ Index: bfd/configure
;;
- netbsd* | freebsd* | openbsd* | darwin* | dragonfly*)
+ netbsd* | freebsd* | openbsd* | darwin* | dragonfly* | secbsd*)
+ netbsd* | freebsd* | openbsd* | secbsd* | darwin* | dragonfly*)
# This has been around since 386BSD, at least. Likely further.
if test -x /sbin/sysctl; then
lt_cv_sys_max_cmd_len=`/sbin/sysctl -n kern.argmax`
@ -15,7 +15,7 @@ Index: bfd/configure
# Not sure whether the presence of OpenBSD here was a mistake.
# Let's accept both of them until this is cleared up.
- lt_cv_deplibs_check_method='file_magic (FreeBSD|OpenBSD|DragonFly)/i[3-9]86 (compact )?demand paged shared library'
+ lt_cv_deplibs_check_method='file_magic (FreeBSD|OpenBSD|DragonFly|SecBSD)/i[3-9]86 (compact )?demand paged shared library'
+ lt_cv_deplibs_check_method='file_magic (FreeBSD|OpenBSD|SecBSD|DragonFly)/i[3-9]86 (compact )?demand paged shared library'
lt_cv_file_magic_cmd=/usr/bin/file
lt_cv_file_magic_test_file=`echo /usr/lib/libc.so.*`
;;
@ -37,6 +37,15 @@ Index: bfd/configure
with_gnu_ld=no
;;
esac
@@ -15115,7 +15115,7 @@ if test "${target}" = "${host}"; then
;;
arm-*-freebsd* | arm-*-kfreebsd*-gnu)
COREFILE='' ;;
- arm-*-netbsd* | arm-*-openbsd*)
+ arm-*-netbsd* | arm-*-openbsd* | arm-*-secbsd*)
COREFILE=netbsd-core.lo
;;
arm-*-riscix) COREFILE=trad-core.lo ;;
@@ -15148,7 +15148,7 @@ if test "${target}" = "${host}"; then
COREFILE=''
TRAD_HEADER='"hosts/i386bsd.h"'

View file

@ -10,12 +10,12 @@ Index: configure
case "${target}" in
*-*-linux*aout* | *-*-linux*oldld*)
;;
@@ -3216,7 +3216,7 @@ if test x$enable_libgomp = x ; then
case "${target}" in
*-*-linux* | *-*-gnu* | *-*-k*bsd*-gnu | *-*-kopensolaris*-gnu)
@@ -3218,7 +3218,7 @@ if test x$enable_libgomp = x ; then
;;
- *-*-netbsd* | *-*-freebsd* | *-*-openbsd* | *-*-dragonfly*)
+ *-*-netbsd* | *-*-freebsd* | *-*-openbsd* | *-*-dragonfly* | *-*-secbsd*)
*-*-netbsd* | *-*-freebsd* | *-*-openbsd* | *-*-dragonfly*)
;;
*-*-solaris2* | *-*-hpux11*)
- *-*-solaris2* | *-*-hpux11*)
+ *-*-secbsd* | *-*-solaris2* | *-*-hpux11*)
;;
*-*-darwin* | *-*-aix*)
;;

View file

@ -1,36 +1,15 @@
Index: gdb/configure.host
--- gdb/configure.host.orig
+++ gdb/configure.host
@@ -85,6 +85,8 @@ case "${host}" in
@@ -85,6 +85,7 @@ case "${host}" in
aarch64*-*-linux*) gdb_host=linux ;;
aarch64*-*-freebsd*) gdb_host=fbsd ;;
+aarch64*-*-openbsd* | aarch64*-*-secbsd*)
+ gdb_host=obsd64 ;;
+aarch64*-*-openbsd*) gdb_host=obsd64 ;;
alpha*-*-linux*) gdb_host=alpha-linux ;;
alpha*-*-netbsd* | alpha*-*-knetbsd*-gnu)
@@ -95,7 +97,8 @@ arm*-*-freebsd*) gdb_host=fbsd ;;
arm*-*-linux*) gdb_host=linux ;;
arm*-*-netbsdelf* | arm*-*-knetbsd*-gnu)
gdb_host=nbsdelf ;;
-arm*-*-openbsd*) gdb_host=nbsdelf ;;
+arm*-*-openbsd* | arm*-*-secbsd*)
+ gdb_host=nbsdelf ;;
hppa*-*-linux*) gdb_host=linux ;;
hppa*-*-netbsd*) gdb_host=nbsd ;;
@@ -113,7 +116,8 @@ i[34567]86-*-msdosdjgpp*) gdb_host=go32 ;;
i[34567]86-*-linux*) gdb_host=linux ;;
i[34567]86-*-gnu*) gdb_host=i386gnu ;;
i[3456]86-*-nto*) gdb_host=nto ;;
-i[34567]86-*-openbsd*) gdb_host=obsd ;;
+i[34567]86-*-openbsd* | i[34567]86-*-secbsd*)
+ gdb_host=obsd ;;
i[34567]86-*-solaris2* | x86_64-*-solaris2*)
gdb_host=sol2 ;;
i[34567]86-*-cygwin*) gdb_host=cygwin ;;
@@ -139,12 +143,14 @@ powerpc*-*-freebsd*) gdb_host=fbsd ;;
@@ -139,12 +140,14 @@ powerpc*-*-freebsd*) gdb_host=fbsd ;;
powerpc-*-netbsd* | powerpc-*-knetbsd*-gnu)
gdb_host=nbsd ;;
powerpc-*-openbsd*) gdb_host=obsd ;;
@ -45,13 +24,3 @@ Index: gdb/configure.host
s390*-*-linux*) gdb_host=linux ;;
@@ -177,7 +183,8 @@ x86_64-*-freebsd* | x86_64-*-kfreebsd*-gnu)
gdb_host=fbsd64 ;;
x86_64-*-netbsd* | x86_64-*-knetbsd*-gnu)
gdb_host=nbsd64 ;;
-x86_64-*-openbsd*) gdb_host=obsd64 ;;
+x86_64-*-openbsd* | x86_64-*-secbsd*)
+ gdb_host=obsd64 ;;
x86_64-*-mingw*) gdb_host=mingw64
gdb_host_obs=mingw-hdep.o
;;

View file

@ -1,20 +1,11 @@
Index: gdb/configure.tgt
--- gdb/configure.tgt.orig
+++ gdb/configure.tgt
@@ -104,7 +104,7 @@ case "${targ}" in
os_obs="fbsd-tdep.o solib-svr4.o";;
*-*-netbsd* | *-*-knetbsd*-gnu)
os_obs="nbsd-tdep.o solib-svr4.o";;
-*-*-openbsd*)
+*-*-openbsd* | *-*-secbsd*)
os_obs="obsd-tdep.o solib-svr4.o";;
esac
@@ -131,6 +131,13 @@ aarch64*-*-linux*)
build_gdbserver=yes
;;
+aarch64*-*-openbsd* | aarch64*-*-secbsd*)
+aarch64*-*-openbsd*)
+ # Target: OpenBSD/arm64
+ gdb_target_obs="aarch64-tdep.o aarch64-obsd-tdep.o arch/aarch64-insn.o \
+ obsd-tdep.o solib-svr4.o \
@ -24,24 +15,6 @@ Index: gdb/configure.tgt
alpha*-*-linux*)
# Target: Little-endian Alpha running Linux
gdb_target_obs="alpha-mdebug-tdep.o alpha-linux-tdep.o \
@@ -177,7 +184,7 @@ arm*-*-netbsd* | arm*-*-knetbsd*-gnu)
# Target: NetBSD/arm
gdb_target_obs="arm-nbsd-tdep.o"
;;
-arm*-*-openbsd*)
+arm*-*-openbsd* | arm*-*-secbsd)
# Target: OpenBSD/arm
gdb_target_obs="arm-bsd-tdep.o arm-obsd-tdep.o"
;;
@@ -276,7 +283,7 @@ i[34567]86-*-netbsd* | i[34567]86-*-knetbsd*-gnu)
# Target: NetBSD/i386
gdb_target_obs="i386-bsd-tdep.o i386-nbsd-tdep.o "
;;
-i[34567]86-*-openbsd*)
+i[34567]86-*-openbsd* | i[34567]86-*-secbsd*)
# Target: OpenBSD/i386
gdb_target_obs="i386-bsd-tdep.o i386-obsd-tdep.o bsd-uthread.o"
;;
@@ -506,6 +513,12 @@ powerpc-*-openbsd*)
gdb_target_obs="rs6000-tdep.o ppc-sysv-tdep.o ppc-obsd-tdep.o \
ravenscar-thread.o ppc-ravenscar-thread.o"
@ -55,25 +28,16 @@ Index: gdb/configure.tgt
powerpc-*-aix* | rs6000-*-* | powerpc64-*-aix*)
# Target: PowerPC running AIX
gdb_target_obs="rs6000-tdep.o rs6000-aix-tdep.o xcoffread.o \
@@ -554,6 +567,12 @@ riscv*-*-linux*)
@@ -552,6 +565,12 @@ riscv*-*-linux*)
# Target: Linux/RISC-V
gdb_target_obs="riscv-linux-tdep.o glibc-tdep.o \
linux-tdep.o solib-svr4.o symfile-mem.o linux-record.o"
;;
+ ;;
+
+riscv*-*-openbsd*)
+ # Target: OpenBSD/riscv
+ # XXX is that list enough?
+ gdb_target_obs="riscv-obsd-tdep.o"
+ ;;
+
riscv*-*-*)
# Target: RISC-V architecture
gdb_target_obs=""
@@ -759,7 +778,7 @@ x86_64-*-netbsd* | x86_64-*-knetbsd*-gnu)
# Target: NetBSD/amd64
gdb_target_obs="amd64-nbsd-tdep.o ${i386_tobjs}"
;;
-x86_64-*-openbsd*)
+x86_64-*-openbsd* | x86_64-*-secbsd*)
# Target: OpenBSD/amd64
gdb_target_obs="amd64-obsd-tdep.o ${i386_tobjs} \
i386-bsd-tdep.o i386-obsd-tdep.o \
riscv*-*-*)

View file

@ -1,21 +0,0 @@
Index: gnulib/configure
--- gnulib/configure.orig
+++ gnulib/configure
@@ -13718,7 +13718,7 @@ else
if test "$cross_compiling" = yes; then :
case "$host_os" in
# Guess yes on platforms where we know the result.
- *-gnu* | freebsd* | netbsd* | openbsd* \
+ *-gnu* | freebsd* | netbsd* | openbsd* | secbsd* \
| hpux* | solaris* | cygwin* | mingw*)
ac_cv_func_malloc_0_nonnull=yes ;;
# If we don't know, assume the worst.
@@ -18238,7 +18238,7 @@ $as_echo "#define FLEXIBLE_ARRAY_MEMBER /**/" >>confde
FLOAT_H=
REPLACE_FLOAT_LDBL=0
case "$host_os" in
- aix* | beos* | openbsd* | mirbsd* | irix*)
+ aix* | beos* | openbsd* | mirbsd* | irix* | secbsd*)
FLOAT_H=float.h
;;
freebsd*)

View file

@ -1,39 +0,0 @@
Index: libctf/configure
--- libctf/configure.orig
+++ libctf/configure
@@ -6021,7 +6021,7 @@ else
lt_cv_sys_max_cmd_len=8192;
;;
- netbsd* | freebsd* | openbsd* | darwin* | dragonfly*)
+ netbsd* | freebsd* | openbsd* | darwin* | dragonfly* | secbsd*)
# This has been around since 386BSD, at least. Likely further.
if test -x /sbin/sysctl; then
lt_cv_sys_max_cmd_len=`/sbin/sysctl -n kern.argmax`
@@ -6377,7 +6377,7 @@ freebsd* | dragonfly*)
i*86 )
# Not sure whether the presence of OpenBSD here was a mistake.
# Let's accept both of them until this is cleared up.
- lt_cv_deplibs_check_method='file_magic (FreeBSD|OpenBSD|DragonFly)/i[3-9]86 (compact )?demand paged shared library'
+ lt_cv_deplibs_check_method='file_magic (FreeBSD|OpenBSD|DragonFly|SecBSD)/i[3-9]86 (compact )?demand paged shared library'
lt_cv_file_magic_cmd=/usr/bin/file
lt_cv_file_magic_test_file=`echo /usr/lib/libc.so.*`
;;
@@ -6835,7 +6835,7 @@ old_postuninstall_cmds=
if test -n "$RANLIB"; then
case $host_os in
- openbsd*)
+ openbsd* | secbsd*)
old_postinstall_cmds="$old_postinstall_cmds~\$RANLIB -t \$oldlib"
;;
*)
@@ -9062,7 +9062,7 @@ $as_echo_n "checking whether the $compiler linker ($LD
# we just hope/assume this is gcc and not c89 (= MSVC++)
with_gnu_ld=yes
;;
- openbsd*)
+ openbsd* | secbsd*)
with_gnu_ld=no
;;
esac

View file

@ -1,30 +0,0 @@
Index: ltmain.sh
--- ltmain.sh.orig
+++ ltmain.sh
@@ -4741,7 +4741,7 @@ func_mode_link ()
# These systems don't actually have a C library (as such)
test "X$arg" = "X-lc" && continue
;;
- *-*-openbsd* | *-*-freebsd* | *-*-dragonfly*)
+ *-*-openbsd* | *-*-freebsd* | *-*-dragonfly* | *-*-secbsd*)
# Do not include libc due to us having libc/libc_r.
test "X$arg" = "X-lc" && continue
;;
@@ -4764,7 +4764,7 @@ func_mode_link ()
esac
elif test "X$arg" = "X-lc_r"; then
case $host in
- *-*-openbsd* | *-*-freebsd* | *-*-dragonfly*)
+ *-*-openbsd* | *-*-freebsd* | *-*-dragonfly* | *-*-secbsd*)
# Do not include libc_r directly, use -pthread flag.
continue
;;
@@ -6703,7 +6703,7 @@ func_mode_link ()
*-*-netbsd*)
# Don't link with libc until the a.out ld.so is fixed.
;;
- *-*-openbsd* | *-*-freebsd* | *-*-dragonfly*)
+ *-*-openbsd* | *-*-freebsd* | *-*-dragonfly* | *-*-secbsd*)
# Do not include libc due to us having libc/libc_r.
;;
*-*-sco3.2v5* | *-*-sco5v6*)

View file

@ -6,7 +6,7 @@ Index: opcodes/configure
;;
- netbsd* | freebsd* | openbsd* | darwin* | dragonfly*)
+ netbsd* | freebsd* | openbsd* | darwin* | dragonfly* | secbsd*)
+ netbsd* | freebsd* | openbsd* | secbsd* | darwin* | dragonfly*)
# This has been around since 386BSD, at least. Likely further.
if test -x /sbin/sysctl; then
lt_cv_sys_max_cmd_len=`/sbin/sysctl -n kern.argmax`
@ -15,7 +15,7 @@ Index: opcodes/configure
# Not sure whether the presence of OpenBSD here was a mistake.
# Let's accept both of them until this is cleared up.
- lt_cv_deplibs_check_method='file_magic (FreeBSD|OpenBSD|DragonFly)/i[3-9]86 (compact )?demand paged shared library'
+ lt_cv_deplibs_check_method='file_magic (FreeBSD|OpenBSD|DragonFly|SecBSD)/i[3-9]86 (compact )?demand paged shared library'
+ lt_cv_deplibs_check_method='file_magic (FreeBSD|OpenBSD|SecBSD|DragonFly)/i[3-9]86 (compact )?demand paged shared library'
lt_cv_file_magic_cmd=/usr/bin/file
lt_cv_file_magic_test_file=`echo /usr/lib/libc.so.*`
;;

View file

@ -1,39 +0,0 @@
Index: sim/aarch64/configure
--- sim/aarch64/configure.orig
+++ sim/aarch64/configure
@@ -6303,7 +6303,7 @@ else
lt_cv_sys_max_cmd_len=8192;
;;
- netbsd* | freebsd* | openbsd* | darwin* | dragonfly*)
+ netbsd* | freebsd* | openbsd* | darwin* | dragonfly* | secbsd*)
# This has been around since 386BSD, at least. Likely further.
if test -x /sbin/sysctl; then
lt_cv_sys_max_cmd_len=`/sbin/sysctl -n kern.argmax`
@@ -6659,7 +6659,7 @@ freebsd* | dragonfly*)
i*86 )
# Not sure whether the presence of OpenBSD here was a mistake.
# Let's accept both of them until this is cleared up.
- lt_cv_deplibs_check_method='file_magic (FreeBSD|OpenBSD|DragonFly)/i[3-9]86 (compact )?demand paged shared library'
+ lt_cv_deplibs_check_method='file_magic (FreeBSD|OpenBSD|DragonFly|SecBSD)/i[3-9]86 (compact )?demand paged shared library'
lt_cv_file_magic_cmd=/usr/bin/file
lt_cv_file_magic_test_file=`echo /usr/lib/libc.so.*`
;;
@@ -7117,7 +7117,7 @@ old_postuninstall_cmds=
if test -n "$RANLIB"; then
case $host_os in
- openbsd*)
+ openbsd* | secbsd*)
old_postinstall_cmds="$old_postinstall_cmds~\$RANLIB -t \$oldlib"
;;
*)
@@ -10510,7 +10510,7 @@ $as_echo_n "checking whether the $compiler linker ($LD
# we just hope/assume this is gcc and not c89 (= MSVC++)
with_gnu_ld=yes
;;
- openbsd*)
+ openbsd* | secbsd*)
with_gnu_ld=no
;;
esac

View file

@ -1,39 +0,0 @@
Index: sim/arm/configure
--- sim/arm/configure.orig
+++ sim/arm/configure
@@ -6303,7 +6303,7 @@ else
lt_cv_sys_max_cmd_len=8192;
;;
- netbsd* | freebsd* | openbsd* | darwin* | dragonfly*)
+ netbsd* | freebsd* | openbsd* | darwin* | dragonfly* | secbsd*)
# This has been around since 386BSD, at least. Likely further.
if test -x /sbin/sysctl; then
lt_cv_sys_max_cmd_len=`/sbin/sysctl -n kern.argmax`
@@ -6659,7 +6659,7 @@ freebsd* | dragonfly*)
i*86 )
# Not sure whether the presence of OpenBSD here was a mistake.
# Let's accept both of them until this is cleared up.
- lt_cv_deplibs_check_method='file_magic (FreeBSD|OpenBSD|DragonFly)/i[3-9]86 (compact )?demand paged shared library'
+ lt_cv_deplibs_check_method='file_magic (FreeBSD|OpenBSD|DragonFly|SecBSD)/i[3-9]86 (compact )?demand paged shared library'
lt_cv_file_magic_cmd=/usr/bin/file
lt_cv_file_magic_test_file=`echo /usr/lib/libc.so.*`
;;
@@ -7117,7 +7117,7 @@ old_postuninstall_cmds=
if test -n "$RANLIB"; then
case $host_os in
- openbsd*)
+ openbsd* | secbsd*)
old_postinstall_cmds="$old_postinstall_cmds~\$RANLIB -t \$oldlib"
;;
*)
@@ -10510,7 +10510,7 @@ $as_echo_n "checking whether the $compiler linker ($LD
# we just hope/assume this is gcc and not c89 (= MSVC++)
with_gnu_ld=yes
;;
- openbsd*)
+ openbsd* | secbsd*)
with_gnu_ld=no
;;
esac

View file

@ -1,39 +0,0 @@
Index: sim/m32r/configure
--- sim/m32r/configure.orig
+++ sim/m32r/configure
@@ -6311,7 +6311,7 @@ else
lt_cv_sys_max_cmd_len=8192;
;;
- netbsd* | freebsd* | openbsd* | darwin* | dragonfly*)
+ netbsd* | freebsd* | openbsd* | darwin* | dragonfly* | secbsd*)
# This has been around since 386BSD, at least. Likely further.
if test -x /sbin/sysctl; then
lt_cv_sys_max_cmd_len=`/sbin/sysctl -n kern.argmax`
@@ -6667,7 +6667,7 @@ freebsd* | dragonfly*)
i*86 )
# Not sure whether the presence of OpenBSD here was a mistake.
# Let's accept both of them until this is cleared up.
- lt_cv_deplibs_check_method='file_magic (FreeBSD|OpenBSD|DragonFly)/i[3-9]86 (compact )?demand paged shared library'
+ lt_cv_deplibs_check_method='file_magic (FreeBSD|OpenBSD|DragonFly|SecBSD)/i[3-9]86 (compact )?demand paged shared library'
lt_cv_file_magic_cmd=/usr/bin/file
lt_cv_file_magic_test_file=`echo /usr/lib/libc.so.*`
;;
@@ -7125,7 +7125,7 @@ old_postuninstall_cmds=
if test -n "$RANLIB"; then
case $host_os in
- openbsd*)
+ openbsd* | secbsd*)
old_postinstall_cmds="$old_postinstall_cmds~\$RANLIB -t \$oldlib"
;;
*)
@@ -10518,7 +10518,7 @@ $as_echo_n "checking whether the $compiler linker ($LD
# we just hope/assume this is gcc and not c89 (= MSVC++)
with_gnu_ld=yes
;;
- openbsd*)
+ openbsd* | secbsd*)
with_gnu_ld=no
;;
esac

View file

@ -1,39 +0,0 @@
Index: sim/mn10300/configure
--- sim/mn10300/configure.orig
+++ sim/mn10300/configure
@@ -6312,7 +6312,7 @@ else
lt_cv_sys_max_cmd_len=8192;
;;
- netbsd* | freebsd* | openbsd* | darwin* | dragonfly*)
+ netbsd* | freebsd* | openbsd* | darwin* | dragonfly* | secbsd*)
# This has been around since 386BSD, at least. Likely further.
if test -x /sbin/sysctl; then
lt_cv_sys_max_cmd_len=`/sbin/sysctl -n kern.argmax`
@@ -6668,7 +6668,7 @@ freebsd* | dragonfly*)
i*86 )
# Not sure whether the presence of OpenBSD here was a mistake.
# Let's accept both of them until this is cleared up.
- lt_cv_deplibs_check_method='file_magic (FreeBSD|OpenBSD|DragonFly)/i[3-9]86 (compact )?demand paged shared library'
+ lt_cv_deplibs_check_method='file_magic (FreeBSD|OpenBSD|DragonFly|SecBSD)/i[3-9]86 (compact )?demand paged shared library'
lt_cv_file_magic_cmd=/usr/bin/file
lt_cv_file_magic_test_file=`echo /usr/lib/libc.so.*`
;;
@@ -7126,7 +7126,7 @@ old_postuninstall_cmds=
if test -n "$RANLIB"; then
case $host_os in
- openbsd*)
+ openbsd* | secbsd*)
old_postinstall_cmds="$old_postinstall_cmds~\$RANLIB -t \$oldlib"
;;
*)
@@ -10519,7 +10519,7 @@ $as_echo_n "checking whether the $compiler linker ($LD
# we just hope/assume this is gcc and not c89 (= MSVC++)
with_gnu_ld=yes
;;
- openbsd*)
+ openbsd* | secbsd*)
with_gnu_ld=no
;;
esac

View file

@ -1,39 +0,0 @@
Index: sim/msp430/configure
--- sim/msp430/configure.orig
+++ sim/msp430/configure
@@ -6303,7 +6303,7 @@ else
lt_cv_sys_max_cmd_len=8192;
;;
- netbsd* | freebsd* | openbsd* | darwin* | dragonfly*)
+ netbsd* | freebsd* | openbsd* | darwin* | dragonfly* | secbsd*)
# This has been around since 386BSD, at least. Likely further.
if test -x /sbin/sysctl; then
lt_cv_sys_max_cmd_len=`/sbin/sysctl -n kern.argmax`
@@ -6659,7 +6659,7 @@ freebsd* | dragonfly*)
i*86 )
# Not sure whether the presence of OpenBSD here was a mistake.
# Let's accept both of them until this is cleared up.
- lt_cv_deplibs_check_method='file_magic (FreeBSD|OpenBSD|DragonFly)/i[3-9]86 (compact )?demand paged shared library'
+ lt_cv_deplibs_check_method='file_magic (FreeBSD|OpenBSD|DragonFly|SecBSD)/i[3-9]86 (compact )?demand paged shared library'
lt_cv_file_magic_cmd=/usr/bin/file
lt_cv_file_magic_test_file=`echo /usr/lib/libc.so.*`
;;
@@ -7117,7 +7117,7 @@ old_postuninstall_cmds=
if test -n "$RANLIB"; then
case $host_os in
- openbsd*)
+ openbsd* | secbsd*)
old_postinstall_cmds="$old_postinstall_cmds~\$RANLIB -t \$oldlib"
;;
*)
@@ -10510,7 +10510,7 @@ $as_echo_n "checking whether the $compiler linker ($LD
# we just hope/assume this is gcc and not c89 (= MSVC++)
with_gnu_ld=yes
;;
- openbsd*)
+ openbsd* | secbsd*)
with_gnu_ld=no
;;
esac

View file

@ -1,39 +0,0 @@
Index: sim/pru/configure
--- sim/pru/configure.orig
+++ sim/pru/configure
@@ -6303,7 +6303,7 @@ else
lt_cv_sys_max_cmd_len=8192;
;;
- netbsd* | freebsd* | openbsd* | darwin* | dragonfly*)
+ netbsd* | freebsd* | openbsd* | darwin* | dragonfly* | secbsd*)
# This has been around since 386BSD, at least. Likely further.
if test -x /sbin/sysctl; then
lt_cv_sys_max_cmd_len=`/sbin/sysctl -n kern.argmax`
@@ -6659,7 +6659,7 @@ freebsd* | dragonfly*)
i*86 )
# Not sure whether the presence of OpenBSD here was a mistake.
# Let's accept both of them until this is cleared up.
- lt_cv_deplibs_check_method='file_magic (FreeBSD|OpenBSD|DragonFly)/i[3-9]86 (compact )?demand paged shared library'
+ lt_cv_deplibs_check_method='file_magic (FreeBSD|OpenBSD|DragonFly|SecBSD)/i[3-9]86 (compact )?demand paged shared library'
lt_cv_file_magic_cmd=/usr/bin/file
lt_cv_file_magic_test_file=`echo /usr/lib/libc.so.*`
;;
@@ -7117,7 +7117,7 @@ old_postuninstall_cmds=
if test -n "$RANLIB"; then
case $host_os in
- openbsd*)
+ openbsd* | secbsd*)
old_postinstall_cmds="$old_postinstall_cmds~\$RANLIB -t \$oldlib"
;;
*)
@@ -10510,7 +10510,7 @@ $as_echo_n "checking whether the $compiler linker ($LD
# we just hope/assume this is gcc and not c89 (= MSVC++)
with_gnu_ld=yes
;;
- openbsd*)
+ openbsd* | secbsd*)
with_gnu_ld=no
;;
esac

View file

@ -1,39 +0,0 @@
Index: sim/rx/configure
--- sim/rx/configure.orig
+++ sim/rx/configure
@@ -6293,7 +6293,7 @@ else
lt_cv_sys_max_cmd_len=8192;
;;
- netbsd* | freebsd* | openbsd* | darwin* | dragonfly*)
+ netbsd* | freebsd* | openbsd* | darwin* | dragonfly* | secbsd*)
# This has been around since 386BSD, at least. Likely further.
if test -x /sbin/sysctl; then
lt_cv_sys_max_cmd_len=`/sbin/sysctl -n kern.argmax`
@@ -6649,7 +6649,7 @@ freebsd* | dragonfly*)
i*86 )
# Not sure whether the presence of OpenBSD here was a mistake.
# Let's accept both of them until this is cleared up.
- lt_cv_deplibs_check_method='file_magic (FreeBSD|OpenBSD|DragonFly)/i[3-9]86 (compact )?demand paged shared library'
+ lt_cv_deplibs_check_method='file_magic (FreeBSD|OpenBSD|DragonFly|SecBSD)/i[3-9]86 (compact )?demand paged shared library'
lt_cv_file_magic_cmd=/usr/bin/file
lt_cv_file_magic_test_file=`echo /usr/lib/libc.so.*`
;;
@@ -7107,7 +7107,7 @@ old_postuninstall_cmds=
if test -n "$RANLIB"; then
case $host_os in
- openbsd*)
+ openbsd* | secbsd*)
old_postinstall_cmds="$old_postinstall_cmds~\$RANLIB -t \$oldlib"
;;
*)
@@ -10500,7 +10500,7 @@ $as_echo_n "checking whether the $compiler linker ($LD
# we just hope/assume this is gcc and not c89 (= MSVC++)
with_gnu_ld=yes
;;
- openbsd*)
+ openbsd* | secbsd*)
with_gnu_ld=no
;;
esac

View file

@ -1,39 +0,0 @@
Index: zlib/configure
--- zlib/configure.orig
+++ zlib/configure
@@ -4903,7 +4903,7 @@ else
lt_cv_sys_max_cmd_len=8192;
;;
- netbsd* | freebsd* | openbsd* | darwin* | dragonfly*)
+ netbsd* | freebsd* | openbsd* | darwin* | dragonfly* | secbsd*)
# This has been around since 386BSD, at least. Likely further.
if test -x /sbin/sysctl; then
lt_cv_sys_max_cmd_len=`/sbin/sysctl -n kern.argmax`
@@ -5259,7 +5259,7 @@ freebsd* | dragonfly*)
i*86 )
# Not sure whether the presence of OpenBSD here was a mistake.
# Let's accept both of them until this is cleared up.
- lt_cv_deplibs_check_method='file_magic (FreeBSD|OpenBSD|DragonFly)/i[3-9]86 (compact )?demand paged shared library'
+ lt_cv_deplibs_check_method='file_magic (FreeBSD|OpenBSD|DragonFly|SecBSD)/i[3-9]86 (compact )?demand paged shared library'
lt_cv_file_magic_cmd=/usr/bin/file
lt_cv_file_magic_test_file=`echo /usr/lib/libc.so.*`
;;
@@ -5717,7 +5717,7 @@ old_postuninstall_cmds=
if test -n "$RANLIB"; then
case $host_os in
- openbsd*)
+ openbsd* | secbsd*)
old_postinstall_cmds="$old_postinstall_cmds~\$RANLIB -t \$oldlib"
;;
*)
@@ -8248,7 +8248,7 @@ $as_echo_n "checking whether the $compiler linker ($LD
# we just hope/assume this is gcc and not c89 (= MSVC++)
with_gnu_ld=yes
;;
- openbsd*)
+ openbsd* | secbsd*)
with_gnu_ld=no
;;
esac

View file

@ -35,25 +35,42 @@ share/gdb/python/gdb/FrameDecorator.py
share/gdb/python/gdb/FrameIterator.py
share/gdb/python/gdb/__init__.py
${MODPY_COMMENT}share/gdb/python/gdb/${MODPY_PYCACHE}/
share/gdb/python/gdb/${MODPY_PYCACHE}FrameDecorator.${MODPY_PYC_MAGIC_TAG}${MODPY_PYOEXTENSION}
share/gdb/python/gdb/${MODPY_PYCACHE}FrameDecorator.${MODPY_PYC_MAGIC_TAG}pyc
share/gdb/python/gdb/${MODPY_PYCACHE}FrameIterator.${MODPY_PYC_MAGIC_TAG}${MODPY_PYOEXTENSION}
share/gdb/python/gdb/${MODPY_PYCACHE}FrameIterator.${MODPY_PYC_MAGIC_TAG}pyc
share/gdb/python/gdb/${MODPY_PYCACHE}__init__.${MODPY_PYC_MAGIC_TAG}${MODPY_PYOEXTENSION}
share/gdb/python/gdb/${MODPY_PYCACHE}__init__.${MODPY_PYC_MAGIC_TAG}pyc
share/gdb/python/gdb/${MODPY_PYCACHE}frames.${MODPY_PYC_MAGIC_TAG}${MODPY_PYOEXTENSION}
share/gdb/python/gdb/${MODPY_PYCACHE}frames.${MODPY_PYC_MAGIC_TAG}pyc
share/gdb/python/gdb/${MODPY_PYCACHE}printing.${MODPY_PYC_MAGIC_TAG}${MODPY_PYOEXTENSION}
share/gdb/python/gdb/${MODPY_PYCACHE}printing.${MODPY_PYC_MAGIC_TAG}pyc
share/gdb/python/gdb/${MODPY_PYCACHE}prompt.${MODPY_PYC_MAGIC_TAG}${MODPY_PYOEXTENSION}
share/gdb/python/gdb/${MODPY_PYCACHE}prompt.${MODPY_PYC_MAGIC_TAG}pyc
share/gdb/python/gdb/${MODPY_PYCACHE}types.${MODPY_PYC_MAGIC_TAG}${MODPY_PYOEXTENSION}
share/gdb/python/gdb/${MODPY_PYCACHE}types.${MODPY_PYC_MAGIC_TAG}pyc
share/gdb/python/gdb/${MODPY_PYCACHE}unwinder.${MODPY_PYC_MAGIC_TAG}${MODPY_PYOEXTENSION}
share/gdb/python/gdb/${MODPY_PYCACHE}unwinder.${MODPY_PYC_MAGIC_TAG}pyc
share/gdb/python/gdb/${MODPY_PYCACHE}xmethod.${MODPY_PYC_MAGIC_TAG}${MODPY_PYOEXTENSION}
share/gdb/python/gdb/${MODPY_PYCACHE}xmethod.${MODPY_PYC_MAGIC_TAG}pyc
share/gdb/python/gdb/command/
share/gdb/python/gdb/command/__init__.py
${MODPY_COMMENT}share/gdb/python/gdb/command/${MODPY_PYCACHE}/
share/gdb/python/gdb/command/${MODPY_PYCACHE}__init__.${MODPY_PYC_MAGIC_TAG}${MODPY_PYOEXTENSION}
share/gdb/python/gdb/command/${MODPY_PYCACHE}__init__.${MODPY_PYC_MAGIC_TAG}pyc
share/gdb/python/gdb/command/${MODPY_PYCACHE}explore.${MODPY_PYC_MAGIC_TAG}${MODPY_PYOEXTENSION}
share/gdb/python/gdb/command/${MODPY_PYCACHE}explore.${MODPY_PYC_MAGIC_TAG}pyc
share/gdb/python/gdb/command/${MODPY_PYCACHE}frame_filters.${MODPY_PYC_MAGIC_TAG}${MODPY_PYOEXTENSION}
share/gdb/python/gdb/command/${MODPY_PYCACHE}frame_filters.${MODPY_PYC_MAGIC_TAG}pyc
share/gdb/python/gdb/command/${MODPY_PYCACHE}pretty_printers.${MODPY_PYC_MAGIC_TAG}${MODPY_PYOEXTENSION}
share/gdb/python/gdb/command/${MODPY_PYCACHE}pretty_printers.${MODPY_PYC_MAGIC_TAG}pyc
share/gdb/python/gdb/command/${MODPY_PYCACHE}prompt.${MODPY_PYC_MAGIC_TAG}${MODPY_PYOEXTENSION}
share/gdb/python/gdb/command/${MODPY_PYCACHE}prompt.${MODPY_PYC_MAGIC_TAG}pyc
share/gdb/python/gdb/command/${MODPY_PYCACHE}type_printers.${MODPY_PYC_MAGIC_TAG}${MODPY_PYOEXTENSION}
share/gdb/python/gdb/command/${MODPY_PYCACHE}type_printers.${MODPY_PYC_MAGIC_TAG}pyc
share/gdb/python/gdb/command/${MODPY_PYCACHE}unwinders.${MODPY_PYC_MAGIC_TAG}${MODPY_PYOEXTENSION}
share/gdb/python/gdb/command/${MODPY_PYCACHE}unwinders.${MODPY_PYC_MAGIC_TAG}pyc
share/gdb/python/gdb/command/${MODPY_PYCACHE}xmethods.${MODPY_PYC_MAGIC_TAG}${MODPY_PYOEXTENSION}
share/gdb/python/gdb/command/${MODPY_PYCACHE}xmethods.${MODPY_PYC_MAGIC_TAG}pyc
share/gdb/python/gdb/command/explore.py
share/gdb/python/gdb/command/frame_filters.py
@ -66,9 +83,13 @@ share/gdb/python/gdb/frames.py
share/gdb/python/gdb/function/
share/gdb/python/gdb/function/__init__.py
${MODPY_COMMENT}share/gdb/python/gdb/function/${MODPY_PYCACHE}/
share/gdb/python/gdb/function/${MODPY_PYCACHE}__init__.${MODPY_PYC_MAGIC_TAG}${MODPY_PYOEXTENSION}
share/gdb/python/gdb/function/${MODPY_PYCACHE}__init__.${MODPY_PYC_MAGIC_TAG}pyc
share/gdb/python/gdb/function/${MODPY_PYCACHE}as_string.${MODPY_PYC_MAGIC_TAG}${MODPY_PYOEXTENSION}
share/gdb/python/gdb/function/${MODPY_PYCACHE}as_string.${MODPY_PYC_MAGIC_TAG}pyc
share/gdb/python/gdb/function/${MODPY_PYCACHE}caller_is.${MODPY_PYC_MAGIC_TAG}${MODPY_PYOEXTENSION}
share/gdb/python/gdb/function/${MODPY_PYCACHE}caller_is.${MODPY_PYC_MAGIC_TAG}pyc
share/gdb/python/gdb/function/${MODPY_PYCACHE}strfns.${MODPY_PYC_MAGIC_TAG}${MODPY_PYOEXTENSION}
share/gdb/python/gdb/function/${MODPY_PYCACHE}strfns.${MODPY_PYC_MAGIC_TAG}pyc
share/gdb/python/gdb/function/as_string.py
share/gdb/python/gdb/function/caller_is.py
@ -76,7 +97,9 @@ share/gdb/python/gdb/function/strfns.py
share/gdb/python/gdb/printer/
share/gdb/python/gdb/printer/__init__.py
${MODPY_COMMENT}share/gdb/python/gdb/printer/${MODPY_PYCACHE}/
share/gdb/python/gdb/printer/${MODPY_PYCACHE}__init__.${MODPY_PYC_MAGIC_TAG}${MODPY_PYOEXTENSION}
share/gdb/python/gdb/printer/${MODPY_PYCACHE}__init__.${MODPY_PYC_MAGIC_TAG}pyc
share/gdb/python/gdb/printer/${MODPY_PYCACHE}bound_registers.${MODPY_PYC_MAGIC_TAG}${MODPY_PYOEXTENSION}
share/gdb/python/gdb/printer/${MODPY_PYCACHE}bound_registers.${MODPY_PYC_MAGIC_TAG}pyc
share/gdb/python/gdb/printer/bound_registers.py
share/gdb/python/gdb/printing.py