UPDATE: lang/go 1.23.1 -> 1.23.3

This commit is contained in:
purplerain 2025-01-15 01:40:21 +00:00
parent 59d9755966
commit cfe8a6e765
Signed by: purplerain
GPG key ID: F42C07F07E2E35B7
6 changed files with 24 additions and 8 deletions

View file

@ -7,7 +7,7 @@ COMMENT = Go programming language
# increment _MODGO_SYSTEM_VERSION in go.port.mk after updating to a new
# version, to trigger updates of go-compiled ports
VERSION = 1.23.1
VERSION = 1.23.3
DISTNAME = go${VERSION}.src
PKGNAME = go-${VERSION}
PKGSPEC = ${FULLPKGNAME:S/go-/go-=/}

View file

@ -3,10 +3,10 @@ SHA256 (go-openbsd-amd64-bootstrap-1.22.5.tar.gz) = vFJP02dfZ2hBhlBtyKwXeoUSKTsz
SHA256 (go-openbsd-arm-bootstrap-1.22.5.tar.gz) = hd5uX+7C1KPYDhhh3GjexRShYcZR6qOVNmmr7nrINmE=
SHA256 (go-openbsd-arm64-bootstrap-1.22.5.tar.gz) = jfRynOQVoniG2ZvzZgHExVUEzKFOlfEWPEW43/NaZtQ=
SHA256 (go-openbsd-riscv64-bootstrap-1.22.5.tar.gz) = 7uKbM7V/XPXVfeJMdEDG57hzhoao5hv1vzpsal+YPiw=
SHA256 (go1.23.1.src.tar.gz) = buROKYN50Ual5aprHFtdX10KM2XqvdcHQebiE0DsOw0=
SHA256 (go1.23.3.src.tar.gz) = jWp3MySHVXxq+iQhExtQ+D20rjxXnDvHLmcO4faWhZk=
SIZE (go-openbsd-386-bootstrap-1.22.5.tar.gz) = 69567775
SIZE (go-openbsd-amd64-bootstrap-1.22.5.tar.gz) = 79553441
SIZE (go-openbsd-arm-bootstrap-1.22.5.tar.gz) = 77558960
SIZE (go-openbsd-arm64-bootstrap-1.22.5.tar.gz) = 76871926
SIZE (go-openbsd-riscv64-bootstrap-1.22.5.tar.gz) = 77931440
SIZE (go1.23.1.src.tar.gz) = 28164249
SIZE (go1.23.3.src.tar.gz) = 28173788

View file

@ -1,6 +1,6 @@
# increment after a go compiler update to trigger updates of
# compiled go packages (see arch-defines.mk)
_MODGO_SYSTEM_VERSION = 18
_MODGO_SYSTEM_VERSION = 19
ONLY_FOR_ARCHS ?= ${GO_ARCHS}
@ -10,7 +10,7 @@ MODGO_DIST_SUBDIR ?= go_modules
SITE_ATHENS = https://proxy.golang.org/
SITES.go ?= ${SITE_ATHENS}
SITES.go ?= ${SITE_ATHENS}
MODGO_RUN_DEPENDS = lang/go
MODGO_BUILD_DEPENDS = lang/go
@ -47,7 +47,7 @@ MODGO_TYPE ?= bin
MODGO_WORKSPACE ?= ${WRKDIR}/go
MODGO_GOCACHE ?= ${WRKDIR}/go-cache
MODGO_GOPATH ?= ${MODGO_WORKSPACE}:${MODGO_PACKAGE_PATH}
# We cannot assume that the maching running the built code will have SSE,
# We cannot assume that the machine running the built code will have SSE,
# even though the machine building the package has SSE. As such, we need
# to explicitly disable SSE on i386 builds.
MAKE_ENV += GO386=softfloat

View file

@ -1,7 +1,7 @@
Index: src/cmd/link/internal/ld/elf.go
--- src/cmd/link/internal/ld/elf.go.orig
+++ src/cmd/link/internal/ld/elf.go
@@ -2185,7 +2185,7 @@ func asmbElf(ctxt *Link) {
@@ -2193,7 +2193,7 @@ func asmbElf(ctxt *Link) {
ph.Type = elf.PT_GNU_STACK
ph.Flags = elf.PF_W + elf.PF_R
ph.Align = uint64(ctxt.Arch.RegSize)

View file

@ -0,0 +1,12 @@
Index: src/time/time_test.go
--- src/time/time_test.go.orig
+++ src/time/time_test.go
@@ -1085,7 +1085,7 @@ func TestLoadFixed(t *testing.T) {
name, offset := Now().In(loc).Zone()
// The zone abbreviation is "-01" since tzdata-2016g, and "GMT+1"
// on earlier versions; we accept both. (Issue #17276).
- if !(name == "GMT+1" || name == "-01") || offset != -1*60*60 {
+ if !(name == "GMT+1" || name == "-01" || name == "+01") || offset != -1*60*60 {
t.Errorf("Now().In(loc).Zone() = %q, %d, want %q or %q, %d",
name, offset, "GMT+1", "-01", -1*60*60)
}

View file

@ -5713,7 +5713,7 @@ go/src/debug/elf/testdata/compressed-32.obj
go/src/debug/elf/testdata/compressed-64.obj
go/src/debug/elf/testdata/gcc-386-freebsd-exec
go/src/debug/elf/testdata/gcc-amd64-linux-exec
go/src/debug/elf/testdata/gcc-amd64-openbsd-debug-with-rela.obj
go/src/debug/elf/testdata/gcc-${MACHINE_ARCH}-openbsd-debug-with-rela.obj
go/src/debug/elf/testdata/go-relocation-test-clang-arm.obj
go/src/debug/elf/testdata/go-relocation-test-clang-x86.obj
go/src/debug/elf/testdata/go-relocation-test-gcc424-x86-64.obj
@ -8831,6 +8831,7 @@ go/src/net/write_unix_test.go
go/src/net/writev_test.go
go/src/net/writev_unix.go
go/src/os/
go/src/os/copy_test.go
go/src/os/dir.go
go/src/os/dir_darwin.go
go/src/os/dir_plan9.go
@ -13693,6 +13694,9 @@ go/test/fixedbugs/issue6889.go
go/test/fixedbugs/issue6899.go
go/test/fixedbugs/issue6899.out
go/test/fixedbugs/issue6902.go
go/test/fixedbugs/issue69110.go
go/test/fixedbugs/issue69434.go
go/test/fixedbugs/issue69507.go
go/test/fixedbugs/issue6964.go
go/test/fixedbugs/issue6977.go
go/test/fixedbugs/issue7023.dir/