sync ports with The Matrix
This commit is contained in:
parent
7382e22420
commit
c56ca4657c
6 changed files with 0 additions and 78 deletions
|
@ -1,36 +0,0 @@
|
|||
COMMENT= google maps API scanner
|
||||
|
||||
MODPY_EGG_VERSION= 0.1
|
||||
GH_COMMIT= 0b305fc2d62150c56d3d383d36a04ff1c181964c
|
||||
GH_ACCOUNT= ozguralp
|
||||
GH_PROJECT= gmapsapiscanner
|
||||
|
||||
DISTNAME= ${GH_PROJECT}-${MODPY_EGG_VERSION}
|
||||
|
||||
CATEGORIES= security
|
||||
|
||||
HOMEPAGE= https://github.com/ozguralp/gmapsapiscanner
|
||||
|
||||
MAINTAINER= Purple Rain <purplerain@secbsd.org>
|
||||
|
||||
# MIT
|
||||
PERMIT_PACKAGE= Yes
|
||||
|
||||
MODULES= lang/python
|
||||
|
||||
RUN_DEPENDS= www/py-requests${MODPY_FLAVOR}
|
||||
|
||||
NO_BUILD= Yes
|
||||
|
||||
INSTDIR= ${PREFIX}/share/gmapsapiscanner
|
||||
|
||||
do-install:
|
||||
cp -r ${WRKDIST} ${INSTDIR}
|
||||
chmod 755 ${INSTDIR}/maps_api_scanner_python3.py
|
||||
ln -s ${TRUEPREFIX}/share/gmapsapiscanner/maps_api_scanner_python3.py \
|
||||
${PREFIX}/bin/gmapsapiscanner
|
||||
|
||||
post-install:
|
||||
rm -rf ${INSTDIR}/maps_api_scanner.py
|
||||
|
||||
.include <bsd.port.mk>
|
|
@ -1,2 +0,0 @@
|
|||
SHA256 (gmapsapiscanner-0.1-0b305fc2.tar.gz) = N7bKCvTEqaeZ1hHIfua7Os35FM3qyf1aOgTcxJ0GRRk=
|
||||
SIZE (gmapsapiscanner-0.1-0b305fc2.tar.gz) = 6776
|
|
@ -1,29 +0,0 @@
|
|||
$OpenBSD$
|
||||
|
||||
Index: maps_api_scanner_python3.py
|
||||
--- maps_api_scanner_python3.py.orig
|
||||
+++ maps_api_scanner_python3.py
|
||||
@@ -1,3 +1,5 @@
|
||||
+#!/usr/bin/env python3
|
||||
+
|
||||
import requests
|
||||
import warnings
|
||||
import json
|
||||
@@ -265,12 +267,12 @@ if len(sys.argv) > 1:
|
||||
scan_gmaps(sys.argv[2])
|
||||
else:
|
||||
print("Missing api key, aborting.")
|
||||
- print("Either use --api-key as argument such \"python maps_api_scanner.py --api-key KEY\" or directly run script as \"python maps_api_scanner.py\" and supply API key via input.")
|
||||
+ print("usage: $ gmapsapiscanner --api-key KEY")
|
||||
elif sys.argv[1] == "--help" or sys.argv[1] == "-h":
|
||||
- print("Either use --api-key as argument such \"python maps_api_scanner.py --api-key KEY\" or directly run script as \"python maps_api_scanner.py\" and supply API key via input.")
|
||||
+ print("usage: $ gmapsapiscanner --api-key KEY")
|
||||
else:
|
||||
print("Invalid arguments, aborting.")
|
||||
- print("Either use --api-key as argument such \"python maps_api_scanner.py --api-key KEY\" or directly run script as \"python maps_api_scanner.py\" and supply API key via input.")
|
||||
+ print("usage: $ gmapsapiscanner --api-key KEY")
|
||||
else:
|
||||
apikey = input("Please enter the Google Maps API key you wanted to test: ")
|
||||
- scan_gmaps(apikey)
|
||||
\ No newline at end of file
|
||||
+ scan_gmaps(apikey)
|
|
@ -1,2 +0,0 @@
|
|||
Used for determining whether a leaked/found Google Maps API Key
|
||||
is vulnerable to unauthorized access by other applications or not.
|
|
@ -1,3 +0,0 @@
|
|||
How to use:
|
||||
|
||||
$ gmapsapiscanner
|
|
@ -1,6 +0,0 @@
|
|||
bin/gmapsapiscanner
|
||||
share/gmapsapiscanner/
|
||||
share/gmapsapiscanner/Dockerfile
|
||||
share/gmapsapiscanner/LICENSE
|
||||
share/gmapsapiscanner/README.md
|
||||
share/gmapsapiscanner/maps_api_scanner_python3.py
|
Loading…
Add table
Add a link
Reference in a new issue