sync ports with The Matrix
This commit is contained in:
parent
c376d85ea0
commit
b6c01378e8
89 changed files with 898 additions and 818 deletions
|
@ -13,7 +13,7 @@ Index: configure.ac
|
|||
])dnl
|
||||
dnl
|
||||
define(AC_NOTE,
|
||||
@@ -362,7 +362,7 @@ main()
|
||||
@@ -385,7 +385,7 @@ int main()
|
||||
], AC_NOTE(- your fifos are usable) fifo=1,
|
||||
AC_NOTE(- your fifos are not usable),
|
||||
AC_NOTE(- skipping check because we are cross compiling; assuming fifos are usable) fifo=1)
|
||||
|
@ -22,7 +22,7 @@ Index: configure.ac
|
|||
|
||||
if test -n "$fifo"; then
|
||||
AC_CHECKING(for broken fifo implementation)
|
||||
@@ -411,7 +411,7 @@ main()
|
||||
@@ -436,7 +436,7 @@ main()
|
||||
], AC_NOTE(- your implementation is ok),
|
||||
AC_NOTE(- you have a broken implementation) AC_DEFINE(BROKEN_PIPE) fifobr=1,
|
||||
AC_NOTE(- skipping check because we are cross compiling; assuming fifo implementation is ok))
|
||||
|
@ -31,7 +31,7 @@ Index: configure.ac
|
|||
fi
|
||||
|
||||
dnl
|
||||
@@ -474,7 +474,7 @@ main()
|
||||
@@ -503,7 +503,7 @@ main()
|
||||
], AC_NOTE(- your sockets are usable) sock=1,
|
||||
AC_NOTE(- your sockets are not usable),
|
||||
AC_NOTE(- skipping check because we are cross compiling; assuming sockets are usable) sock=1)
|
||||
|
@ -40,7 +40,7 @@ Index: configure.ac
|
|||
|
||||
if test -n "$sock"; then
|
||||
AC_CHECKING(socket implementation)
|
||||
@@ -514,7 +514,7 @@ main()
|
||||
@@ -546,7 +546,7 @@ main()
|
||||
AC_NOTE(- unix domain sockets are not kept in the filesystem)
|
||||
AC_DEFINE(SOCK_NOT_IN_FS) socknofs=1,
|
||||
AC_NOTE(- skipping check because we are cross compiling; assuming sockets are normal))
|
||||
|
@ -49,11 +49,3 @@ Index: configure.ac
|
|||
fi
|
||||
|
||||
|
||||
@@ -619,6 +619,7 @@ main()
|
||||
],AC_NOTE(- select is ok),
|
||||
AC_NOTE(- select can't count) AC_DEFINE(SELECT_BROKEN),
|
||||
AC_NOTE(- skipping check because we are cross compiling; assuming select is ok))
|
||||
+rm -f /tmp/conftest$$
|
||||
|
||||
dnl
|
||||
dnl **** termcap or terminfo ****
|
||||
|
|
Loading…
Add table
Add a link
Reference in a new issue