sync ports with The Matrix
This commit is contained in:
parent
c376d85ea0
commit
b6c01378e8
89 changed files with 898 additions and 818 deletions
|
@ -1,9 +1,9 @@
|
|||
COMMENT= Tcl interface to PostgreSQL
|
||||
|
||||
V= 1.7
|
||||
DISTNAME= libpgtcl-$V
|
||||
PKGNAME= pgtcl-$V
|
||||
REVISION= 1
|
||||
GH_ACCOUNT= flightaware
|
||||
GH_PROJECT= Pgtcl
|
||||
GH_TAGNAME= v3.0.0
|
||||
PKGNAME= ${DISTNAME:L}
|
||||
CATEGORIES= databases
|
||||
|
||||
HOMEPAGE= https://flightaware.github.io/Pgtcl/
|
||||
|
@ -13,33 +13,38 @@ MAINTAINER= Stuart Cassoff <stwo@users.sourceforge.net>
|
|||
# BSD
|
||||
PERMIT_PACKAGE= Yes
|
||||
|
||||
PORTROACH= site:https://github.com/flightaware/Pgtcl/archive/
|
||||
MASTER_SITES= https://ftp.postgresql.org/pub/projects/pgFoundry/pgtcl/pgtcl/$V/
|
||||
|
||||
MODULES= lang/tcl
|
||||
|
||||
LIB_DEPENDS= databases/postgresql
|
||||
LIB_DEPENDS= databases/postgresql \
|
||||
databases/sqlite3
|
||||
RUN_DEPENDS= ${MODTCL_RUN_DEPENDS}
|
||||
BUILD_DEPENDS= ${MODTCL_BUILD_DEPENDS}
|
||||
WANTLIB += pq>=5 ${MODTCL_WANTLIB}
|
||||
WANTLIB += pq>=5 sqlite3
|
||||
|
||||
CONFIGURE_STYLE= gnu
|
||||
CONFIGURE_STYLE= autoreconf
|
||||
CONFIGURE_ARGS= --with-tcl=${MODTCL_LIBDIR} \
|
||||
--libdir=${MODTCL_TCLDIR} \
|
||||
--with-postgres-include=${LOCALBASE}/include/postgresql \
|
||||
--with-postgres-lib=${LOCALBASE}/lib \
|
||||
--disable-threads
|
||||
|
||||
# fix sqlite detection
|
||||
CONFIGURE_ARGS+=CFLAGS="${CFLAGS} -I${LOCALBASE}/include" \
|
||||
LDFLAGS="-L${LOCALBASE}/lib"
|
||||
|
||||
# the configure needs to be adapted for 2.71
|
||||
AUTOCONF_VERSION=2.69
|
||||
AUTOMAKE_VERSION=1.16
|
||||
|
||||
FAKE_FLAGS = PKG_DIR='$$(PACKAGE_NAME)' INSTALL_PROGRAM='$$(INSTALL_DATA)' \
|
||||
PKG_HEADERS='' PKG_TCL_SOURCES=''
|
||||
|
||||
NO_TEST= Yes
|
||||
ALL_TARGET = binaries libraries
|
||||
INSTALL_TARGET =install-binaries install-libraries
|
||||
SEPARATE_BUILD =Yes
|
||||
SUBST_VARS = VER
|
||||
|
||||
VER = ${V:S/.//g}
|
||||
# upstream forgot to update the version number in configure.in
|
||||
# after tagging 3.0.0?
|
||||
VER = 277
|
||||
|
||||
post-install:
|
||||
${INSTALL_DATA_DIR} ${PREFIX}/share/doc/pgtcl/html
|
||||
|
|
|
@ -1,2 +1,2 @@
|
|||
SHA256 (libpgtcl-1.7.tar.gz) = COmhSWGxs9mFgpq+VvMHpoOAFzvSEnHMwWtfEu2wsuw=
|
||||
SIZE (libpgtcl-1.7.tar.gz) = 497868
|
||||
SHA256 (Pgtcl-3.0.0.tar.gz) = i6SRRBDv8o6upuf0M06mmfY0dGFcBHoxtTqPqE+iMqc=
|
||||
SIZE (Pgtcl-3.0.0.tar.gz) = 642965
|
||||
|
|
|
@ -1,20 +0,0 @@
|
|||
--- configure.orig Mon Apr 30 20:54:06 2012
|
||||
+++ configure Mon Apr 30 20:59:24 2012
|
||||
@@ -7826,7 +7826,7 @@ fi
|
||||
|
||||
# TEA specific:
|
||||
CFLAGS_OPTIMIZE=-O2
|
||||
- CFLAGS_WARNING="-Wall -Wno-implicit-int"
|
||||
+ CFLAGS_WARNING="-Wall"
|
||||
|
||||
else
|
||||
CFLAGS_WARNING=""
|
||||
@@ -9006,7 +9006,7 @@ fi
|
||||
fi
|
||||
|
||||
LD_SEARCH_FLAGS=${CC_SEARCH_FLAGS}
|
||||
- SHARED_LIB_SUFFIX='${TCL_TRIM_DOTS}.so.1.0'
|
||||
+ SHARED_LIB_SUFFIX='${TCL_TRIM_DOTS}.so'
|
||||
{ echo "$as_me:$LINENO: checking for ELF" >&5
|
||||
echo $ECHO_N "checking for ELF... $ECHO_C" >&6; }
|
||||
if test "${tcl_cv_ld_elf+set}" = set; then
|
|
@ -1,8 +1,46 @@
|
|||
@so lib/tcl/libpgtcl${VER}.so
|
||||
lib/tcl/pgtcl/
|
||||
lib/tcl/pgtcl/libpgtcl${VER}.so
|
||||
@so lib/tcl/pgtcl/libpgtcl${VER}.so
|
||||
lib/tcl/pgtcl/pkgIndex.tcl
|
||||
@man man/mann/PgGetConnectionId.n
|
||||
@man man/mann/pg_blocking.n
|
||||
@man man/mann/pg_cancelrequest.n
|
||||
@man man/mann/pg_conndefaults.n
|
||||
@man man/mann/pg_connect.n
|
||||
@man man/mann/pg_copy_complete.n
|
||||
@man man/mann/pg_dbinfo.n
|
||||
@man man/mann/pg_disconnect.n
|
||||
@man man/mann/pg_escape_bytea.n
|
||||
@man man/mann/pg_escape_string.n
|
||||
@man man/mann/pg_exec.n
|
||||
@man man/mann/pg_exec_prepared.n
|
||||
@man man/mann/pg_execute.n
|
||||
@man man/mann/pg_getresult.n
|
||||
@man man/mann/pg_isbusy.n
|
||||
@man man/mann/pg_listen.n
|
||||
@man man/mann/pg_lo_close.n
|
||||
@man man/mann/pg_lo_creat.n
|
||||
@man man/mann/pg_lo_export.n
|
||||
@man man/mann/pg_lo_import.n
|
||||
@man man/mann/pg_lo_lseek.n
|
||||
@man man/mann/pg_lo_open.n
|
||||
@man man/mann/pg_lo_read.n
|
||||
@man man/mann/pg_lo_tell.n
|
||||
@man man/mann/pg_lo_truncate.n
|
||||
@man man/mann/pg_lo_unlink.n
|
||||
@man man/mann/pg_lo_write.n
|
||||
@man man/mann/pg_null_value_string.n
|
||||
@man man/mann/pg_on_connection_loss.n
|
||||
@man man/mann/pg_quote.n
|
||||
@man man/mann/pg_result.n
|
||||
@man man/mann/pg_select.n
|
||||
@man man/mann/pg_sendquery.n
|
||||
@man man/mann/pg_sendquery_prepared.n
|
||||
@man man/mann/pg_sqlite.n
|
||||
@man man/mann/pg_unescape_bytea.n
|
||||
share/doc/pgtcl/
|
||||
share/doc/pgtcl/html/
|
||||
share/doc/pgtcl/html/HTML.index
|
||||
share/doc/pgtcl/html/index.html
|
||||
share/doc/pgtcl/html/libpgtcl-loading.html
|
||||
share/doc/pgtcl/html/libpgtcl-ref.html
|
||||
|
@ -15,12 +53,14 @@ share/doc/pgtcl/html/pgtcl-pgcancelrequest.html
|
|||
share/doc/pgtcl/html/pgtcl-pgconndefaults.html
|
||||
share/doc/pgtcl/html/pgtcl-pgconnect.html
|
||||
share/doc/pgtcl/html/pgtcl-pgconninfo.html
|
||||
share/doc/pgtcl/html/pgtcl-pgcopycomplete.html
|
||||
share/doc/pgtcl/html/pgtcl-pgdisconnect.html
|
||||
share/doc/pgtcl/html/pgtcl-pgescape-bytea.html
|
||||
share/doc/pgtcl/html/pgtcl-pgescape-string.html
|
||||
share/doc/pgtcl/html/pgtcl-pgexec.html
|
||||
share/doc/pgtcl/html/pgtcl-pgexecprepared.html
|
||||
share/doc/pgtcl/html/pgtcl-pgexecute.html
|
||||
share/doc/pgtcl/html/pgtcl-pggetconnectionid.html
|
||||
share/doc/pgtcl/html/pgtcl-pggetresult.html
|
||||
share/doc/pgtcl/html/pgtcl-pgisbusy.html
|
||||
share/doc/pgtcl/html/pgtcl-pglisten.html
|
||||
|
@ -39,6 +79,8 @@ share/doc/pgtcl/html/pgtcl-pgresult.html
|
|||
share/doc/pgtcl/html/pgtcl-pgselect.html
|
||||
share/doc/pgtcl/html/pgtcl-pgsendquery.html
|
||||
share/doc/pgtcl/html/pgtcl-pgsendqueryprepared.html
|
||||
share/doc/pgtcl/html/pgtcl-pgsqlite.html
|
||||
share/doc/pgtcl/html/pgtcl-pgtruncate.html
|
||||
share/doc/pgtcl/html/pgtcl-pgunescape-bytea.html
|
||||
share/doc/pgtcl/html/pgtcl-quote.html
|
||||
share/doc/pgtcl/html/pgtcl-tclnamespace.html
|
||||
|
|
Loading…
Add table
Add a link
Reference in a new issue