sync ports with The Matrix

This commit is contained in:
purplerain 2023-09-17 04:05:06 +00:00
parent 02776f1507
commit a0fe1892c0
Signed by: purplerain
GPG key ID: F42C07F07E2E35B7
885 changed files with 6817 additions and 4874 deletions

View file

@ -0,0 +1,14 @@
https://github.com/protobuf-c/protobuf-c/pull/673
Index: build-cmake/CMakeLists.txt
--- build-cmake/CMakeLists.txt.orig
+++ build-cmake/CMakeLists.txt
@@ -88,7 +88,7 @@ if (MSVC AND NOT BUILD_SHARED_LIBS)
endif (MSVC AND NOT BUILD_SHARED_LIBS)
IF(BUILD_PROTOC)
-SET(CMAKE_CXX_STANDARD 11)
+SET(CMAKE_CXX_STANDARD 17)
SET(CMAKE_CXX_STANDARD_REQUIRED ON)
SET(CMAKE_CXX_EXTENSIONS OFF)
ADD_CUSTOM_COMMAND(OUTPUT protobuf-c/protobuf-c.pb.cc protobuf-c/protobuf-c.pb.h