As we discussed in the last meeting, we reset the ports tree and began from scratch, even though this change involves porting all the packages. Starting small and growing gradually, this approach will reduce build times and consequently lower energy consumption in a world affected by climate change. We will add new ports as users needs arise; ok h3artbl33d@
This commit is contained in:
parent
83a0aaf92c
commit
9a3af55370
59377 changed files with 98673 additions and 4712155 deletions
|
@ -19,8 +19,6 @@ SITES= https://github.com/skvadrik/re2c/releases/download/$V/
|
|||
|
||||
TEST_DEPENDS= shells/bash
|
||||
|
||||
MODGNU_CONFIG_GUESS_DIRS=${WRKSRC} ${WRKSRC}/build-aux
|
||||
|
||||
CONFIGURE_STYLE= gnu
|
||||
|
||||
# re2c will use bison if present at build time, but will otherwise fallback
|
||||
|
@ -33,4 +31,6 @@ CONFIGURE_ENV= ac_cv_path_BISON=no
|
|||
# a normal build from the tarball
|
||||
CONFIGURE_ENV+= am_cv_pathless_PYTHON=python3
|
||||
|
||||
MODGNU_CONFIG_GUESS_DIRS= ${WRKSRC} ${WRKSRC}/build-aux
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
|
30
devel/re2c/patches/patch-build-aux_ltmain_sh
Normal file
30
devel/re2c/patches/patch-build-aux_ltmain_sh
Normal file
|
@ -0,0 +1,30 @@
|
|||
Index: build-aux/ltmain.sh
|
||||
--- build-aux/ltmain.sh.orig
|
||||
+++ build-aux/ltmain.sh
|
||||
@@ -7283,7 +7283,7 @@ func_mode_link ()
|
||||
# These systems don't actually have a C library (as such)
|
||||
test X-lc = "X$arg" && continue
|
||||
;;
|
||||
- *-*-openbsd* | *-*-freebsd* | *-*-dragonfly* | *-*-bitrig* | *-*-midnightbsd*)
|
||||
+ *-*-openbsd* | *-*-freebsd* | *-*-dragonfly* | *-*-bitrig* | *-*-midnightbsd* | *-*-secbsd*)
|
||||
# Do not include libc due to us having libc/libc_r.
|
||||
test X-lc = "X$arg" && continue
|
||||
;;
|
||||
@@ -7303,7 +7303,7 @@ func_mode_link ()
|
||||
esac
|
||||
elif test X-lc_r = "X$arg"; then
|
||||
case $host in
|
||||
- *-*-openbsd* | *-*-freebsd* | *-*-dragonfly* | *-*-bitrig* | *-*-midnightbsd*)
|
||||
+ *-*-openbsd* | *-*-freebsd* | *-*-dragonfly* | *-*-bitrig* | *-*-midnightbsd* | *-*-secbsd*)
|
||||
# Do not include libc_r directly, use -pthread flag.
|
||||
continue
|
||||
;;
|
||||
@@ -9408,7 +9408,7 @@ func_mode_link ()
|
||||
*-*-netbsd*)
|
||||
# Don't link with libc until the a.out ld.so is fixed.
|
||||
;;
|
||||
- *-*-openbsd* | *-*-freebsd* | *-*-dragonfly* | *-*-midnightbsd*)
|
||||
+ *-*-openbsd* | *-*-freebsd* | *-*-dragonfly* | *-*-midnightbsd* | *-*-secbsd*)
|
||||
# Do not include libc due to us having libc/libc_r.
|
||||
;;
|
||||
*-*-sco3.2v5* | *-*-sco5v6*)
|
84
devel/re2c/patches/patch-configure
Normal file
84
devel/re2c/patches/patch-configure
Normal file
|
@ -0,0 +1,84 @@
|
|||
Index: configure
|
||||
--- configure.orig
|
||||
+++ configure
|
||||
@@ -9276,7 +9276,7 @@ else $as_nop
|
||||
lt_cv_sys_max_cmd_len=8192;
|
||||
;;
|
||||
|
||||
- bitrig* | darwin* | dragonfly* | freebsd* | midnightbsd* | netbsd* | openbsd*)
|
||||
+ bitrig* | darwin* | dragonfly* | freebsd* | midnightbsd* | netbsd* | openbsd* | secbsd*)
|
||||
# This has been around since 386BSD, at least. Likely further.
|
||||
if test -x /sbin/sysctl; then
|
||||
lt_cv_sys_max_cmd_len=`/sbin/sysctl -n kern.argmax`
|
||||
@@ -9812,7 +9812,7 @@ freebsd* | dragonfly* | midnightbsd*)
|
||||
i*86 )
|
||||
# Not sure whether the presence of OpenBSD here was a mistake.
|
||||
# Let's accept both of them until this is cleared up.
|
||||
- lt_cv_deplibs_check_method='file_magic (FreeBSD|OpenBSD|DragonFly)/i[3-9]86 (compact )?demand paged shared library'
|
||||
+ lt_cv_deplibs_check_method='file_magic (FreeBSD|OpenBSD|DragonFly|SecBSD)/i[3-9]86 (compact )?demand paged shared library'
|
||||
lt_cv_file_magic_cmd=$FILECMD
|
||||
lt_cv_file_magic_test_file=`echo /usr/lib/libc.so.*`
|
||||
;;
|
||||
@@ -9882,7 +9882,7 @@ newos6*)
|
||||
lt_cv_deplibs_check_method=pass_all
|
||||
;;
|
||||
|
||||
-openbsd* | bitrig*)
|
||||
+openbsd* | bitrig* | secbsd*)
|
||||
if test -z "`echo __ELF__ | $CC -E - | $GREP __ELF__`"; then
|
||||
lt_cv_deplibs_check_method='match_pattern /lib[^/]+(\.so\.[0-9]+\.[0-9]+|\.so|_pic\.a)$'
|
||||
else
|
||||
@@ -10557,7 +10557,7 @@ old_postuninstall_cmds=
|
||||
|
||||
if test -n "$RANLIB"; then
|
||||
case $host_os in
|
||||
- bitrig* | openbsd*)
|
||||
+ bitrig* | openbsd* | secbsd*)
|
||||
old_postinstall_cmds="$old_postinstall_cmds~\$RANLIB -t \$tool_oldlib"
|
||||
;;
|
||||
*)
|
||||
@@ -13759,7 +13759,7 @@ printf %s "checking whether the $compiler linker ($LD)
|
||||
# we just hope/assume this is gcc and not c89 (= MSVC++ or ICC)
|
||||
with_gnu_ld=yes
|
||||
;;
|
||||
- openbsd* | bitrig*)
|
||||
+ openbsd* | bitrig* | secbsd*)
|
||||
with_gnu_ld=no
|
||||
;;
|
||||
esac
|
||||
@@ -14737,7 +14737,7 @@ printf "%s\n" "$lt_cv_irix_exported_symbol" >&6; }
|
||||
*nto* | *qnx*)
|
||||
;;
|
||||
|
||||
- openbsd* | bitrig*)
|
||||
+ openbsd* | bitrig* | secbsd*)
|
||||
if test -f /usr/libexec/ld.so; then
|
||||
hardcode_direct=yes
|
||||
hardcode_shlibpath_var=no
|
||||
@@ -15872,7 +15872,7 @@ newsos6)
|
||||
dynamic_linker='ldqnx.so'
|
||||
;;
|
||||
|
||||
-openbsd* | bitrig*)
|
||||
+openbsd* | bitrig* | secbsd*)
|
||||
version_type=sunos
|
||||
sys_lib_dlsearch_path_spec=/usr/lib
|
||||
need_lib_prefix=no
|
||||
@@ -18048,7 +18048,7 @@ fi
|
||||
ld_shlibs_CXX=yes
|
||||
;;
|
||||
|
||||
- openbsd* | bitrig*)
|
||||
+ openbsd* | bitrig* | secbsd*)
|
||||
if test -f /usr/libexec/ld.so; then
|
||||
hardcode_direct_CXX=yes
|
||||
hardcode_shlibpath_var_CXX=no
|
||||
@@ -19861,7 +19861,7 @@ newsos6)
|
||||
dynamic_linker='ldqnx.so'
|
||||
;;
|
||||
|
||||
-openbsd* | bitrig*)
|
||||
+openbsd* | bitrig* | secbsd*)
|
||||
version_type=sunos
|
||||
sys_lib_dlsearch_path_spec=/usr/lib
|
||||
need_lib_prefix=no
|
Loading…
Add table
Add a link
Reference in a new issue