switch default py3 version to 3.11 and rm old py3.x versions
This commit is contained in:
parent
7f1bb8f14c
commit
9888392b04
63 changed files with 720 additions and 19538 deletions
102
lang/python/3/patches/patch-configure_ac
Normal file
102
lang/python/3/patches/patch-configure_ac
Normal file
|
@ -0,0 +1,102 @@
|
|||
Index: configure.ac
|
||||
--- configure.ac.orig
|
||||
+++ configure.ac
|
||||
@@ -249,7 +249,7 @@ VERSION=PYTHON_VERSION
|
||||
|
||||
# Version number of Python's own shared library file.
|
||||
AC_SUBST(SOVERSION)
|
||||
-SOVERSION=1.0
|
||||
+SOVERSION=${LIBpython3.11_VERSION}
|
||||
|
||||
# The later definition of _XOPEN_SOURCE and _POSIX_C_SOURCE disables
|
||||
# certain features on NetBSD, so we need _NETBSD_SOURCE to re-enable
|
||||
@@ -645,7 +645,7 @@ case $ac_sys_system/$ac_sys_release in
|
||||
# As this has a different meaning on Linux, only define it on OpenBSD
|
||||
AC_DEFINE(_BSD_SOURCE, 1, [Define on OpenBSD to activate all library features])
|
||||
;;
|
||||
- OpenBSD/*)
|
||||
+ OpenBSD/* | SecBSD/*)
|
||||
# OpenBSD undoes our definition of __BSD_VISIBLE if _XOPEN_SOURCE is
|
||||
# also defined. This can be overridden by defining _BSD_SOURCE
|
||||
# As this has a different meaning on Linux, only define it on OpenBSD
|
||||
@@ -1104,6 +1104,7 @@ AC_MSG_CHECKING([for multiarch])
|
||||
AS_CASE([$ac_sys_system],
|
||||
[Darwin*], [MULTIARCH=""],
|
||||
[FreeBSD*], [MULTIARCH=""],
|
||||
+ [SecBSD*], [MULTIARCH=""],
|
||||
[MULTIARCH=$($CC --print-multiarch 2>/dev/null)]
|
||||
)
|
||||
AC_SUBST([MULTIARCH])
|
||||
@@ -1493,7 +1494,7 @@ if test $enable_shared = "yes"; then
|
||||
PY3LIBRARY=libpython3.so
|
||||
fi
|
||||
;;
|
||||
- Linux*|GNU*|NetBSD*|FreeBSD*|DragonFly*|OpenBSD*|VxWorks*)
|
||||
+ Linux*|GNU*|NetBSD*|FreeBSD*|DragonFly*|OpenBSD*|SecBSD*|VxWorks*)
|
||||
LDLIBRARY='libpython$(LDVERSION).so'
|
||||
BLDLIBRARY='-L. -lpython$(LDVERSION)'
|
||||
RUNSHARED=LD_LIBRARY_PATH=`pwd`${LD_LIBRARY_PATH:+:${LD_LIBRARY_PATH}}
|
||||
@@ -1843,13 +1844,13 @@ esac
|
||||
[AC_MSG_RESULT(no)])
|
||||
if test "$Py_LTO" = 'true' ; then
|
||||
case $CC in
|
||||
- *clang*)
|
||||
+ *clang*|cc)
|
||||
LDFLAGS_NOLTO="-fno-lto"
|
||||
dnl Clang linker requires -flto in order to link objects with LTO information.
|
||||
dnl Thin LTO is faster and works for object files with full LTO information, too.
|
||||
AX_CHECK_COMPILE_FLAG([-flto=thin],[LDFLAGS_NOLTO="-flto=thin"],[LDFLAGS_NOLTO="-flto"])
|
||||
AC_SUBST(LLVM_AR)
|
||||
- AC_PATH_TOOL(LLVM_AR, llvm-ar, '', ${llvm_path})
|
||||
+ AC_PATH_TOOL(LLVM_AR, ar, '', ${llvm_path})
|
||||
AC_SUBST(LLVM_AR_FOUND)
|
||||
if test -n "${LLVM_AR}" -a -x "${LLVM_AR}"
|
||||
then
|
||||
@@ -1964,7 +1965,7 @@ then
|
||||
fi
|
||||
LLVM_PROF_ERR=no
|
||||
case $CC in
|
||||
- *clang*)
|
||||
+ *clang*|cc)
|
||||
# Any changes made here should be reflected in the GCC+Darwin case below
|
||||
PGO_PROF_GEN_FLAG="-fprofile-instr-generate"
|
||||
PGO_PROF_USE_FLAG="-fprofile-instr-use=code.profclangd"
|
||||
@@ -3193,7 +3194,7 @@ then
|
||||
else
|
||||
LDSHARED="ld -Bshareable"
|
||||
fi;;
|
||||
- OpenBSD*)
|
||||
+ OpenBSD* | SecBSD*)
|
||||
if [[ "`$CC -dM -E - </dev/null | grep __ELF__`" != "" ]]
|
||||
then
|
||||
LDSHARED='$(CC) -shared $(CCSHARED)'
|
||||
@@ -3269,7 +3270,7 @@ then
|
||||
AS_VAR_IF([enable_wasm_dynamic_linking], [yes], [
|
||||
CCSHARED="-fPIC"
|
||||
]);;
|
||||
- FreeBSD*|NetBSD*|OpenBSD*|DragonFly*) CCSHARED="-fPIC";;
|
||||
+ FreeBSD*|NetBSD*|OpenBSD*|SecBSD*|DragonFly*) CCSHARED="-fPIC";;
|
||||
Haiku*) CCSHARED="-fPIC";;
|
||||
OpenUNIX*|UnixWare*)
|
||||
if test "$GCC" = "yes"
|
||||
@@ -3326,7 +3327,7 @@ then
|
||||
OpenUNIX*|UnixWare*) LINKFORSHARED="-Wl,-Bexport";;
|
||||
SCO_SV*) LINKFORSHARED="-Wl,-Bexport";;
|
||||
ReliantUNIX*) LINKFORSHARED="-W1 -Blargedynsym";;
|
||||
- FreeBSD*|NetBSD*|OpenBSD*|DragonFly*)
|
||||
+ FreeBSD*|NetBSD*|OpenBSD*|SecBSD*|DragonFly*)
|
||||
if [[ "`$CC -dM -E - </dev/null | grep __ELF__`" != "" ]]
|
||||
then
|
||||
LINKFORSHARED="-Wl,--export-dynamic"
|
||||
@@ -3888,11 +3889,7 @@ dnl Detect Tcl/Tk. Use pkg-config if available.
|
||||
dnl
|
||||
found_tcltk=no
|
||||
for _QUERY in \
|
||||
- "tcl >= 8.5.12 tk >= 8.5.12" \
|
||||
- "tcl8.6 tk8.6" \
|
||||
"tcl86 tk86" \
|
||||
- "tcl8.5 >= 8.5.12 tk8.5 >= 8.5.12" \
|
||||
- "tcl85 >= 8.5.12 tk85 >= 8.5.12" \
|
||||
; do
|
||||
PKG_CHECK_EXISTS([$_QUERY], [
|
||||
PKG_CHECK_MODULES([TCLTK], [$_QUERY], [found_tcltk=yes], [found_tcltk=no])
|
Loading…
Add table
Add a link
Reference in a new issue