UPDATE: net/libcares 1.28.1 -> 1.33.0
This commit is contained in:
parent
8df8c9ea8e
commit
964c84bb75
8 changed files with 239 additions and 27 deletions
|
@ -1,14 +1,14 @@
|
|||
COMMENT= asynchronous resolver library
|
||||
|
||||
V= 1.28.1
|
||||
V= 1.33.0
|
||||
DISTNAME= c-ares-${V}
|
||||
PKGNAME= libcares-${V}
|
||||
CATEGORIES= net devel
|
||||
SITES= ${HOMEPAGE}download/
|
||||
SITES= https://github.com/c-ares/c-ares/releases/download/v${V}/
|
||||
|
||||
SHARED_LIBS += cares 3.6 # 2.13.1
|
||||
SHARED_LIBS += cares 4.2 # 2.18.0
|
||||
|
||||
HOMEPAGE= https://c-ares.haxx.se/
|
||||
HOMEPAGE= https://c-ares.org/
|
||||
|
||||
MAINTAINER= Brad Smith <brad@comstyle.com>
|
||||
|
||||
|
|
|
@ -1,2 +1,2 @@
|
|||
SHA256 (c-ares-1.28.1.tar.gz) = Z1pp/FTdv0LmgwvGce62zYnuykOCjrQTJD/SwKdggJ0=
|
||||
SIZE (c-ares-1.28.1.tar.gz) = 1312102
|
||||
SHA256 (c-ares-1.33.0.tar.gz) = PkHfLxcgQetOy3VKRkwRzMUEayocix1qQNrEXTo7I0Y=
|
||||
SIZE (c-ares-1.33.0.tar.gz) = 1040626
|
||||
|
|
19
net/libcares/patches/patch-CMakeLists_txt
Normal file
19
net/libcares/patches/patch-CMakeLists_txt
Normal file
|
@ -0,0 +1,19 @@
|
|||
Index: CMakeLists.txt
|
||||
--- CMakeLists.txt.orig
|
||||
+++ CMakeLists.txt
|
||||
@@ -634,6 +634,7 @@ IF (HAVE_GETSERVBYPORT_R)
|
||||
SET (GETSERVBYPORT_R_ARGS 5)
|
||||
ELSEIF (CMAKE_SYSTEM_NAME STREQUAL "AIX" OR
|
||||
CMAKE_SYSTEM_NAME STREQUAL "OpenBSD" OR
|
||||
+ CMAKE_SYSTEM_NAME STREQUAL "SecBSD" OR
|
||||
HAIKU)
|
||||
SET (GETSERVBYPORT_R_ARGS 4)
|
||||
ELSE ()
|
||||
@@ -648,6 +649,7 @@ IF (HAVE_GETSERVBYNAME_R)
|
||||
SET (GETSERVBYNAME_R_ARGS 5)
|
||||
ELSEIF (CMAKE_SYSTEM_NAME STREQUAL "AIX" OR
|
||||
CMAKE_SYSTEM_NAME STREQUAL "OpenBSD" OR
|
||||
+ CMAKE_SYSTEM_NAME STREQUAL "SecBSD" OR
|
||||
HAIKU)
|
||||
SET (GETSERVBYNAME_R_ARGS 4)
|
||||
ELSE ()
|
30
net/libcares/patches/patch-config_ltmain_sh
Normal file
30
net/libcares/patches/patch-config_ltmain_sh
Normal file
|
@ -0,0 +1,30 @@
|
|||
Index: config/ltmain.sh
|
||||
--- config/ltmain.sh.orig
|
||||
+++ config/ltmain.sh
|
||||
@@ -7283,7 +7283,7 @@ func_mode_link ()
|
||||
# These systems don't actually have a C library (as such)
|
||||
test X-lc = "X$arg" && continue
|
||||
;;
|
||||
- *-*-openbsd* | *-*-freebsd* | *-*-dragonfly* | *-*-bitrig* | *-*-midnightbsd*)
|
||||
+ *-*-openbsd* | *-*-freebsd* | *-*-dragonfly* | *-*-bitrig* | *-*-midnightbsd* | *-*-secbsd*)
|
||||
# Do not include libc due to us having libc/libc_r.
|
||||
test X-lc = "X$arg" && continue
|
||||
;;
|
||||
@@ -7303,7 +7303,7 @@ func_mode_link ()
|
||||
esac
|
||||
elif test X-lc_r = "X$arg"; then
|
||||
case $host in
|
||||
- *-*-openbsd* | *-*-freebsd* | *-*-dragonfly* | *-*-bitrig* | *-*-midnightbsd*)
|
||||
+ *-*-openbsd* | *-*-freebsd* | *-*-dragonfly* | *-*-bitrig* | *-*-midnightbsd* | *-*-secbsd*)
|
||||
# Do not include libc_r directly, use -pthread flag.
|
||||
continue
|
||||
;;
|
||||
@@ -9408,7 +9408,7 @@ func_mode_link ()
|
||||
*-*-netbsd*)
|
||||
# Don't link with libc until the a.out ld.so is fixed.
|
||||
;;
|
||||
- *-*-openbsd* | *-*-freebsd* | *-*-dragonfly* | *-*-midnightbsd*)
|
||||
+ *-*-openbsd* | *-*-freebsd* | *-*-dragonfly* | *-*-midnightbsd* | *-*-secbsd*)
|
||||
# Do not include libc due to us having libc/libc_r.
|
||||
;;
|
||||
*-*-sco3.2v5* | *-*-sco5v6*)
|
102
net/libcares/patches/patch-configure
Normal file
102
net/libcares/patches/patch-configure
Normal file
|
@ -0,0 +1,102 @@
|
|||
Index: configure
|
||||
--- configure.orig
|
||||
+++ configure
|
||||
@@ -7266,7 +7266,7 @@ else case e in #(
|
||||
lt_cv_sys_max_cmd_len=8192;
|
||||
;;
|
||||
|
||||
- bitrig* | darwin* | dragonfly* | freebsd* | midnightbsd* | netbsd* | openbsd*)
|
||||
+ bitrig* | darwin* | dragonfly* | freebsd* | midnightbsd* | netbsd* | openbsd* | secbsd*)
|
||||
# This has been around since 386BSD, at least. Likely further.
|
||||
if test -x /sbin/sysctl; then
|
||||
lt_cv_sys_max_cmd_len=`/sbin/sysctl -n kern.argmax`
|
||||
@@ -7810,7 +7810,7 @@ freebsd* | dragonfly* | midnightbsd*)
|
||||
i*86 )
|
||||
# Not sure whether the presence of OpenBSD here was a mistake.
|
||||
# Let's accept both of them until this is cleared up.
|
||||
- lt_cv_deplibs_check_method='file_magic (FreeBSD|OpenBSD|DragonFly)/i[3-9]86 (compact )?demand paged shared library'
|
||||
+ lt_cv_deplibs_check_method='file_magic (FreeBSD|OpenBSD|SecBSD|DragonFly)/i[3-9]86 (compact )?demand paged shared library'
|
||||
lt_cv_file_magic_cmd=$FILECMD
|
||||
lt_cv_file_magic_test_file=`echo /usr/lib/libc.so.*`
|
||||
;;
|
||||
@@ -7880,7 +7880,7 @@ newos6*)
|
||||
lt_cv_deplibs_check_method=pass_all
|
||||
;;
|
||||
|
||||
-openbsd* | bitrig*)
|
||||
+openbsd* | bitrig* | secbsd*)
|
||||
if test -z "`echo __ELF__ | $CC -E - | $GREP __ELF__`"; then
|
||||
lt_cv_deplibs_check_method='match_pattern /lib[^/]+(\.so\.[0-9]+\.[0-9]+|\.so|_pic\.a)$'
|
||||
else
|
||||
@@ -8566,7 +8566,7 @@ old_postuninstall_cmds=
|
||||
|
||||
if test -n "$RANLIB"; then
|
||||
case $host_os in
|
||||
- bitrig* | openbsd*)
|
||||
+ bitrig* | openbsd* | secbsd*)
|
||||
old_postinstall_cmds="$old_postinstall_cmds~\$RANLIB -t \$tool_oldlib"
|
||||
;;
|
||||
*)
|
||||
@@ -11813,7 +11813,7 @@ printf %s "checking whether the $compiler linker ($LD)
|
||||
# we just hope/assume this is gcc and not c89 (= MSVC++ or ICC)
|
||||
with_gnu_ld=yes
|
||||
;;
|
||||
- openbsd* | bitrig*)
|
||||
+ openbsd* | bitrig* | secbsd*)
|
||||
with_gnu_ld=no
|
||||
;;
|
||||
esac
|
||||
@@ -12796,7 +12796,7 @@ printf "%s\n" "$lt_cv_irix_exported_symbol" >&6; }
|
||||
*nto* | *qnx*)
|
||||
;;
|
||||
|
||||
- openbsd* | bitrig*)
|
||||
+ openbsd* | bitrig* | secbsd*)
|
||||
if test -f /usr/libexec/ld.so; then
|
||||
hardcode_direct=yes
|
||||
hardcode_shlibpath_var=no
|
||||
@@ -13933,7 +13933,7 @@ newsos6)
|
||||
dynamic_linker='ldqnx.so'
|
||||
;;
|
||||
|
||||
-openbsd* | bitrig*)
|
||||
+openbsd* | bitrig* | secbsd*)
|
||||
version_type=sunos
|
||||
sys_lib_dlsearch_path_spec=/usr/lib
|
||||
need_lib_prefix=no
|
||||
@@ -16168,7 +16168,7 @@ fi
|
||||
ld_shlibs_CXX=yes
|
||||
;;
|
||||
|
||||
- openbsd* | bitrig*)
|
||||
+ openbsd* | bitrig* | secbsd*)
|
||||
if test -f /usr/libexec/ld.so; then
|
||||
hardcode_direct_CXX=yes
|
||||
hardcode_shlibpath_var_CXX=no
|
||||
@@ -17988,7 +17988,7 @@ newsos6)
|
||||
dynamic_linker='ldqnx.so'
|
||||
;;
|
||||
|
||||
-openbsd* | bitrig*)
|
||||
+openbsd* | bitrig* | secbsd*)
|
||||
version_type=sunos
|
||||
sys_lib_dlsearch_path_spec=/usr/lib
|
||||
need_lib_prefix=no
|
||||
@@ -23050,7 +23050,7 @@ printf %s "checking number of arguments for getservbyp
|
||||
solaris*)
|
||||
getservbyport_r_args=5
|
||||
;;
|
||||
- aix*|openbsd*)
|
||||
+ aix*|openbsd*|secbsd*)
|
||||
getservbyport_r_args=4
|
||||
;;
|
||||
esac
|
||||
@@ -23069,7 +23069,7 @@ printf %s "checking number of arguments for getservbyn
|
||||
solaris*)
|
||||
getservbyname_r_args=5
|
||||
;;
|
||||
- aix*|openbsd*)
|
||||
+ aix*|openbsd*|secbsd*)
|
||||
getservbyname_r_args=4
|
||||
;;
|
||||
esac
|
75
net/libcares/patches/patch-m4_libtool_m4
Normal file
75
net/libcares/patches/patch-m4_libtool_m4
Normal file
|
@ -0,0 +1,75 @@
|
|||
Index: m4/libtool.m4
|
||||
--- m4/libtool.m4.orig
|
||||
+++ m4/libtool.m4
|
||||
@@ -1557,7 +1557,7 @@ old_postuninstall_cmds=
|
||||
|
||||
if test -n "$RANLIB"; then
|
||||
case $host_os in
|
||||
- bitrig* | openbsd*)
|
||||
+ bitrig* | openbsd* | secbsd*)
|
||||
old_postinstall_cmds="$old_postinstall_cmds~\$RANLIB -t \$tool_oldlib"
|
||||
;;
|
||||
*)
|
||||
@@ -1725,7 +1725,7 @@ AC_CACHE_VAL([lt_cv_sys_max_cmd_len], [dnl
|
||||
lt_cv_sys_max_cmd_len=8192;
|
||||
;;
|
||||
|
||||
- bitrig* | darwin* | dragonfly* | freebsd* | midnightbsd* | netbsd* | openbsd*)
|
||||
+ bitrig* | darwin* | dragonfly* | freebsd* | midnightbsd* | netbsd* | openbsd* | secbsd*)
|
||||
# This has been around since 386BSD, at least. Likely further.
|
||||
if test -x /sbin/sysctl; then
|
||||
lt_cv_sys_max_cmd_len=`/sbin/sysctl -n kern.argmax`
|
||||
@@ -2944,7 +2944,7 @@ newsos6)
|
||||
dynamic_linker='ldqnx.so'
|
||||
;;
|
||||
|
||||
-openbsd* | bitrig*)
|
||||
+openbsd* | bitrig* | secbsd*)
|
||||
version_type=sunos
|
||||
sys_lib_dlsearch_path_spec=/usr/lib
|
||||
need_lib_prefix=no
|
||||
@@ -3514,7 +3514,7 @@ freebsd* | dragonfly* | midnightbsd*)
|
||||
i*86 )
|
||||
# Not sure whether the presence of OpenBSD here was a mistake.
|
||||
# Let's accept both of them until this is cleared up.
|
||||
- lt_cv_deplibs_check_method='file_magic (FreeBSD|OpenBSD|DragonFly)/i[[3-9]]86 (compact )?demand paged shared library'
|
||||
+ lt_cv_deplibs_check_method='file_magic (FreeBSD|OpenBSD|SecBSD|DragonFly)/i[[3-9]]86 (compact )?demand paged shared library'
|
||||
lt_cv_file_magic_cmd=$FILECMD
|
||||
lt_cv_file_magic_test_file=`echo /usr/lib/libc.so.*`
|
||||
;;
|
||||
@@ -3584,7 +3584,7 @@ newos6*)
|
||||
lt_cv_deplibs_check_method=pass_all
|
||||
;;
|
||||
|
||||
-openbsd* | bitrig*)
|
||||
+openbsd* | bitrig* | secbsd*)
|
||||
if test -z "`echo __ELF__ | $CC -E - | $GREP __ELF__`"; then
|
||||
lt_cv_deplibs_check_method='match_pattern /lib[[^/]]+(\.so\.[[0-9]]+\.[[0-9]]+|\.so|_pic\.a)$'
|
||||
else
|
||||
@@ -5015,7 +5015,7 @@ dnl Note also adjust exclude_expsyms for C++ above.
|
||||
# we just hope/assume this is gcc and not c89 (= MSVC++ or ICC)
|
||||
with_gnu_ld=yes
|
||||
;;
|
||||
- openbsd* | bitrig*)
|
||||
+ openbsd* | bitrig* | secbsd*)
|
||||
with_gnu_ld=no
|
||||
;;
|
||||
esac
|
||||
@@ -5837,7 +5837,7 @@ _LT_EOF
|
||||
*nto* | *qnx*)
|
||||
;;
|
||||
|
||||
- openbsd* | bitrig*)
|
||||
+ openbsd* | bitrig* | secbsd*)
|
||||
if test -f /usr/libexec/ld.so; then
|
||||
_LT_TAGVAR(hardcode_direct, $1)=yes
|
||||
_LT_TAGVAR(hardcode_shlibpath_var, $1)=no
|
||||
@@ -7131,7 +7131,7 @@ if test yes != "$_lt_caught_CXX_error"; then
|
||||
_LT_TAGVAR(ld_shlibs, $1)=yes
|
||||
;;
|
||||
|
||||
- openbsd* | bitrig*)
|
||||
+ openbsd* | bitrig* | secbsd*)
|
||||
if test -f /usr/libexec/ld.so; then
|
||||
_LT_TAGVAR(hardcode_direct, $1)=yes
|
||||
_LT_TAGVAR(hardcode_shlibpath_var, $1)=no
|
|
@ -1,20 +0,0 @@
|
|||
Revert the change from https://github.com/c-ares/c-ares/pull/659
|
||||
because it breaks node (https://github.com/nodejs/node/issues/52439)
|
||||
and likely other use cases as well.
|
||||
|
||||
Index: src/lib/ares__socket.c
|
||||
--- src/lib/ares__socket.c.orig
|
||||
+++ src/lib/ares__socket.c
|
||||
@@ -253,12 +253,6 @@ ares_status_t ares__open_connection(ares_channel_t
|
||||
struct server_connection *conn;
|
||||
ares__llist_node_t *node;
|
||||
int type = is_tcp ? SOCK_STREAM : SOCK_DGRAM;
|
||||
-#ifdef __OpenBSD__
|
||||
- if ((is_tcp && server->tcp_port == 53) ||
|
||||
- (!is_tcp && server->udp_port == 53)) {
|
||||
- type |= SOCK_DNS;
|
||||
- }
|
||||
-#endif
|
||||
|
||||
switch (server->addr.family) {
|
||||
case AF_INET:
|
|
@ -3,7 +3,6 @@ include/ares_build.h
|
|||
include/ares_dns.h
|
||||
include/ares_dns_record.h
|
||||
include/ares_nameser.h
|
||||
include/ares_rules.h
|
||||
include/ares_version.h
|
||||
lib/cmake/
|
||||
lib/cmake/c-ares/
|
||||
|
@ -34,6 +33,7 @@ lib/pkgconfig/libcares.pc
|
|||
@man man/man3/ares_dns_rcode_tostr.3
|
||||
@man man/man3/ares_dns_rec_type_fromstr.3
|
||||
@man man/man3/ares_dns_rec_type_t.3
|
||||
@man man/man3/ares_dns_rec_type_tostr.3
|
||||
@man man/man3/ares_dns_record.3
|
||||
@man man/man3/ares_dns_record_create.3
|
||||
@man man/man3/ares_dns_record_destroy.3
|
||||
|
@ -52,7 +52,12 @@ lib/pkgconfig/libcares.pc
|
|||
@man man/man3/ares_dns_record_rr_del.3
|
||||
@man man/man3/ares_dns_record_rr_get.3
|
||||
@man man/man3/ares_dns_record_rr_get_const.3
|
||||
@man man/man3/ares_dns_record_set_id.3
|
||||
@man man/man3/ares_dns_rr.3
|
||||
@man man/man3/ares_dns_rr_add_abin.3
|
||||
@man man/man3/ares_dns_rr_del_abin.3
|
||||
@man man/man3/ares_dns_rr_get_abin.3
|
||||
@man man/man3/ares_dns_rr_get_abin_cnt.3
|
||||
@man man/man3/ares_dns_rr_get_addr.3
|
||||
@man man/man3/ares_dns_rr_get_addr6.3
|
||||
@man man/man3/ares_dns_rr_get_bin.3
|
||||
|
@ -136,6 +141,7 @@ lib/pkgconfig/libcares.pc
|
|||
@man man/man3/ares_set_local_dev.3
|
||||
@man man/man3/ares_set_local_ip4.3
|
||||
@man man/man3/ares_set_local_ip6.3
|
||||
@man man/man3/ares_set_server_state_callback.3
|
||||
@man man/man3/ares_set_servers.3
|
||||
@man man/man3/ares_set_servers_csv.3
|
||||
@man man/man3/ares_set_servers_ports.3
|
||||
|
|
Loading…
Add table
Add a link
Reference in a new issue