sync ports with The Matrix
This commit is contained in:
parent
74706e64f4
commit
77bea1694c
1060 changed files with 39921 additions and 2746 deletions
|
@ -6,7 +6,7 @@ Should match b_lundef in meson(1).
|
|||
Index: meson.build
|
||||
--- meson.build.orig
|
||||
+++ meson.build
|
||||
@@ -257,7 +257,6 @@ array_bounds = get_option('b_sanitize') == 'none' ? 2
|
||||
@@ -266,7 +266,6 @@ array_bounds = get_option('b_sanitize') == 'none' ? 2
|
||||
|
||||
cc_flags += [
|
||||
'-fasynchronous-unwind-tables',
|
||||
|
@ -14,7 +14,7 @@ Index: meson.build
|
|||
'-fipa-pure-const',
|
||||
'-fno-common',
|
||||
'-Wabsolute-value',
|
||||
@@ -540,11 +539,6 @@ libvirt_nodelete = cc.get_supported_link_arguments([
|
||||
@@ -549,11 +548,6 @@ libvirt_nodelete = cc.get_supported_link_arguments([
|
||||
])
|
||||
|
||||
libvirt_no_undefined = []
|
||||
|
@ -26,7 +26,7 @@ Index: meson.build
|
|||
|
||||
libvirt_no_indirect = cc.get_supported_link_arguments([
|
||||
'-Wl,--no-copy-dt-needed-entries',
|
||||
@@ -853,7 +847,7 @@ if not get_option('driver_remote').disabled()
|
||||
@@ -869,7 +863,7 @@ if not get_option('driver_remote').disabled()
|
||||
xdr_dep = cc.find_library('portablexdr', required: get_option('driver_remote'))
|
||||
elif host_machine.system() == 'linux'
|
||||
xdr_dep = dependency('libtirpc', required: get_option('driver_remote'))
|
||||
|
@ -35,7 +35,7 @@ Index: meson.build
|
|||
xdr_dep = cc.find_library('c', required: get_option('driver_remote'))
|
||||
else
|
||||
xdr_dep = dependency('', required: false)
|
||||
@@ -938,15 +932,18 @@ if devmapper_dep.found()
|
||||
@@ -954,15 +948,18 @@ if devmapper_dep.found()
|
||||
conf.set('WITH_DEVMAPPER', 1)
|
||||
endif
|
||||
|
||||
|
@ -62,7 +62,7 @@ Index: meson.build
|
|||
fuse_version = '3.1.0'
|
||||
fuse_dep = dependency('fuse3', version: '>=' + fuse_version, required: false)
|
||||
if fuse_dep.found()
|
||||
@@ -1879,7 +1876,7 @@ endif
|
||||
@@ -1901,7 +1898,7 @@ endif
|
||||
|
||||
driver_modules_flags = []
|
||||
if conf.has('WITH_LIBVIRTD')
|
||||
|
@ -71,7 +71,7 @@ Index: meson.build
|
|||
error('You must have dlfcn.h / dlopen() support to build driver modules')
|
||||
endif
|
||||
driver_modules_flags = libvirt_export_dynamic
|
||||
@@ -2204,7 +2201,7 @@ libs_summary = {
|
||||
@@ -2229,7 +2226,7 @@ libs_summary = {
|
||||
'capng': capng_dep.found(),
|
||||
'curl': curl_dep.found(),
|
||||
'devmapper': devmapper_dep.found(),
|
||||
|
|
Loading…
Add table
Add a link
Reference in a new issue