sync ports with The Matrix
This commit is contained in:
parent
358e427f5b
commit
6f57aa08fd
149 changed files with 1364 additions and 3248 deletions
|
@ -15,15 +15,34 @@ Index: configure.ac
|
|||
|
||||
# The later defininition of _XOPEN_SOURCE disables certain features
|
||||
# on Linux, so we need _GNU_SOURCE to re-enable them (makedev, tm_zone).
|
||||
@@ -876,6 +876,7 @@ AC_MSG_CHECKING([for multiarch])
|
||||
@@ -483,7 +483,7 @@ case $ac_sys_system/$ac_sys_release in
|
||||
# As this has a different meaning on Linux, only define it on OpenBSD
|
||||
AC_DEFINE(_BSD_SOURCE, 1, [Define on OpenBSD to activate all library features])
|
||||
;;
|
||||
- OpenBSD/*)
|
||||
+ OpenBSD/* | SecBSD/*)
|
||||
# OpenBSD undoes our definition of __BSD_VISIBLE if _XOPEN_SOURCE is
|
||||
# also defined. This can be overridden by defining _BSD_SOURCE
|
||||
# As this has a different meaning on Linux, only define it on OpenBSD
|
||||
@@ -876,6 +876,8 @@ AC_MSG_CHECKING([for multiarch])
|
||||
AS_CASE([$ac_sys_system],
|
||||
[Darwin*], [MULTIARCH=""],
|
||||
[FreeBSD*], [MULTIARCH=""],
|
||||
+ [OpenBSD*], [MULTIARCH=""],
|
||||
+ [SecBSD*], [MULTIARCH=""],
|
||||
[MULTIARCH=$($CC --print-multiarch 2>/dev/null)]
|
||||
)
|
||||
AC_SUBST([MULTIARCH])
|
||||
@@ -1380,9 +1381,9 @@ fi],
|
||||
@@ -1149,7 +1151,7 @@ if test $enable_shared = "yes"; then
|
||||
PY3LIBRARY=libpython3.so
|
||||
fi
|
||||
;;
|
||||
- Linux*|GNU*|NetBSD*|FreeBSD*|DragonFly*|OpenBSD*|VxWorks*)
|
||||
+ Linux*|GNU*|NetBSD*|FreeBSD*|DragonFly*|OpenBSD*|SecBSD*|VxWorks*)
|
||||
LDLIBRARY='libpython$(LDVERSION).so'
|
||||
BLDLIBRARY='-L. -lpython$(LDVERSION)'
|
||||
RUNSHARED=LD_LIBRARY_PATH=`pwd`${LD_LIBRARY_PATH:+:${LD_LIBRARY_PATH}}
|
||||
@@ -1380,9 +1382,9 @@ fi],
|
||||
[AC_MSG_RESULT(no)])
|
||||
if test "$Py_LTO" = 'true' ; then
|
||||
case $CC in
|
||||
|
@ -35,7 +54,7 @@ Index: configure.ac
|
|||
AC_SUBST(LLVM_AR_FOUND)
|
||||
if test -n "${LLVM_AR}" -a -x "${LLVM_AR}"
|
||||
then
|
||||
@@ -1473,7 +1474,7 @@ then
|
||||
@@ -1473,7 +1475,7 @@ then
|
||||
fi
|
||||
LLVM_PROF_ERR=no
|
||||
case $CC in
|
||||
|
@ -44,7 +63,34 @@ Index: configure.ac
|
|||
# Any changes made here should be reflected in the GCC+Darwin case below
|
||||
PGO_PROF_GEN_FLAG="-fprofile-instr-generate"
|
||||
PGO_PROF_USE_FLAG="-fprofile-instr-use=code.profclangd"
|
||||
@@ -2905,18 +2906,7 @@ AC_CHECK_LIB(dl, dlopen) # Dynamic linking for SunOS/S
|
||||
@@ -2723,7 +2725,7 @@ then
|
||||
else
|
||||
LDSHARED="ld -Bshareable"
|
||||
fi;;
|
||||
- OpenBSD*)
|
||||
+ OpenBSD*|SecBSD*)
|
||||
if [[ "`$CC -dM -E - </dev/null | grep __ELF__`" != "" ]]
|
||||
then
|
||||
LDSHARED='$(CC) -shared $(CCSHARED)'
|
||||
@@ -2780,7 +2782,7 @@ then
|
||||
fi;;
|
||||
Linux-android*) ;;
|
||||
Linux*|GNU*) CCSHARED="-fPIC";;
|
||||
- FreeBSD*|NetBSD*|OpenBSD*|DragonFly*) CCSHARED="-fPIC";;
|
||||
+ FreeBSD*|NetBSD*|OpenBSD*|SecBSD*|DragonFly*) CCSHARED="-fPIC";;
|
||||
OpenUNIX*|UnixWare*)
|
||||
if test "$GCC" = "yes"
|
||||
then CCSHARED="-fPIC"
|
||||
@@ -2836,7 +2838,7 @@ then
|
||||
OpenUNIX*|UnixWare*) LINKFORSHARED="-Wl,-Bexport";;
|
||||
SCO_SV*) LINKFORSHARED="-Wl,-Bexport";;
|
||||
ReliantUNIX*) LINKFORSHARED="-W1 -Blargedynsym";;
|
||||
- FreeBSD*|NetBSD*|OpenBSD*|DragonFly*)
|
||||
+ FreeBSD*|NetBSD*|OpenBSD*|SecBSD*|DragonFly*)
|
||||
if [[ "`$CC -dM -E - </dev/null | grep __ELF__`" != "" ]]
|
||||
then
|
||||
LINKFORSHARED="-Wl,--export-dynamic"
|
||||
@@ -2905,18 +2907,7 @@ AC_CHECK_LIB(dl, dlopen) # Dynamic linking for SunOS/S
|
||||
AC_CHECK_LIB(dld, shl_load) # Dynamic linking for HP-UX
|
||||
|
||||
# checks for uuid.h location
|
||||
|
|
|
@ -6,7 +6,7 @@ Index: setup.py
|
|||
uuid_uuid_h = sysconfig.get_config_var("HAVE_UUID_UUID_H")
|
||||
if uuid_h or uuid_uuid_h:
|
||||
- if sysconfig.get_config_var("HAVE_LIBUUID"):
|
||||
+ if sysconfig.get_config_var("HAVE_LIBUUID") and not HOST_PLATFORM.startswith('openbsd'):
|
||||
+ if sysconfig.get_config_var("HAVE_LIBUUID") and not HOST_PLATFORM.startswith('secbsd'):
|
||||
uuid_libs = ["uuid"]
|
||||
else:
|
||||
uuid_libs = []
|
||||
|
|
|
@ -230,9 +230,9 @@ lib/python3.10/__pycache__/_sitebuiltins.cpython-310.pyc
|
|||
lib/python3.10/__pycache__/_strptime.cpython-310.opt-1.pyc
|
||||
lib/python3.10/__pycache__/_strptime.cpython-310.opt-2.pyc
|
||||
lib/python3.10/__pycache__/_strptime.cpython-310.pyc
|
||||
lib/python3.10/__pycache__/_sysconfigdata__${PY_PLATFORM}_.cpython-310.opt-1.pyc
|
||||
lib/python3.10/__pycache__/_sysconfigdata__${PY_PLATFORM}_.cpython-310.opt-2.pyc
|
||||
lib/python3.10/__pycache__/_sysconfigdata__${PY_PLATFORM}_.cpython-310.pyc
|
||||
lib/python3.10/__pycache__/_sysconfigdata__secbsd1_.cpython-310.opt-1.pyc
|
||||
lib/python3.10/__pycache__/_sysconfigdata__secbsd1_.cpython-310.opt-2.pyc
|
||||
lib/python3.10/__pycache__/_sysconfigdata__secbsd1_.cpython-310.pyc
|
||||
lib/python3.10/__pycache__/_threading_local.cpython-310.opt-1.pyc
|
||||
lib/python3.10/__pycache__/_threading_local.cpython-310.opt-2.pyc
|
||||
lib/python3.10/__pycache__/_threading_local.cpython-310.pyc
|
||||
|
@ -710,7 +710,7 @@ lib/python3.10/_pydecimal.py
|
|||
lib/python3.10/_pyio.py
|
||||
lib/python3.10/_sitebuiltins.py
|
||||
lib/python3.10/_strptime.py
|
||||
lib/python3.10/_sysconfigdata__${PY_PLATFORM}_.py
|
||||
lib/python3.10/_sysconfigdata__secbsd1_.py
|
||||
lib/python3.10/_threading_local.py
|
||||
lib/python3.10/_weakrefset.py
|
||||
lib/python3.10/abc.py
|
||||
|
|
Loading…
Add table
Add a link
Reference in a new issue