sync ports with The Matrix

This commit is contained in:
purplerain 2023-09-23 16:54:07 +00:00
parent 2577b38b96
commit 546ec68bda
Signed by: purplerain
GPG key ID: F42C07F07E2E35B7
41 changed files with 1097 additions and 729 deletions

View file

@ -2,9 +2,9 @@ LLVM_MAJOR = 13
LLVM_VERSION = ${LLVM_MAJOR}.0.0
LLVM_PKGSPEC = >=13,<14
REVISION-main = 15
REVISION-lldb = 4
REVISION-python = 3
REVISION-main = 16
REVISION-lldb = 5
REVISION-python = 4
SHARED_LIBS += LTO 6.0 \
Remarks 0.0 \

View file

@ -2,9 +2,9 @@ LLVM_MAJOR = 16
LLVM_VERSION = ${LLVM_MAJOR}.0.6
LLVM_PKGSPEC = >=16,<17
REVISION-main = 7
REVISION-lldb = 1
REVISION-python = 0
REVISION-main = 8
REVISION-lldb = 2
REVISION-python = 1
SHARED_LIBS += LTO 0.0 \
Remarks 0.0 \

View file

@ -22,7 +22,7 @@ PKGSPEC-python = ${MODPY_PY_PREFIX}llvm-${LLVM_PKGSPEC}
CATEGORIES = devel
MAINTAINER = Sebastien Marie <semarie@online.fr> \
MAINTAINER = Sebastien Marie <semarie@online.fr>, \
Robert Nagy <robert@openbsd.org>
LLVM_BASE = llvm${LLVM_MAJOR}

View file

@ -1,13 +1,11 @@
COMMENT= Python IDE based on IntelliJ IDEA
V= 2022.2.3
V= 2023.2.1
DISTNAME= pycharm-community-${V}
PKGNAME= pycharm-${V}
CATEGORIES= devel
REVISION= 0
HOMEPAGE= https://www.jetbrains.com/pycharm/
DISTFILES= ${DISTNAME}-no-jbr${EXTRACT_SUFX}
MAINTAINER = Lucas Raab <tuftedocelot@fastmail.fm>
@ -36,6 +34,7 @@ do-build:
do-install:
${INSTALL_DATA_DIR} ${PC}
@cd ${WRKDIST} && pax -rw . ${PC}
@rm -rf ${PC}/jbr
@rm -rf ${PC}/plugins/android
@rm -rf ${PC}/lib/pty4j-native
.for PLUGIN in darwin-x86-64 darwin-aarch64 win32-x86-64

View file

@ -1,2 +1,2 @@
SHA256 (pycharm-community-2022.2.3-no-jbr.tar.gz) = tfjguifIjjG/TDv7IbJiSMtv3hpfJKv6enAmzpJDnQY=
SIZE (pycharm-community-2022.2.3-no-jbr.tar.gz) = 357012371
SHA256 (pycharm-community-2023.2.1.tar.gz) = WVbGy1pbrR2XSeSHs7tp/L8BcPUjJOT/AJKDtyODh3g=
SIZE (pycharm-community-2023.2.1.tar.gz) = 588203470

File diff suppressed because it is too large Load diff

View file

@ -2,6 +2,7 @@ COMMENT = modal text editor
VER = 23.05
DISTNAME = helix-${VER}
REVISION = 0
CATEGORIES = editors

View file

@ -0,0 +1,60 @@
Backport upstream compatibility fix for rust >= 1.71
https://github.com/helix-editor/helix/commit/de0ef8af15945fb7f761503c615a2d6213d2fd82
Index: helix-vcs/src/diff/line_cache.rs
--- helix-vcs/src/diff/line_cache.rs.orig
+++ helix-vcs/src/diff/line_cache.rs
@@ -20,8 +20,8 @@ use super::{MAX_DIFF_BYTES, MAX_DIFF_LINES};
/// A cache that stores the `lines` of a rope as a vector.
/// It allows safely reusing the allocation of the vec when updating the rope
pub(crate) struct InternedRopeLines {
- diff_base: Rope,
- doc: Rope,
+ diff_base: Box<Rope>,
+ doc: Box<Rope>,
num_tokens_diff_base: u32,
interned: InternedInput<RopeSlice<'static>>,
}
@@ -34,8 +34,8 @@ impl InternedRopeLines {
after: Vec::with_capacity(doc.len_lines()),
interner: Interner::new(diff_base.len_lines() + doc.len_lines()),
},
- diff_base,
- doc,
+ diff_base: Box::new(diff_base),
+ doc: Box::new(doc),
// will be populated by update_diff_base_impl
num_tokens_diff_base: 0,
};
@@ -44,19 +44,19 @@ impl InternedRopeLines {
}
pub fn doc(&self) -> Rope {
- self.doc.clone()
+ Rope::clone(&*self.doc)
}
pub fn diff_base(&self) -> Rope {
- self.diff_base.clone()
+ Rope::clone(&*self.diff_base)
}
/// Updates the `diff_base` and optionally the document if `doc` is not None
pub fn update_diff_base(&mut self, diff_base: Rope, doc: Option<Rope>) {
self.interned.clear();
- self.diff_base = diff_base;
+ self.diff_base = Box::new(diff_base);
if let Some(doc) = doc {
- self.doc = doc
+ self.doc = Box::new(doc)
}
if !self.is_too_large() {
self.update_diff_base_impl();
@@ -74,7 +74,7 @@ impl InternedRopeLines {
.interner
.erase_tokens_after(self.num_tokens_diff_base.into());
- self.doc = doc;
+ self.doc = Box::new(doc);
if self.is_too_large() {
self.interned.after.clear();
} else {

View file

@ -2,6 +2,7 @@ COMMENT = SVG vector drawing application
VERSION = 1.3
DISTNAME = inkscape-${VERSION}
REVISION = 0
CATEGORIES = graphics
@ -19,10 +20,10 @@ WANTLIB += MagickWand-6.Q16 SM X11 Xext atk-1.0 atkmm-1.6 boost_filesystem-mt
WANTLIB += c cairo cairo-gobject cairomm-1.0 enchant-2 epoxy fontconfig
WANTLIB += freetype gc gdk-3 gdk_pixbuf-2.0 gdkmm-3.0 gio-2.0
WANTLIB += giomm-2.4 glib-2.0 glibmm-2.4 gmodule-2.0 gobject-2.0
WANTLIB += gsl gslcblas gspell-1 gtk-3 gtkmm-3.0 harfbuzz iconv
WANTLIB += intl jpeg lcms2 m pango-1.0 pangocairo-1.0 pangoft2-1.0
WANTLIB += pangomm-1.4 png poppler poppler-glib potrace sigc-2.0
WANTLIB += soup-2.4 xml2 xslt z
WANTLIB += gsl gslcblas gspell-1 gtk-3 gtkmm-3.0 gtksourceview-4
WANTLIB += harfbuzz iconv intl jpeg lcms2 m pango-1.0 pangocairo-1.0
WANTLIB += pangoft2-1.0 pangomm-1.4 png poppler poppler-glib potrace
WANTLIB += sigc-2.0 soup-2.4 xml2 xslt z
MASTER_SITES = https://media.inkscape.org/dl/resources/file/
EXTRACT_SUFX = .tar.xz
@ -58,7 +59,8 @@ LIB_DEPENDS = devel/boost \
textproc/gspell \
textproc/libxslt \
x11/gtk+3 \
x11/gtk3mm
x11/gtk3mm \
x11/gtksourceview4
RUN_DEPENDS = devel/desktop-file-utils \
devel/gettext,-runtime \

View file

@ -1,13 +1,15 @@
COMMENT= toolkit for manipulation and conversion of graphic images
DISTNAME= netpbm-11.01.01
DISTNAME= netpbm-11.03.05
SHARED_LIBS= netpbm 6.0
CATEGORIES= graphics
HOMEPAGE= http://netpbm.sourceforge.net/
MAINTAINER= Christian Weisgerber <naddy@openbsd.org>
PERMIT_PACKAGE= Yes
MASTER_SITES= https://shell.uugrn.org/~naddy/
SITES= https://shell.uugrn.org/~naddy/
EXTRACT_SUFX= .tar.xz
LIB_DEPENDS= graphics/tiff \

View file

@ -1,2 +1,2 @@
SHA256 (netpbm-11.01.01.tar.xz) = DBh4nEU+E63VJ07uvFJrpIp3vUp0tP7NAgIOWWf49qg=
SIZE (netpbm-11.01.01.tar.xz) = 2157660
SHA256 (netpbm-11.03.05.tar.xz) = uAG2ieDwTK/H/5RAqMTRC4/0K5ESMNTMhEr8EdHSI98=
SIZE (netpbm-11.03.05.tar.xz) = 2163952

View file

@ -1,6 +1,8 @@
# https://github.com/crystal-lang/crystal/issues/12743
#BROKEN = No LLVM 15 support
BROKEN= not IBT compatible, cannot load library libLLVM-13.so
# Hopefully ${CLANG_ARCHS} at some point.
ONLY_FOR_ARCHS= amd64

View file

@ -13,8 +13,6 @@ HOMEPAGE = https://wxmaxima-developers.github.io/
# GPLv2
PERMIT_PACKAGE = Yes
MAINTAINER = Edd Barrett <edd@openbsd.org>
WANTLIB += ${COMPILER_LIBCXX} c m wx_baseu-3.2 wx_baseu_net-3.2
WANTLIB += wx_baseu_xml-3.2 wx_gtk3u_aui-3.2 wx_gtk3u_core-3.2
WANTLIB += wx_gtk3u_html-3.2 wx_gtk3u_richtext-3.2

View file

@ -0,0 +1,23 @@
https://gitlab.freedesktop.org/pipewire/pipewire/-/issues/1819
Index: modcargo-crates/pipewire-0.7.0/src/lib.rs
--- modcargo-crates/pipewire-0.7.0/src/lib.rs.orig
+++ modcargo-crates/pipewire-0.7.0/src/lib.rs
@@ -152,7 +152,7 @@ pub mod prelude {
pub fn init() {
use once_cell::sync::OnceCell;
static INITIALIZED: OnceCell<()> = OnceCell::new();
- INITIALIZED.get_or_init(|| unsafe { pw_sys::pw_init(ptr::null_mut(), ptr::null_mut()) });
+ INITIALIZED.get_or_init(|| unsafe { pw_sys::pipewire_init(ptr::null_mut(), ptr::null_mut()) });
}
/// Deinitialize PipeWire
@@ -161,7 +161,7 @@ pub fn init() {
/// This must only be called once during the lifetime of the process, once no PipeWire threads
/// are running anymore and all PipeWire resources are released.
pub unsafe fn deinit() {
- pw_sys::pw_deinit()
+ pw_sys::pipewire_deinit()
}
#[cfg(test)]

View file

@ -0,0 +1,13 @@
https://gitlab.freedesktop.org/pipewire/pipewire/-/issues/1819
Index: modcargo-crates/pipewire-sys-0.7.0/build.rs
--- modcargo-crates/pipewire-sys-0.7.0/build.rs.orig
+++ modcargo-crates/pipewire-sys-0.7.0/build.rs
@@ -19,6 +19,7 @@ fn main() {
// included header files changed.
.parse_callbacks(Box::new(bindgen::CargoCallbacks))
.size_t_is_usize(true)
+ .allowlist_function("pipewire_.*")
.allowlist_function("pw_.*")
.allowlist_type("pw_.*")
.allowlist_var("pw_.*")

View file

@ -0,0 +1,16 @@
https://gitlab.freedesktop.org/pipewire/pipewire/-/issues/1819
Index: modcargo-crates/pipewire-sys-0.7.0/src/lib.rs
--- modcargo-crates/pipewire-sys-0.7.0/src/lib.rs.orig
+++ modcargo-crates/pipewire-sys-0.7.0/src/lib.rs
@@ -20,8 +20,8 @@ mod tests {
#[test]
fn init() {
unsafe {
- pw_init(std::ptr::null_mut(), std::ptr::null_mut());
- pw_deinit();
+ pipewire_init(std::ptr::null_mut(), std::ptr::null_mut());
+ pipewire_deinit();
}
}
}

View file

@ -7,7 +7,6 @@
SUBDIR += cups
SUBDIR += cups-bjnp
SUBDIR += cups-filters
SUBDIR += cups-filters,ldap
SUBDIR += cups-pdf
SUBDIR += cups-pk-helper
SUBDIR += detex
@ -31,8 +30,10 @@
SUBDIR += l2a
SUBDIR += latex-mk
SUBDIR += lcdf-typetools
SUBDIR += libcupsfilters
SUBDIR += libharu
SUBDIR += libpaper
SUBDIR += libppd
SUBDIR += libspectre
SUBDIR += lilypond
SUBDIR += lout

View file

@ -1,99 +1,55 @@
BROKEN-alpha= ICE in cupsfilters/image-jpeg.c:316
BROKEN-hppa= ICE on filter/pdftopdf/qpdf_pdftopdf.cc:147
COMMENT= OpenPrinting CUPS filters
COMMENT= OpenPrinting CUPS filters
V= 2.0.0
DISTNAME= cups-filters-${V}
V= 1.28.17
DISTNAME= cups-filters-${V}
REVISION= 0
CATEGORIES= print
CATEGORIES= print
HOMEPAGE= https://wiki.linuxfoundation.org/openprinting/cups-filters
SHARED_LIBS += cupsfilters 1.2 # 1.0
SHARED_LIBS += fontembed 1.0 # 1.0
HOMEPAGE= https://wiki.linuxfoundation.org/openprinting/cups-filters
MAINTAINER= Antoine Jacoutot <ajacoutot@openbsd.org>
MAINTAINER= Antoine Jacoutot <ajacoutot@openbsd.org>
# GPLv3 - LGPLv2 - GPLv2+ - MIT
PERMIT_PACKAGE= Yes
PERMIT_PACKAGE= Yes
WANTLIB += ${COMPILER_LIBCXX} avahi-client avahi-common avahi-glib
WANTLIB += brotlidec brotlienc c crypto cups dbus-1 execinfo exif
WANTLIB += expat ffi fontconfig freetype gio-2.0 glib-2.0 gmodule-2.0
WANTLIB += gmp gnutls gobject-2.0 hogweed iconv idn2 intl jpeg
WANTLIB += lcms2 lzma m nettle openjp2 p11-kit pcre2-8 png poppler
WANTLIB += poppler-cpp qpdf ssl tasn1 tiff unistring z zstd
WANTLIB += avahi-client avahi-common brotlidec brotlienc c crypto
WANTLIB += cups cupsfilters dbus-1 execinfo exif expat fontconfig
WANTLIB += freetype gmp hogweed iconv idn2 intl jpeg lcms2 lzma
WANTLIB += m nettle p11-kit png poppler-cpp ppd pthread qpdf ssl
WANTLIB += tasn1 tiff unistring z zstd
MASTER_SITES= https://github.com/OpenPrinting/cups-filters/releases/download/${V}/
MASTER_SITES= https://github.com/OpenPrinting/cups-filters/releases/download/${V}/
# cc1plus: error: unrecognized command line option "-std=c++0x"
COMPILER= base-clang ports-gcc
COMPILER= base-clang ports-gcc
USE_GMAKE= Yes
USE_GMAKE= Yes
.if ${MACHINE_ARCH} == "hppa"
CFLAGS += -O0
.endif
# default is: --with-pdftops=hybrid (pdftops+gs)
BUILD_DEPENDS= print/ghostscript/gnu \
print/poppler,-utils
RUN_DEPENDS= print/ghostscript/gnu \
print/poppler,-utils
LIB_DEPENDS= graphics/libexif \
net/avahi,-glib \
print/cups,-libs \
print/poppler \
print/qpdf
LIB_DEPENDS= print/libcupsfilters>=2.0.0 \
print/libppd \
print/qpdf
# make it easier for users: bring in foomatic-db and allow the
# regeneration of PPD files from share/foomatic/db/source/*/*.xml
RUN_DEPENDS += print/foomatic-db-engine
RUN_DEPENDS += print/foomatic-db-engine
# don't enforce dependency on colord; it'll be used if found at runtime
#RUN_DEPENDS += graphics/colord
FAKE_FLAGS= pkgfontconfigdir=${PREFIX}/share/examples/cups-filters \
pkgcupsserverrootdir=${PREFIX}/share/examples/cups-filters/cups
FAKE_FLAGS= pkgfontconfigdir=${PREFIX}/share/examples/cups-filters \
pkgcupsserverrootdir=${PREFIX}/share/examples/cups-filters/cups
CONFIGURE_STYLE= gnu
CONFIGURE_STYLE=gnu
CONFIGURE_ENV= CPPFLAGS="-I${X11BASE}/include -I${LOCALBASE}/include" \
LDFLAGS="-L${X11BASE}/lib -L${LOCALBASE}/lib"
CONFIGURE_ARGS= --with-gs-path=${LOCALBASE}/bin/gs \
--with-test-font-path=${X11BASE}/lib/X11/fonts/TTF/DejaVuSans.ttf \
--with-shell=/bin/ksh \
--without-php \
--with-pdftops-path=${LOCALBASE}/bin/pdftops \
--disable-braille \
--disable-mutool
FLAVORS= ldap
FLAVOR?=
.if ${FLAVOR:Mldap}
WANTLIB += lber ldap sasl2
LIB_DEPENDS += databases/openldap
.else
CONFIGURE_ARGS += --disable-ldap
.endif
CONFIGURE_ARGS= --with-shell=/bin/ksh \
--disable-mutool
DEBUG_PACKAGES= ${BUILD_PACKAGES}
pre-configure:
sed -i -e 's,/usr/share/cups,${LOCALBASE}/share/cups,g;' \
-e 's,/usr/bin,${LOCALBASE}/bin,g' \
${WRKSRC}/filter/{gstoraster.c,gstopxl}
sed -i 's,/etc/cups,${SYSCONFDIR}/cups,g' \
${WRKSRC}/filter/foomatic-rip/spooler.c
sed -i 's,/usr/local,${LOCALBASE},g' \
${WRKSRC}/filter/foomatic-rip/foomaticrip.c
post-install:
rm -rf ${WRKINST}/rc?.d
# handle old filters looking for these
cd ${PREFIX}/libexec/cups/filter && ln -s gstopxl pstopxl
cd ${PREFIX}/libexec/cups/filter && ln -s gstoraster pstoraster

View file

@ -1,2 +1,2 @@
SHA256 (cups-filters-1.28.17.tar.gz) = AaKsvWu3jwljgEfk6c4wXX5e9Mue1pSWcrXZAbcyHdQ=
SIZE (cups-filters-1.28.17.tar.gz) = 1996729
SHA256 (cups-filters-2.0.0.tar.gz) = cJpPgVJU+8UerIpHp07i4qvxObV7hzQNC2K/Ao4Dl5I=
SIZE (cups-filters-2.0.0.tar.gz) = 642362

View file

@ -1,173 +0,0 @@
From 93e60d3df358c0ae6f3dba79e1c9684657683d89 Mon Sep 17 00:00:00 2001
From: Till Kamppeter <till.kamppeter@gmail.com>
Date: Wed, 17 May 2023 11:11:29 +0200
Subject: [PATCH] beh backend: Use execv() instead of system() - CVE-2023-24805
Index: backend/beh.c
--- backend/beh.c.orig
+++ backend/beh.c
@@ -22,12 +22,13 @@
#include "backend-private.h"
#include <cups/array.h>
#include <ctype.h>
+#include <sys/wait.h>
/*
* Local globals...
*/
-static int job_canceled = 0; /* Set to 1 on SIGTERM */
+static volatile int job_canceled = 0; /* Set to 1 on SIGTERM */
/*
* Local functions...
@@ -213,21 +214,40 @@ call_backend(char *uri, /* I - URI of
char **argv, /* I - Command-line arguments */
char *filename) { /* I - File name of input data */
const char *cups_serverbin; /* Location of programs */
+ char *backend_argv[8]; /* Arguments for backend */
char scheme[1024], /* Scheme from URI */
*ptr, /* Pointer into scheme */
- cmdline[65536]; /* Backend command line */
- int retval;
+ backend_path[2048]; /* Backend path */
+ int pid = 0, /* Process ID of backend */
+ wait_pid, /* Process ID from wait() */
+ wait_status, /* Status from child */
+ retval = 0;
+ int bytes;
/*
* Build the backend command line...
*/
- strncpy(scheme, uri, sizeof(scheme) - 1);
- if (strlen(uri) > 1023)
- scheme[1023] = '\0';
+ scheme[0] = '\0';
+ strncat(scheme, uri, sizeof(scheme) - 1);
if ((ptr = strchr(scheme, ':')) != NULL)
*ptr = '\0';
-
+ else {
+ fprintf(stderr,
+ "ERROR: beh: Invalid URI, no colon (':') to mark end of scheme part.\n");
+ exit (CUPS_BACKEND_FAILED);
+ }
+ if (strchr(scheme, '/')) {
+ fprintf(stderr,
+ "ERROR: beh: Invalid URI, scheme contains a slash ('/').\n");
+ exit (CUPS_BACKEND_FAILED);
+ }
+ if (!strcmp(scheme, ".") || !strcmp(scheme, "..")) {
+ fprintf(stderr,
+ "ERROR: beh: Invalid URI, scheme (\"%s\") is a directory.\n",
+ scheme);
+ exit (CUPS_BACKEND_FAILED);
+ }
if ((cups_serverbin = getenv("CUPS_SERVERBIN")) == NULL)
cups_serverbin = CUPS_SERVERBIN;
@@ -235,17 +255,30 @@ call_backend(char *uri, /* I - URI of
fprintf(stderr,
"ERROR: beh: Direct output into a file not supported.\n");
exit (CUPS_BACKEND_FAILED);
- } else
- snprintf(cmdline, sizeof(cmdline),
- "%s/backend/%s '%s' '%s' '%s' '%s' '%s' %s",
- cups_serverbin, scheme, argv[1], argv[2], argv[3],
- /* Apply number of copies only if beh was called with a
- file name and not with the print data in stdin, as
- backends should handle copies only if they are called
- with a file name */
- (argc == 6 ? "1" : argv[4]),
- argv[5], filename);
+ }
+ backend_argv[0] = uri;
+ backend_argv[1] = argv[1];
+ backend_argv[2] = argv[2];
+ backend_argv[3] = argv[3];
+ /* Apply number of copies only if beh was called with a file name
+ and not with the print data in stdin, as backends should handle
+ copies only if they are called with a file name */
+ backend_argv[4] = (argc == 6 ? "1" : argv[4]);
+ backend_argv[5] = argv[5];
+ backend_argv[6] = filename;
+ backend_argv[7] = NULL;
+
+ bytes = snprintf(backend_path, sizeof(backend_path),
+ "%s/backend/%s", cups_serverbin, scheme);
+ if (bytes < 0 || bytes >= sizeof(backend_path))
+ {
+ fprintf(stderr,
+ "ERROR: beh: Invalid scheme (\"%s\"), could not determing backend path.\n",
+ scheme);
+ return (CUPS_BACKEND_FAILED);
+ }
+
/*
* Overwrite the device URI and run the actual backend...
*/
@@ -253,18 +286,44 @@ call_backend(char *uri, /* I - URI of
setenv("DEVICE_URI", uri, 1);
fprintf(stderr,
- "DEBUG: beh: Executing backend command line \"%s\"...\n",
- cmdline);
+ "DEBUG: beh: Executing backend command line \"%s '%s' '%s' '%s' '%s' '%s' %s\"...\n",
+ backend_path, backend_argv[1], backend_argv[2], backend_argv[3],
+ backend_argv[4], backend_argv[5], backend_argv[6]);
fprintf(stderr,
"DEBUG: beh: Using device URI: %s\n",
uri);
- retval = system(cmdline) >> 8;
+ if ((pid = fork()) == 0) {
+ /*
+ * Child comes here...
+ */
- if (retval == -1)
+ /* Run the backend */
+ execv(backend_path, backend_argv);
+
fprintf(stderr, "ERROR: Unable to execute backend command line: %s\n",
strerror(errno));
+ exit(1);
+ } else if (pid < 0) {
+ /*
+ * Unable to fork!
+ */
+
+ return (CUPS_BACKEND_FAILED);
+ }
+
+ while ((wait_pid = wait(&wait_status)) < 0 && errno == EINTR);
+
+ if (wait_pid >= 0 && wait_status) {
+ if (WIFEXITED(wait_status))
+ retval = WEXITSTATUS(wait_status);
+ else if (WTERMSIG(wait_status) != SIGTERM)
+ retval = WTERMSIG(wait_status);
+ else
+ retval = 0;
+ }
+
return (retval);
}
@@ -277,8 +336,10 @@ static void
sigterm_handler(int sig) { /* I - Signal number (unused) */
(void)sig;
- fprintf(stderr,
- "DEBUG: beh: Job canceled.\n");
+ const char * const msg = "DEBUG: beh: Job canceled.\n";
+ /* The if() is to eliminate the return value and silence the warning
+ about an unused return value. */
+ if (write(2, msg, strlen(msg)));
if (job_canceled)
_exit(CUPS_BACKEND_OK);

View file

@ -0,0 +1,16 @@
https://github.com/OpenPrinting/cups-filters/pull/548
Index: backend/serial.c
--- backend/serial.c.orig
+++ backend/serial.c
@@ -818,8 +818,8 @@ list_devices(void)
{
#if defined(__sun) || defined(__FreeBSD__) || defined(__OpenBSD__) || defined(__DragonFly__) || defined(__FreeBSD_kernel__)
static char *funky_hex = "0123456789abcdefghijklmnopqrstuvwxyz";
- // Funky hex numbering used for some *
- * devices
+ /* Funky hex numbering used for some *
+ * devices */
#endif // __sun || __FreeBSD__ || __OpenBSD__ || __FreeBSD_kernel__

View file

@ -1,6 +1,3 @@
This package provides additional CUPS filters which are not provided by
the CUPS project itself. This includes filters for a PDF based printing
workflow.
Available flavor:
ldap support for browsing remote printer queues via LDAP

View file

@ -2,37 +2,14 @@
@conflict ghostscript-<9.06p3
@conflict foomatic-filters-*
@pkgpath print/foomatic-filters
@pkgpath print/cups-filters,ldap
@rcscript ${RCDIR}/cups_browsed
bin/driverless
bin/driverless-fax
bin/foomatic-rip
include/cupsfilters/
include/cupsfilters/colord.h
include/cupsfilters/colormanager.h
include/cupsfilters/driver.h
include/cupsfilters/image.h
include/cupsfilters/ipp.h
include/cupsfilters/pdftoippprinter.h
include/cupsfilters/ppdgenerator.h
include/cupsfilters/raster.h
include/fontembed/
include/fontembed/bitset.h
include/fontembed/embed.h
include/fontembed/fontfile.h
include/fontembed/iofn.h
include/fontembed/sfnt.h
@static-lib lib/libcupsfilters.a
lib/libcupsfilters.la
@lib lib/libcupsfilters.so.${LIBcupsfilters_VERSION}
@static-lib lib/libfontembed.a
lib/libfontembed.la
@lib lib/libfontembed.so.${LIBfontembed_VERSION}
lib/pkgconfig/libcupsfilters.pc
lib/pkgconfig/libfontembed.pc
@bin libexec/cups/backend/beh
libexec/cups/backend/driverless
libexec/cups/backend/driverless-fax
@bin libexec/cups/backend/implicitclass
@bin libexec/cups/backend/parallel
@bin libexec/cups/backend/serial
@bin libexec/cups/driver/driverless
@ -41,76 +18,48 @@ libexec/cups/driver/driverless-fax
@bin libexec/cups/filter/commandtoescpx
@bin libexec/cups/filter/commandtopclx
@bin libexec/cups/filter/foomatic-rip
libexec/cups/filter/gstopdf
libexec/cups/filter/gstopxl
@bin libexec/cups/filter/gstopdf
@bin libexec/cups/filter/gstopxl
@bin libexec/cups/filter/gstoraster
@bin libexec/cups/filter/imagetopdf
libexec/cups/filter/imagetops
@bin libexec/cups/filter/imagetops
@bin libexec/cups/filter/imagetoraster
@bin libexec/cups/filter/pclmtoraster
@bin libexec/cups/filter/pdftopdf
@bin libexec/cups/filter/pdftops
@bin libexec/cups/filter/pdftoraster
libexec/cups/filter/pstopxl
libexec/cups/filter/pstoraster
@bin libexec/cups/filter/pwgtopclm
@bin libexec/cups/filter/pwgtopdf
@bin libexec/cups/filter/pwgtoraster
@bin libexec/cups/filter/rastertoescpx
libexec/cups/filter/rastertopclm
@bin libexec/cups/filter/rastertopclx
@bin libexec/cups/filter/rastertopdf
@bin libexec/cups/filter/rastertops
@bin libexec/cups/filter/sys5ippprinter
@bin libexec/cups/filter/texttopdf
libexec/cups/filter/texttops
@bin libexec/cups/filter/texttotext
@bin libexec/cups/filter/universal
@man man/man1/driverless.1
@man man/man1/foomatic-rip.1
@man man/man5/cups-browsed.conf.5
@man man/man8/cups-browsed.8
@bin sbin/cups-browsed
share/cups/banners/classified
share/cups/banners/confidential
share/cups/banners/form
share/cups/banners/secret
share/cups/banners/standard
share/cups/banners/topsecret
share/cups/banners/unclassified
share/cups/charsets/
share/cups/charsets/pdf.utf-8
share/cups/charsets/pdf.utf-8.heavy
share/cups/charsets/pdf.utf-8.simple
share/cups/data/classified.pdf
share/cups/data/confidential.pdf
share/cups/data/default-testpage.pdf
share/cups/data/default.pdf
share/cups/data/form_english.pdf
share/cups/data/form_english_in.odt
share/cups/data/form_russian.pdf
share/cups/data/form_russian_in.odt
share/cups/data/secret.pdf
share/cups/data/standard.pdf
share/cups/data/testprint
share/cups/data/topsecret.pdf
share/cups/data/unclassified.pdf
share/cups/drv/cupsfilters.drv
share/cups/mime/cupsfilters-ghostscript.convs
share/cups/mime/cupsfilters-poppler.convs
share/cups/mime/cupsfilters-universal-postscript.convs
share/cups/mime/cupsfilters-universal.convs
share/cups/mime/cupsfilters.convs
share/cups/mime/cupsfilters.types
share/cups/ppdc/escp.h
share/cups/ppdc/pcl.h
share/doc/cups-filters/
share/doc/cups-filters/ABOUT-NLS
share/doc/cups-filters/AUTHORS
share/doc/cups-filters/CHANGES-1.x.md
share/doc/cups-filters/CHANGES.md
share/doc/cups-filters/CONTRIBUTING.md
share/doc/cups-filters/COPYING
share/doc/cups-filters/DEVELOPING.md
share/doc/cups-filters/INSTALL
share/doc/cups-filters/NEWS
share/doc/cups-filters/README
share/doc/cups-filters/LICENSE
share/doc/cups-filters/NOTICE
share/doc/cups-filters/README.md
share/doc/pkg-readmes/${PKGSTEM}
share/examples/cups-filters/
share/examples/cups-filters/cups/
@mode 0644
share/examples/cups-filters/cups/cups-browsed.conf
@sample ${SYSCONFDIR}/cups/cups-browsed.conf
@mode
share/ppd/
share/ppd/cupsfilters/
share/ppd/cupsfilters/Fuji_Xerox-DocuPrint_CM305_df-PDF.ppd
@ -119,3 +68,5 @@ share/ppd/cupsfilters/HP-Color_LaserJet_CM3530_MFP-PDF.ppd
share/ppd/cupsfilters/Ricoh-PDF_Printer-PDF.ppd
share/ppd/cupsfilters/pxlcolor.ppd
share/ppd/cupsfilters/pxlmono.ppd
share/ppdc/escp.h
share/ppdc/pcl.h

View file

@ -87,10 +87,8 @@ CONFIGURE_ARGS= --enable-static \
--with-system-groups=wheel \
--with-dbusdir=${SYSCONFDIR}/dbus-1 \
--with-printcap=${SYSCONFDIR}/cups/printcap \
--with-smbconfigfile="samba://${SYSCONFDIR}/samba/smb.conf" \
--disable-cdsassl \
--disable-pam \
--disable-systemd
--without-systemd
DEBUG_PACKAGES= ${BUILD_PACKAGES}

View file

@ -0,0 +1,56 @@
COMMENT= library for developing printing filters
V= 2.0.0
DISTNAME= libcupsfilters-${V}
REVISION= 0
SHARED_LIBS += cupsfilters 2.0 # 2.0
CATEGORIES= print devel
HOMEPAGE= https://github.com/OpenPrinting/libcupsfilters
MAINTAINER= Antoine Jacoutot <ajacoutot@openbsd.org>
# Apache-2.0
PERMIT_PACKAGE= Yes
MASTER_SITES= https://github.com/OpenPrinting/libcupsfilters/releases/download/${V}/
WANTLIB += ${COMPILER_LIBCXX} avahi-client avahi-common brotlidec
WANTLIB += brotlienc crypto cups dbus-1 execinfo exif expat fontconfig
WANTLIB += freetype gmp gnutls hogweed iconv idn2 intl jpeg lcms2
WANTLIB += lzma m nettle openjp2 p11-kit png poppler poppler-cpp
WANTLIB += qpdf ssl tasn1 tiff unistring z zstd
# -std=c++17
COMPILER= base-clang ports-gcc
USE_GMAKE= Yes
# CUPS_GHOSTSCRIPT in cupsfilters/ghostscript.c
BUILD_DEPENDS += print/ghostscript/gnu
RUN_DEPENDS += print/ghostscript/gnu
# don't enforce dependency on colord; it'll be used if found at runtime
#RUN_DEPENDS += graphics/colord
LIB_DEPENDS= graphics/libexif \
print/cups,-libs \
print/poppler \
print/qpdf
CONFIGURE_STYLE= gnu
CONFIGURE_ENV= LDFLAGS="-L${LOCALBASE}/lib"
CONFIGURE_ARGS= --with-test-font-path=${X11BASE}/lib/X11/fonts/TTF/DejaVuSans.ttf \
--disable-mutool
# XXX
# /usr/local/include/lcms2.h:1297:44: error: ISO C++17 does not allow 'register' storage class specifier [-Wregister]
# CMSREGISTER void * Cargo);
CXXFLAGS += -DCMS_NO_REGISTER_KEYWORD
DEBUG_PACKAGES= ${BUILD_PACKAGES}
.include <bsd.port.mk>

View file

@ -0,0 +1,2 @@
SHA256 (libcupsfilters-2.0.0.tar.gz) = vD2GtXkxc5D5yymogPQF711ozMnngxtzSn0gbuelUb4=
SIZE (libcupsfilters-2.0.0.tar.gz) = 1642773

View file

@ -0,0 +1,11 @@
Index: cupsfilters/filter.c
--- cupsfilters/filter.c.orig
+++ cupsfilters/filter.c
@@ -18,6 +18,7 @@
#include <math.h>
#include <errno.h>
#include <signal.h>
+#include <sys/stat.h> /* S_IRUSR */
#include <sys/wait.h>
#include <cups/file.h>
#include <cups/array.h>

View file

@ -0,0 +1,17 @@
https://github.com/OpenPrinting/cups-filters/pull/505
Index: cupsfilters/pdftoraster.cxx
--- cupsfilters/pdftoraster.cxx.orig
+++ cupsfilters/pdftoraster.cxx
@@ -2198,7 +2198,11 @@ cfFilterPDFToRaster(int inputfd, // I - Fil
// For compatibility with g++ >= 4.7 compilers _GLIBCXX_THROW
// should be used as a guard, otherwise use traditional definition
#ifndef _GLIBCXX_THROW
+#if __cplusplus < 201703L
#define _GLIBCXX_THROW throw
+#else
+#define _GLIBCXX_THROW(x) noexcept(false)
+#endif
#endif
void * operator new(size_t size) _GLIBCXX_THROW (std::bad_alloc)

View file

@ -0,0 +1,4 @@
Libcupsfilters provides a library, which implements common functions used in
cups-browsed daemon and printing filters, and additional files as banner
templates and character sets.
The filters are used in CUPS daemon and in printer applications.

View file

@ -0,0 +1,54 @@
@conflict cups-filters-<2.0.0
include/cupsfilters/
include/cupsfilters/bitmap.h
include/cupsfilters/catalog.h
include/cupsfilters/colord.h
include/cupsfilters/colormanager.h
include/cupsfilters/driver.h
include/cupsfilters/filter.h
include/cupsfilters/ieee1284.h
include/cupsfilters/image.h
include/cupsfilters/ipp.h
include/cupsfilters/log.h
include/cupsfilters/pdf.h
include/cupsfilters/raster.h
@static-lib lib/libcupsfilters.a
lib/libcupsfilters.la
@lib lib/libcupsfilters.so.${LIBcupsfilters_VERSION}
lib/pkgconfig/libcupsfilters.pc
share/cups/banners/classified
share/cups/banners/confidential
share/cups/banners/form
share/cups/banners/secret
share/cups/banners/standard
share/cups/banners/topsecret
share/cups/banners/unclassified
share/cups/charsets/
share/cups/charsets/pdf.utf-8
share/cups/charsets/pdf.utf-8.heavy
share/cups/charsets/pdf.utf-8.simple
share/cups/data/classified.pdf
share/cups/data/confidential.pdf
share/cups/data/default-testpage.pdf
share/cups/data/default.pdf
share/cups/data/form_english.pdf
share/cups/data/form_english_in.odt
share/cups/data/form_russian.pdf
share/cups/data/form_russian_in.odt
share/cups/data/secret.pdf
share/cups/data/standard.pdf
share/cups/data/testprint
share/cups/data/topsecret.pdf
share/cups/data/unclassified.pdf
share/doc/libcupsfilters/
share/doc/libcupsfilters/ABOUT-NLS
share/doc/libcupsfilters/AUTHORS
share/doc/libcupsfilters/CHANGES-1.x.md
share/doc/libcupsfilters/CHANGES.md
share/doc/libcupsfilters/CONTRIBUTING.md
share/doc/libcupsfilters/COPYING
share/doc/libcupsfilters/DEVELOPING.md
share/doc/libcupsfilters/INSTALL
share/doc/libcupsfilters/LICENSE
share/doc/libcupsfilters/NOTICE
share/doc/libcupsfilters/README.md

51
print/libppd/Makefile Normal file
View file

@ -0,0 +1,51 @@
COMMENT= library for retro-fitting legacy printer drivers
V= 2.0.0
DISTNAME= libppd-${V}
SHARED_LIBS += ppd 0.0 # 2.0
CATEGORIES= print devel
HOMEPAGE= https://github.com/OpenPrinting/libppd
MAINTAINER= Antoine Jacoutot <ajacoutot@openbsd.org>
# Apache-2.0
PERMIT_PACKAGE= Yes
MASTER_SITES= https://github.com/OpenPrinting/libppd/releases/download/${V}/
WANTLIB += ${COMPILER_LIBCXX} avahi-client avahi-common brotlidec
WANTLIB += brotlienc c crypto cups cupsfilters dbus-1 execinfo
WANTLIB += exif expat fontconfig freetype gmp hogweed iconv idn2
WANTLIB += intl jpeg lcms2 lzma m nettle p11-kit png poppler-cpp
WANTLIB += qpdf ssl tasn1 tiff unistring z zstd
# -std=gnu11
COMPILER= base-clang ports-gcc
USE_GMAKE= Yes
# default is: --with-pdftops=hybrid (pdftops+gs)
BUILD_DEPENDS += print/ghostscript/gnu \
print/poppler,-utils
RUN_DEPENDS += print/ghostscript/gnu \
print/poppler,-utils
LIB_DEPENDS= print/libcupsfilters
CONFIGURE_STYLE= gnu
CONFIGURE_ARGS= --disable-mutool \
--enable-testppdfile
# XXX conflict with CUPS 2.X; wait for CUPS 3.X
#CONFIGURE_ARGS += --enable-ppdc-utils
# default to /usr/bin/pdftops
CONFIGURE_ARGS += --with-pdftops-path=${LOCALBASE}/bin/pdftops
DEBUG_PACKAGES= ${BUILD_PACKAGES}
.include <bsd.port.mk>

2
print/libppd/distinfo Normal file
View file

@ -0,0 +1,2 @@
SHA256 (libppd-2.0.0.tar.gz) = 9Je/Y3ASKaZDLK1K+l0rAvbvEk7E9DNGoA1blKi68FM=
SIZE (libppd-2.0.0.tar.gz) = 844183

4
print/libppd/pkg/DESCR Normal file
View file

@ -0,0 +1,4 @@
Libppd provides all PPD related function/API which is going to be removed from
CUPS 3.X, but are still required for retro-fitting support of legacy printers.
The library is meant only for retro-fitting printer applications, any new
printer drivers have to be written as native printer application without libppd.

28
print/libppd/pkg/PLIST Normal file
View file

@ -0,0 +1,28 @@
@bin bin/testppdfile
include/ppd/
include/ppd/ppd-filter.h
include/ppd/ppd.h
include/ppd/ppdc.h
@static-lib lib/libppd.a
lib/libppd.la
@lib lib/libppd.so.${LIBppd_VERSION}
lib/pkgconfig/libppd.pc
share/doc/libppd/
share/doc/libppd/ABOUT-NLS
share/doc/libppd/AUTHORS
share/doc/libppd/CHANGES-1.x.md
share/doc/libppd/CHANGES.md
share/doc/libppd/CONTRIBUTING.md
share/doc/libppd/COPYING
share/doc/libppd/DEVELOPING.md
share/doc/libppd/INSTALL
share/doc/libppd/LICENSE
share/doc/libppd/NOTICE
share/doc/libppd/README.md
share/ppdc/
share/ppdc/epson.h
share/ppdc/font.defs
share/ppdc/hp.h
share/ppdc/label.h
share/ppdc/media.defs
share/ppdc/raster.defs

View file

@ -4,10 +4,7 @@ COMMENT= SSL/TLS scanner (identify version, ciphers, etc)
USE_NOEXECONLY= Yes
.endif
GH_ACCOUNT= rbsec
GH_PROJECT= sslscan
GH_TAGNAME= 2.1.0
REVISION = 0
DIST_TUPLE= github rbsec sslscan 2.1.1 .
CATEGORIES= security net
@ -19,7 +16,7 @@ MAINTAINER= Stuart Henderson <stu.ports@spacehopper.org>
PERMIT_PACKAGE= Yes
COMPILER= base-clang ports-gcc
COMPILER_LANGS = c
COMPILER_LANGS= c
WANTLIB += c pthread z

View file

@ -1,2 +1,2 @@
SHA256 (sslscan-2.1.0.tar.gz) = MUCvBV8GdBGnJvEGHY1/154I/UKG4ijcOiMAZ7VwSnI=
SIZE (sslscan-2.1.0.tar.gz) = 113646
SHA256 (rbsec-sslscan-2.1.1.tar.gz) = zLH/zJfL3lwYRULevirDUp4sZLNpCkArWS7U7jdJVeE=
SIZE (rbsec-sslscan-2.1.1.tar.gz) = 113738

View file

@ -51,7 +51,7 @@ Index: Makefile
opensslpull:
@@ -133,6 +140,7 @@ opensslpull:
else \
git clone --depth 1 -b `git ls-remote https://github.com/openssl/openssl | grep -Eo '(openssl-3\.0\.[0-9]+)' | sort --version-sort | tail -n 1` https://github.com/openssl/openssl ./openssl && cd ./openssl && touch ../.openssl.is.fresh ; \
git clone --depth 1 -b `git ls-remote https://github.com/openssl/openssl | grep -Eo '(openssl-3\.0\.[0-9]+)' | sort -V | tail -n 1` https://github.com/openssl/openssl ./openssl && cd ./openssl && touch ../.openssl.is.fresh ; \
fi
+endif

View file

@ -1,6 +1,6 @@
COMMENT = list obsolete files between OpenBSD upgrades
V = 3.4
V = 3.5
DISTNAME = sysclean-${V}
CATEGORIES = sysutils

View file

@ -1,2 +1,2 @@
SHA256 (sysclean-3.4.tar.gz) = xn3fcWUikfiIO3e0JknDw3xnf1DHBi+raJ8Vc4ht5VA=
SIZE (sysclean-3.4.tar.gz) = 7595
SHA256 (sysclean-3.5.tar.gz) = Xt1rbSz5aTYgFNktNaDLsMpa7dFzR7jVJxu5nfU9eKo=
SIZE (sysclean-3.5.tar.gz) = 7596

View file

@ -6,7 +6,7 @@ DPB_PROPERTIES= parallel parallel2
COMMENT= Chromium browser
V= 117.0.5938.88
V= 117.0.5938.92
DISTNAME= chromium-${V}

View file

@ -1,10 +1,10 @@
SHA256 (chrome-linux-117.0.5938.88-llvm13.profdata.tar.xz) = vKZTdUUFIyGeL5bPhR+2uPUSWpn4aI8vcormPRq80Uk=
SHA256 (chromium-117.0.5938.88-testdata.tar.xz) = xSVpl2R7ywWkuCnZnp78+n4bxGtEqf7OtnqRhW7VQIU=
SHA256 (chromium-117.0.5938.88.tar.xz) = RpHYADnkFV0aPEZ27mih5SbdrWGjz1n2XVlqGi1WyQY=
SHA256 (chrome-linux-117.0.5938.92-llvm13.profdata.tar.xz) = q0ALm0U6kNqT6x+FmeKy/EierqEwQbJYi2jnv7uNM6E=
SHA256 (chromium-117.0.5938.92-testdata.tar.xz) = tOUypaa00tFwNXrSz+lRAqOz7mm1NaRt+a7TpkxwBEQ=
SHA256 (chromium-117.0.5938.92.tar.xz) = ZcpJGSeQJVfK/DhMh5tWfDcosG/I6gxGxF4vDOVDNCw=
SHA256 (libudev-openbsd-20221108-c3330efd.tar.gz) = BBKUTWeCkarFwKZQ+eg9DfekIMr5xi2G4Lce0C43pnc=
SHA256 (test_fonts-336e775eec536b2d785cc80eff6ac39051931286.tar.gz) = osopYtr0gqj5QxY1QeHHO6SyaU+rzSUQmB8ttO2kk8g=
SIZE (chrome-linux-117.0.5938.88-llvm13.profdata.tar.xz) = 28704844
SIZE (chromium-117.0.5938.88-testdata.tar.xz) = 269473360
SIZE (chromium-117.0.5938.88.tar.xz) = 3131921384
SIZE (chrome-linux-117.0.5938.92-llvm13.profdata.tar.xz) = 28701408
SIZE (chromium-117.0.5938.92-testdata.tar.xz) = 269661528
SIZE (chromium-117.0.5938.92.tar.xz) = 3139036620
SIZE (libudev-openbsd-20221108-c3330efd.tar.gz) = 32757
SIZE (test_fonts-336e775eec536b2d785cc80eff6ac39051931286.tar.gz) = 32624734