sync ports with The Matrix
This commit is contained in:
parent
0d1a3e8dd8
commit
4cc63679be
4 changed files with 69 additions and 12 deletions
|
@ -6,7 +6,7 @@ DISTNAME = anthy-$V
|
|||
PKGNAME-main = anthy-$V
|
||||
PKGNAME-emacs = emacs-anthy-$V
|
||||
REVISION-main = 3
|
||||
REVISION-emacs = 7
|
||||
REVISION-emacs = 8
|
||||
|
||||
SHARED_LIBS += anthydic 1.0 # .1.0
|
||||
SHARED_LIBS += anthy 1.0 # .1.0
|
||||
|
|
|
@ -4,6 +4,15 @@
|
|||
Index: src-util/anthy.el
|
||||
--- src-util/anthy.el.orig
|
||||
+++ src-util/anthy.el
|
||||
@@ -71,7 +71,7 @@
|
||||
(defvar anthy-highlight-face nil)
|
||||
(defvar anthy-underline-face nil)
|
||||
(copy-face 'highlight 'anthy-highlight-face)
|
||||
-(set-face-underline-p 'anthy-highlight-face t)
|
||||
+(set-face-underline 'anthy-highlight-face t)
|
||||
(copy-face 'underline 'anthy-underline-face)
|
||||
|
||||
;;
|
||||
@@ -161,11 +161,11 @@
|
||||
|
||||
;; From skk-macs.el From viper-util.el. Welcome!
|
||||
|
|
|
@ -1,6 +1,7 @@
|
|||
COMMENT = sound channel mixer and volume control
|
||||
DISTNAME = kmix-${VERSION}
|
||||
CATEGORIES = audio
|
||||
REVISION = 0
|
||||
|
||||
HOMEPAGE = https://apps.kde.org/kmix
|
||||
|
||||
|
|
|
@ -1,16 +1,63 @@
|
|||
Index: CMakeLists.txt
|
||||
--- CMakeLists.txt.orig
|
||||
+++ CMakeLists.txt
|
||||
@@ -261,9 +261,9 @@ if (HAVE_OSS_3)
|
||||
set(kmix_backend_SRCS ${kmix_backend_SRCS} backends/mixer_oss.cpp)
|
||||
@@ -124,33 +124,33 @@ if (HAVE_SOUNDCARD_H OR HAVE_SYS_SOUNDCARD_H)
|
||||
#message(STATUS "TEST_COMPILE_RESULT= ${TEST_COMPILE_RESULT}")
|
||||
#message(STATUS "TEST_RESULT_VERSION= ${TEST_RESULT_VERSION}")
|
||||
|
||||
- if (${TEST_COMPILE_RESULT} AND (${TEST_RUN_RESULT} EQUAL 0))
|
||||
- message(STATUS "Detected OSS version ${TEST_RESULT_VERSION}")
|
||||
- if (${TEST_RESULT_VERSION} GREATER_EQUAL 0x040000)
|
||||
- message(STATUS "Building with OSS 4 support")
|
||||
- set(HAVE_OSS_4 true)
|
||||
- add_definitions(-DHAVE_OSS_4)
|
||||
- set(SUPPORTED_BACKENDS ${SUPPORTED_BACKENDS} "OSS4")
|
||||
+ #if (${TEST_COMPILE_RESULT} AND (${TEST_RUN_RESULT} EQUAL 0))
|
||||
+ # message(STATUS "Detected OSS version ${TEST_RESULT_VERSION}")
|
||||
+ # if (${TEST_RESULT_VERSION} GREATER_EQUAL 0x040000)
|
||||
+ # message(STATUS "Building with OSS 4 support")
|
||||
+ # set(HAVE_OSS_4 true)
|
||||
+ # add_definitions(-DHAVE_OSS_4)
|
||||
+ # set(SUPPORTED_BACKENDS ${SUPPORTED_BACKENDS} "OSS4")
|
||||
|
||||
- # This is included in 4Front OSS 4 but not in standard BSD.
|
||||
- # Not possible to test at compile time. Both of those appear
|
||||
- # to have sys/soundcard.h and not soundcard.h installed.
|
||||
- check_struct_has_member(oss_mixerinfo devnode sys/soundcard.h HAVE_MIXERINFO_DEVNODE)
|
||||
- if (HAVE_MIXERINFO_DEVNODE)
|
||||
- add_definitions(-DHAVE_MIXERINFO_DEVNODE)
|
||||
- endif ()
|
||||
- else ()
|
||||
- message(STATUS "Building with OSS 3 support")
|
||||
- set(HAVE_OSS_3 true)
|
||||
- add_definitions(-DHAVE_OSS_3)
|
||||
- set(SUPPORTED_BACKENDS ${SUPPORTED_BACKENDS} "OSS")
|
||||
- endif ()
|
||||
- else ()
|
||||
- message(STATUS "Unable to get OSS version, assuming 3")
|
||||
- set(HAVE_OSS_3 true)
|
||||
- add_definitions(-DHAVE_OSS_3)
|
||||
- set(SUPPORTED_BACKENDS ${SUPPORTED_BACKENDS} "OSS")
|
||||
- endif ()
|
||||
+ # # This is included in 4Front OSS 4 but not in standard BSD.
|
||||
+ # # Not possible to test at compile time. Both of those appear
|
||||
+ # # to have sys/soundcard.h and not soundcard.h installed.
|
||||
+ # check_struct_has_member(oss_mixerinfo devnode sys/soundcard.h HAVE_MIXERINFO_DEVNODE)
|
||||
+ # if (HAVE_MIXERINFO_DEVNODE)
|
||||
+ # add_definitions(-DHAVE_MIXERINFO_DEVNODE)
|
||||
+ # endif ()
|
||||
+ # else ()
|
||||
+ # message(STATUS "Building with OSS 3 support")
|
||||
+ # set(HAVE_OSS_3 true)
|
||||
+ # add_definitions(-DHAVE_OSS_3)
|
||||
+ # set(SUPPORTED_BACKENDS ${SUPPORTED_BACKENDS} "OSS")
|
||||
+ # endif ()
|
||||
+ #else ()
|
||||
+ # message(STATUS "Unable to get OSS version, assuming 3")
|
||||
+ # set(HAVE_OSS_3 true)
|
||||
+ # add_definitions(-DHAVE_OSS_3)
|
||||
+ # set(SUPPORTED_BACKENDS ${SUPPORTED_BACKENDS} "OSS")
|
||||
+ #endif ()
|
||||
endif ()
|
||||
|
||||
-if (HAVE_OSS_4)
|
||||
- set(kmix_backend_SRCS ${kmix_backend_SRCS} backends/mixer_oss4.cpp)
|
||||
-endif ()
|
||||
+#if (HAVE_OSS_4)
|
||||
+# set(kmix_backend_SRCS ${kmix_backend_SRCS} backends/mixer_oss4.cpp)
|
||||
+#endif ()
|
||||
|
||||
####################################################################################################
|
||||
########### target: kmixcore library ###############################################################
|
||||
# PulseAudio, optional
|
||||
|
|
Loading…
Add table
Add a link
Reference in a new issue