UPDATE: lang/python 3.11.9 > 3.11.10
This commit is contained in:
parent
c1886eef17
commit
40b4e1a5e9
14 changed files with 131 additions and 28 deletions
|
@ -3,12 +3,12 @@
|
|||
# requirement of the PSF license, if it constitutes a change to
|
||||
# Python itself.
|
||||
|
||||
FULL_VERSION = 3.11.9
|
||||
FULL_VERSION = 3.11.10
|
||||
SHARED_LIBS = python3.11 0.0
|
||||
VERSION_SPEC = >=3.11,<3.12
|
||||
PORTROACH = limit:^3\.11
|
||||
|
||||
REVISION = 2
|
||||
REVISION = 0
|
||||
|
||||
CONFIGURE_ENV += ac_cv_working_openssl_hashlib=yes \
|
||||
TCLTK_CFLAGS="-I${MODTCL_INCDIR} -I${MODTK_INCDIR} -I${X11BASE}/include" \
|
||||
|
|
|
@ -1,2 +1,2 @@
|
|||
SHA256 (Python-3.11.9.tgz) = 594yQKi8Kx4bpcgb+UPwaGH/SUtp/amQzicipQTGFT0=
|
||||
SIZE (Python-3.11.9.tgz) = 26521757
|
||||
SHA256 (Python-3.11.10.tgz) = kvL68kJoG/pAbVOlHhfULFNzr/4joTDNlpfhMu9XRwY=
|
||||
SIZE (Python-3.11.10.tgz) = 26532827
|
||||
|
|
12
lang/python/3/patches/patch-Lib_test_test_crypt_py
Normal file
12
lang/python/3/patches/patch-Lib_test_test_crypt_py
Normal file
|
@ -0,0 +1,12 @@
|
|||
Index: Lib/test/test_crypt.py
|
||||
--- Lib/test/test_crypt.py.orig
|
||||
+++ Lib/test/test_crypt.py
|
||||
@@ -54,7 +54,7 @@ class CryptTestCase(unittest.TestCase):
|
||||
|
||||
def test_methods(self):
|
||||
self.assertTrue(len(crypt.methods) >= 1)
|
||||
- if sys.platform.startswith('openbsd'):
|
||||
+ if sys.platform.startswith('secbsd'):
|
||||
self.assertEqual(crypt.methods, [crypt.METHOD_BLOWFISH])
|
||||
else:
|
||||
self.assertEqual(crypt.methods[-1], crypt.METHOD_CRYPT)
|
12
lang/python/3/patches/patch-Lib_test_test_faulthandler_py
Normal file
12
lang/python/3/patches/patch-Lib_test_test_faulthandler_py
Normal file
|
@ -0,0 +1,12 @@
|
|||
Index: Lib/test/test_faulthandler.py
|
||||
--- Lib/test/test_faulthandler.py.orig
|
||||
+++ Lib/test/test_faulthandler.py
|
||||
@@ -284,7 +284,7 @@ class FaultHandlerTests(unittest.TestCase):
|
||||
def test_fatal_error_without_gil(self):
|
||||
self.check_fatal_error_func(True)
|
||||
|
||||
- @unittest.skipIf(sys.platform.startswith('openbsd'),
|
||||
+ @unittest.skipIf(sys.platform.startswith('secbsd'),
|
||||
"Issue #12868: sigaltstack() doesn't work on "
|
||||
"OpenBSD if Python is compiled with pthread")
|
||||
@unittest.skipIf(not hasattr(faulthandler, '_stack_overflow'),
|
12
lang/python/3/patches/patch-Lib_test_test_fcntl_py
Normal file
12
lang/python/3/patches/patch-Lib_test_test_fcntl_py
Normal file
|
@ -0,0 +1,12 @@
|
|||
Index: Lib/test/test_fcntl.py
|
||||
--- Lib/test/test_fcntl.py.orig
|
||||
+++ Lib/test/test_fcntl.py
|
||||
@@ -24,7 +24,7 @@ def get_lockdata():
|
||||
else:
|
||||
start_len = "qq"
|
||||
|
||||
- if (sys.platform.startswith(('netbsd', 'freebsd', 'openbsd'))
|
||||
+ if (sys.platform.startswith(('netbsd', 'freebsd', 'openbsd', 'secbsd'))
|
||||
or sys.platform == 'darwin'):
|
||||
if struct.calcsize('l') == 8:
|
||||
off_t = 'l'
|
12
lang/python/3/patches/patch-Lib_test_test_subprocess_py
Normal file
12
lang/python/3/patches/patch-Lib_test_test_subprocess_py
Normal file
|
@ -0,0 +1,12 @@
|
|||
Index: Lib/test/test_subprocess.py
|
||||
--- Lib/test/test_subprocess.py.orig
|
||||
+++ Lib/test/test_subprocess.py
|
||||
@@ -2440,7 +2440,7 @@ class POSIXProcessTestCase(BaseTestCase):
|
||||
getattr(p, method)(*args)
|
||||
return p
|
||||
|
||||
- @unittest.skipIf(sys.platform.startswith(('netbsd', 'openbsd')),
|
||||
+ @unittest.skipIf(sys.platform.startswith(('netbsd', 'openbsd', 'secbsd')),
|
||||
"Due to known OS bug (issue #16762)")
|
||||
def _kill_dead_process(self, method, *args):
|
||||
# Do not inherit file handles from the parent.
|
12
lang/python/3/patches/patch-Lib_test_test_tempfile_py
Normal file
12
lang/python/3/patches/patch-Lib_test_test_tempfile_py
Normal file
|
@ -0,0 +1,12 @@
|
|||
Index: Lib/test/test_tempfile.py
|
||||
--- Lib/test/test_tempfile.py.orig
|
||||
+++ Lib/test/test_tempfile.py
|
||||
@@ -25,7 +25,7 @@ has_spawnl = hasattr(os, 'spawnl')
|
||||
|
||||
# TEST_FILES may need to be tweaked for systems depending on the maximum
|
||||
# number of files that can be opened at one time (see ulimit -n)
|
||||
-if sys.platform.startswith('openbsd'):
|
||||
+if sys.platform.startswith('secbsd'):
|
||||
TEST_FILES = 48
|
||||
else:
|
||||
TEST_FILES = 100
|
21
lang/python/3/patches/patch-Lib_test_test_threadsignals_py
Normal file
21
lang/python/3/patches/patch-Lib_test_test_threadsignals_py
Normal file
|
@ -0,0 +1,21 @@
|
|||
Index: Lib/test/test_threadsignals.py
|
||||
--- Lib/test/test_threadsignals.py.orig
|
||||
+++ Lib/test/test_threadsignals.py
|
||||
@@ -75,7 +75,7 @@ class ThreadSignals(unittest.TestCase):
|
||||
'Issue 34004: musl does not allow interruption of locks '
|
||||
'by signals.')
|
||||
# Issue #20564: sem_timedwait() cannot be interrupted on OpenBSD
|
||||
- @unittest.skipIf(sys.platform.startswith('openbsd'),
|
||||
+ @unittest.skipIf(sys.platform.startswith('secbsd'),
|
||||
'lock cannot be interrupted on OpenBSD')
|
||||
def test_lock_acquire_interruption(self):
|
||||
# Mimic receiving a SIGINT (KeyboardInterrupt) with SIGALRM while stuck
|
||||
@@ -106,7 +106,7 @@ class ThreadSignals(unittest.TestCase):
|
||||
'Issue 34004: musl does not allow interruption of locks '
|
||||
'by signals.')
|
||||
# Issue #20564: sem_timedwait() cannot be interrupted on OpenBSD
|
||||
- @unittest.skipIf(sys.platform.startswith('openbsd'),
|
||||
+ @unittest.skipIf(sys.platform.startswith('secbsd'),
|
||||
'lock cannot be interrupted on OpenBSD')
|
||||
def test_rlock_acquire_interruption(self):
|
||||
# Mimic receiving a SIGINT (KeyboardInterrupt) with SIGALRM while stuck
|
|
@ -6,7 +6,7 @@ Index: Python/fileutils.c
|
|||
* 2b. If fdwalk(3) isn't available, just do a plain close(2) loop.
|
||||
*/
|
||||
-#ifdef __FreeBSD__
|
||||
+#if defined(__FreeBSD__) || defined(__OpenBSD__) || defined(__SecBSD__)
|
||||
+#if defined(__FreeBSD__) || defined(__OpenBSD__)
|
||||
# define USE_CLOSEFROM
|
||||
-#endif /* __FreeBSD__ */
|
||||
+#endif /* __FreeBSD__ || __OpenBSD__ */
|
||||
|
|
|
@ -1,3 +1,9 @@
|
|||
#1: Set ports library version
|
||||
#2: Don't pick up an installed linux/e2fsprogs libuuid.so
|
||||
#3: llvm-ar (used for LTO) is installed as ar
|
||||
#4: OpenBSD isn't multi-arch
|
||||
#5: Try only the right tcl/tk string
|
||||
|
||||
Index: configure.ac
|
||||
--- configure.ac.orig
|
||||
+++ configure.ac
|
||||
|
@ -15,19 +21,20 @@ Index: configure.ac
|
|||
AC_DEFINE(_BSD_SOURCE, 1, [Define on OpenBSD to activate all library features])
|
||||
;;
|
||||
- OpenBSD/*)
|
||||
+ OpenBSD/* | SecBSD/*)
|
||||
+ OpenBSD/*|SecBSD/*)
|
||||
# OpenBSD undoes our definition of __BSD_VISIBLE if _XOPEN_SOURCE is
|
||||
# also defined. This can be overridden by defining _BSD_SOURCE
|
||||
# As this has a different meaning on Linux, only define it on OpenBSD
|
||||
@@ -1104,6 +1104,7 @@ AC_MSG_CHECKING([for multiarch])
|
||||
@@ -1104,6 +1104,8 @@ AC_MSG_CHECKING([for multiarch])
|
||||
AS_CASE([$ac_sys_system],
|
||||
[Darwin*], [MULTIARCH=""],
|
||||
[FreeBSD*], [MULTIARCH=""],
|
||||
+ [OpenBSD*], [MULTIARCH=""],
|
||||
+ [SecBSD*], [MULTIARCH=""],
|
||||
[MULTIARCH=$($CC --print-multiarch 2>/dev/null)]
|
||||
)
|
||||
AC_SUBST([MULTIARCH])
|
||||
@@ -1493,7 +1494,7 @@ if test $enable_shared = "yes"; then
|
||||
@@ -1493,7 +1495,7 @@ if test $enable_shared = "yes"; then
|
||||
PY3LIBRARY=libpython3.so
|
||||
fi
|
||||
;;
|
||||
|
@ -36,7 +43,7 @@ Index: configure.ac
|
|||
LDLIBRARY='libpython$(LDVERSION).so'
|
||||
BLDLIBRARY='-L. -lpython$(LDVERSION)'
|
||||
RUNSHARED=LD_LIBRARY_PATH=`pwd`${LD_LIBRARY_PATH:+:${LD_LIBRARY_PATH}}
|
||||
@@ -1843,13 +1844,13 @@ esac
|
||||
@@ -1843,13 +1845,13 @@ esac
|
||||
[AC_MSG_RESULT(no)])
|
||||
if test "$Py_LTO" = 'true' ; then
|
||||
case $CC in
|
||||
|
@ -52,7 +59,7 @@ Index: configure.ac
|
|||
AC_SUBST(LLVM_AR_FOUND)
|
||||
if test -n "${LLVM_AR}" -a -x "${LLVM_AR}"
|
||||
then
|
||||
@@ -1964,7 +1965,7 @@ then
|
||||
@@ -1964,7 +1966,7 @@ then
|
||||
fi
|
||||
LLVM_PROF_ERR=no
|
||||
case $CC in
|
||||
|
@ -61,16 +68,16 @@ Index: configure.ac
|
|||
# Any changes made here should be reflected in the GCC+Darwin case below
|
||||
PGO_PROF_GEN_FLAG="-fprofile-instr-generate"
|
||||
PGO_PROF_USE_FLAG="-fprofile-instr-use=code.profclangd"
|
||||
@@ -3193,7 +3194,7 @@ then
|
||||
@@ -3193,7 +3195,7 @@ then
|
||||
else
|
||||
LDSHARED="ld -Bshareable"
|
||||
fi;;
|
||||
- OpenBSD*)
|
||||
+ OpenBSD* | SecBSD*)
|
||||
+ OpenBSD*|SecBSD*)
|
||||
if [[ "`$CC -dM -E - </dev/null | grep __ELF__`" != "" ]]
|
||||
then
|
||||
LDSHARED='$(CC) -shared $(CCSHARED)'
|
||||
@@ -3269,7 +3270,7 @@ then
|
||||
@@ -3269,7 +3271,7 @@ then
|
||||
AS_VAR_IF([enable_wasm_dynamic_linking], [yes], [
|
||||
CCSHARED="-fPIC"
|
||||
]);;
|
||||
|
@ -79,7 +86,7 @@ Index: configure.ac
|
|||
Haiku*) CCSHARED="-fPIC";;
|
||||
OpenUNIX*|UnixWare*)
|
||||
if test "$GCC" = "yes"
|
||||
@@ -3326,7 +3327,7 @@ then
|
||||
@@ -3326,7 +3328,7 @@ then
|
||||
OpenUNIX*|UnixWare*) LINKFORSHARED="-Wl,-Bexport";;
|
||||
SCO_SV*) LINKFORSHARED="-Wl,-Bexport";;
|
||||
ReliantUNIX*) LINKFORSHARED="-W1 -Blargedynsym";;
|
||||
|
@ -88,7 +95,7 @@ Index: configure.ac
|
|||
if [[ "`$CC -dM -E - </dev/null | grep __ELF__`" != "" ]]
|
||||
then
|
||||
LINKFORSHARED="-Wl,--export-dynamic"
|
||||
@@ -3888,11 +3889,7 @@ dnl Detect Tcl/Tk. Use pkg-config if available.
|
||||
@@ -3888,11 +3890,7 @@ dnl Detect Tcl/Tk. Use pkg-config if available.
|
||||
dnl
|
||||
found_tcltk=no
|
||||
for _QUERY in \
|
||||
|
|
|
@ -1,7 +1,11 @@
|
|||
@option no-default-conflict
|
||||
@option is-branch
|
||||
@conflict python-idle-${VERSION_SPEC}
|
||||
<<<<<<< PLIST-idle
|
||||
@conflict python-idle->=3,<${FULL_VERSION}p0
|
||||
=======
|
||||
@conflict python-idle->=3,<3.11.10p0
|
||||
>>>>>>> 1.5
|
||||
@pkgpath lang/python/3.2,-idle
|
||||
@pkgpath lang/python/3.3,-idle
|
||||
@pkgpath lang/python/3.4,-idle
|
||||
|
|
|
@ -1,7 +1,7 @@
|
|||
@option no-default-conflict
|
||||
@option is-branch
|
||||
@conflict python-${VERSION_SPEC}
|
||||
@conflict python->=3,<3.11.9p0
|
||||
@conflict python->=3,<3.11.10p0
|
||||
@pkgpath lang/python/3.2,-main
|
||||
@pkgpath lang/python/3.3,-main
|
||||
@pkgpath lang/python/3.4,-main
|
||||
|
@ -12,6 +12,7 @@
|
|||
@pkgpath lang/python/3.9,-main
|
||||
@pkgpath lang/python/3.10,-main
|
||||
@pkgpath lang/python/3.11,-main
|
||||
@pkgpath meta/python3
|
||||
bin/2to3
|
||||
bin/2to3-3.11
|
||||
@comment bin/pip3
|
||||
|
|
Loading…
Add table
Add a link
Reference in a new issue