SecBSD's official ports repository
This commit is contained in:
commit
2c0afcbbf3
64331 changed files with 5339189 additions and 0 deletions
21
x11/notion/patches/patch-libtu_test_Makefile
Normal file
21
x11/notion/patches/patch-libtu_test_Makefile
Normal file
|
@ -0,0 +1,21 @@
|
|||
Index: libtu/test/Makefile
|
||||
--- libtu/test/Makefile.orig
|
||||
+++ libtu/test/Makefile
|
||||
@@ -6,7 +6,7 @@ include $(TOPDIR)/build/system-inc.mk
|
||||
|
||||
SOURCES=../misc.c ../tokenizer.c ../util.c ../output.c
|
||||
|
||||
-LIBS += $(LUA_LIBS) $(DL_LIBS) -lm
|
||||
+LIBS += $(LUA_LIBS) $(DL_LIBS) $(LIBTU_LIBS) -lm
|
||||
INCLUDES += $(LIBTU_INCLUDES)
|
||||
CFLAGS += $(XOPEN_SOURCE) $(C99_SOURCE)
|
||||
|
||||
@@ -17,6 +17,6 @@ include $(TOPDIR)/build/rules.mk
|
||||
######################################
|
||||
|
||||
test: $(SOURCES)
|
||||
- $(CC) $(CFLAGS) -o tutest $(SOURCES) tutest.c $(LIBS)
|
||||
+ $(CC) $(CFLAGS) $(INCLUDES) -o tutest $(SOURCES) tutest.c $(LIBS)
|
||||
./tutest
|
||||
$(RM) ./tutest
|
||||
\ No newline at end of file
|
Loading…
Add table
Add a link
Reference in a new issue