SecBSD's official ports repository

This commit is contained in:
purplerain 2023-08-16 22:26:55 +00:00
commit 2c0afcbbf3
Signed by: purplerain
GPG key ID: F42C07F07E2E35B7
64331 changed files with 5339189 additions and 0 deletions

View file

@ -0,0 +1,21 @@
Index: libtu/test/Makefile
--- libtu/test/Makefile.orig
+++ libtu/test/Makefile
@@ -6,7 +6,7 @@ include $(TOPDIR)/build/system-inc.mk
SOURCES=../misc.c ../tokenizer.c ../util.c ../output.c
-LIBS += $(LUA_LIBS) $(DL_LIBS) -lm
+LIBS += $(LUA_LIBS) $(DL_LIBS) $(LIBTU_LIBS) -lm
INCLUDES += $(LIBTU_INCLUDES)
CFLAGS += $(XOPEN_SOURCE) $(C99_SOURCE)
@@ -17,6 +17,6 @@ include $(TOPDIR)/build/rules.mk
######################################
test: $(SOURCES)
- $(CC) $(CFLAGS) -o tutest $(SOURCES) tutest.c $(LIBS)
+ $(CC) $(CFLAGS) $(INCLUDES) -o tutest $(SOURCES) tutest.c $(LIBS)
./tutest
$(RM) ./tutest
\ No newline at end of file