SecBSD's official ports repository
This commit is contained in:
commit
2c0afcbbf3
64331 changed files with 5339189 additions and 0 deletions
37
www/py-html5-parser/Makefile
Normal file
37
www/py-html5-parser/Makefile
Normal file
|
@ -0,0 +1,37 @@
|
|||
COMMENT = fast C based HTML 5 parsing for python
|
||||
|
||||
MODPY_EGG_VERSION = 0.4.10
|
||||
|
||||
DISTNAME = html5-parser-${MODPY_EGG_VERSION}
|
||||
PKGNAME = py-${DISTNAME}
|
||||
REVISION = 2
|
||||
|
||||
CATEGORIES = www
|
||||
|
||||
HOMEPAGE = https://html5-parser.readthedocs.io
|
||||
|
||||
# Apache 2.0
|
||||
PERMIT_PACKAGE = Yes
|
||||
|
||||
FLAVORS = python3
|
||||
FLAVOR = python3
|
||||
|
||||
WANTLIB += pthread xml2
|
||||
|
||||
MODULES = lang/python
|
||||
|
||||
MODPY_PI = Yes
|
||||
MODPY_SETUPTOOLS = Yes
|
||||
MODPY_PYTEST = Yes
|
||||
MODPY_PYTEST_ARGS = test/*py
|
||||
|
||||
TEST_ENV += PYTHONPATH=${WRKSRC}/lib.openbsd-${OSREV}-${ARCH}-${MODPY_VERSION}/
|
||||
|
||||
LIB_DEPENDS = textproc/libxml
|
||||
|
||||
RUN_DEPENDS = textproc/py-chardet${MODPY_FLAVOR} \
|
||||
textproc/py-lxml${MODPY_FLAVOR}
|
||||
|
||||
TEST_DEPENDS = www/py-beautifulsoup4${MODPY_FLAVOR}
|
||||
|
||||
.include <bsd.port.mk>
|
2
www/py-html5-parser/distinfo
Normal file
2
www/py-html5-parser/distinfo
Normal file
|
@ -0,0 +1,2 @@
|
|||
SHA256 (html5-parser-0.4.10.tar.gz) = +SlEGMDalcLV+swZ09wylBCTprjjs+SzbMe1oWl/vKQ=
|
||||
SIZE (html5-parser-0.4.10.tar.gz) = 272814
|
14
www/py-html5-parser/patches/patch-setup_py
Normal file
14
www/py-html5-parser/patches/patch-setup_py
Normal file
|
@ -0,0 +1,14 @@
|
|||
Index: setup.py
|
||||
--- setup.py.orig
|
||||
+++ setup.py
|
||||
@@ -19,9 +19,7 @@ if True:
|
||||
del sys.path[0]
|
||||
|
||||
src_files = tuple(chain(*map(lambda x: find_c_files(x)[0], SRC_DIRS)))
|
||||
-cargs = ('/O2' if iswindows else '-O3').split()
|
||||
-if not iswindows:
|
||||
- cargs.extend('-std=c99 -fvisibility=hidden'.split())
|
||||
+cargs = ('-std=c99 -fvisibility=hidden'.split())
|
||||
|
||||
|
||||
class Test(Build):
|
4
www/py-html5-parser/pkg/DESCR
Normal file
4
www/py-html5-parser/pkg/DESCR
Normal file
|
@ -0,0 +1,4 @@
|
|||
A fast implementation of the HTML 5 parsing spec for Python. Parsing is done in
|
||||
C using a variant of the gumbo parser. The gumbo parse tree is then transformed
|
||||
into an lxml tree, also in C, yielding parse times that can be a thirtieth of
|
||||
the html5lib parse times.
|
21
www/py-html5-parser/pkg/PLIST
Normal file
21
www/py-html5-parser/pkg/PLIST
Normal file
|
@ -0,0 +1,21 @@
|
|||
lib/python${MODPY_VERSION}/site-packages/html5_parser/
|
||||
lib/python${MODPY_VERSION}/site-packages/html5_parser-${MODPY_EGG_VERSION}-py${MODPY_VERSION}.egg-info/
|
||||
lib/python${MODPY_VERSION}/site-packages/html5_parser-${MODPY_EGG_VERSION}-py${MODPY_VERSION}.egg-info/PKG-INFO
|
||||
lib/python${MODPY_VERSION}/site-packages/html5_parser-${MODPY_EGG_VERSION}-py${MODPY_VERSION}.egg-info/SOURCES.txt
|
||||
lib/python${MODPY_VERSION}/site-packages/html5_parser-${MODPY_EGG_VERSION}-py${MODPY_VERSION}.egg-info/dependency_links.txt
|
||||
lib/python${MODPY_VERSION}/site-packages/html5_parser-${MODPY_EGG_VERSION}-py${MODPY_VERSION}.egg-info/requires.txt
|
||||
lib/python${MODPY_VERSION}/site-packages/html5_parser-${MODPY_EGG_VERSION}-py${MODPY_VERSION}.egg-info/top_level.txt
|
||||
lib/python${MODPY_VERSION}/site-packages/html5_parser/__init__.py
|
||||
${MODPY_COMMENT}lib/python${MODPY_VERSION}/site-packages/html5_parser/${MODPY_PYCACHE}/
|
||||
lib/python${MODPY_VERSION}/site-packages/html5_parser/${MODPY_PYCACHE}__init__.${MODPY_PYC_MAGIC_TAG}pyc
|
||||
lib/python${MODPY_VERSION}/site-packages/html5_parser/${MODPY_PYCACHE}dom.${MODPY_PYC_MAGIC_TAG}pyc
|
||||
lib/python${MODPY_VERSION}/site-packages/html5_parser/${MODPY_PYCACHE}encoding_names.${MODPY_PYC_MAGIC_TAG}pyc
|
||||
lib/python${MODPY_VERSION}/site-packages/html5_parser/${MODPY_PYCACHE}encoding_parser.${MODPY_PYC_MAGIC_TAG}pyc
|
||||
lib/python${MODPY_VERSION}/site-packages/html5_parser/${MODPY_PYCACHE}soup.${MODPY_PYC_MAGIC_TAG}pyc
|
||||
lib/python${MODPY_VERSION}/site-packages/html5_parser/${MODPY_PYCACHE}stdlib_etree.${MODPY_PYC_MAGIC_TAG}pyc
|
||||
lib/python${MODPY_VERSION}/site-packages/html5_parser/dom.py
|
||||
lib/python${MODPY_VERSION}/site-packages/html5_parser/encoding_names.py
|
||||
lib/python${MODPY_VERSION}/site-packages/html5_parser/encoding_parser.py
|
||||
@so lib/python${MODPY_VERSION}/site-packages/html5_parser/html_parser.${MODPY_PYC_MAGIC_TAG}so
|
||||
lib/python${MODPY_VERSION}/site-packages/html5_parser/soup.py
|
||||
lib/python${MODPY_VERSION}/site-packages/html5_parser/stdlib_etree.py
|
Loading…
Add table
Add a link
Reference in a new issue