SecBSD's official ports repository

This commit is contained in:
purplerain 2023-08-16 22:26:55 +00:00
commit 2c0afcbbf3
Signed by: purplerain
GPG key ID: F42C07F07E2E35B7
64331 changed files with 5339189 additions and 0 deletions

49
www/py-bokeh/Makefile Normal file
View file

@ -0,0 +1,49 @@
COMMENT= statistical and novel interactive HTML plots for Python
MODPY_EGG_VERSION= 3.2.1
DISTNAME= bokeh-${MODPY_EGG_VERSION}
PKGNAME= py-bokeh-${MODPY_EGG_VERSION}
CATEGORIES= www graphics
HOMEPAGE= https://bokeh.org/
# BSD
PERMIT_PACKAGE= Yes
MODULES= lang/python
FLAVORS= python3
FLAVOR= python3
MODPY_PI = Yes
MODPY_PYBUILD = setuptools
# tests not shipped in pypi distfile
NO_TEST = Yes
RUN_DEPENDS= devel/py-typing-extensions${MODPY_FLAVOR}>=3.10.0.0 \
geo/py-xyzservices${MODPY_FLAVOR} \
graphics/py-Pillow${MODPY_FLAVOR} \
math/py-contourpy${MODPY_FLAVOR} \
math/py-numpy${MODPY_FLAVOR} \
math/py-pandas${MODPY_FLAVOR} \
sysutils/py-packaging${MODPY_FLAVOR} \
textproc/py-yaml${MODPY_FLAVOR} \
www/py-jinja2${MODPY_FLAVOR} \
www/py-tornado${MODPY_FLAVOR}
TEST_DEPENDS= devel/ipython${MODPY_FLAVOR} \
devel/py-flaky${MODPY_FLAVOR} \
devel/py-mock${MODPY_FLAVOR} \
devel/py-nbconvert${MODPY_FLAVOR} \
devel/py-nbformat${MODPY_FLAVOR} \
math/py-networkx${MODPY_FLAVOR} \
math/py-pandas${MODPY_FLAVOR} \
www/py-requests${MODPY_FLAVOR} \
www/py-selenium${MODPY_FLAVOR}
post-extract:
sed -i 's/dynamic = \["version"\]/version = "${MODPY_EGG_VERSION}"/' \
${WRKSRC}/pyproject.toml
.include <bsd.port.mk>

2
www/py-bokeh/distinfo Normal file
View file

@ -0,0 +1,2 @@
SHA256 (bokeh-3.2.1.tar.gz) = I3HpoI/WB2aHnuhgekrlQmes/tHl3uDMaiDYNI4C6BQ=
SIZE (bokeh-3.2.1.tar.gz) = 7248311

View file

@ -0,0 +1,25 @@
Index: pyproject.toml
--- pyproject.toml.orig
+++ pyproject.toml
@@ -1,5 +1,5 @@
[build-system]
-requires = ["setuptools>=64", "setuptools-git-versioning", "colorama"]
+requires = ["setuptools>=64"]
build-backend = "setuptools.build_meta"
[project]
@@ -65,14 +65,8 @@ bokeh = "bokeh.__main__:main"
[tool.setuptools.packages.find]
where = ["src"]
-[tool.setuptools-git-versioning]
-enabled = true
-dev_template = "{tag}+{ccount}.g{sha}"
-dirty_template = "{tag}+{ccount}.g{sha}.dirty"
-
[tool.pytest.ini_options]
timeout = 60
-asyncio_mode = "strict"
norecursedirs = "build _build node_modules tests/support"
python_files = "*_tests.py *_test.py test_*.py"
markers = [

6
www/py-bokeh/pkg/DESCR Normal file
View file

@ -0,0 +1,6 @@
Bokeh is a Python interactive visualization library that targets modern web
browsers for presentation. Its goal is to provide elegant, concise construction
of novel graphics in the style of D3.js, and to extend this capability with
high-performance interactivity over very large or streaming datasets. Bokeh can
help anyone who would like to quickly and easily create interactive plots,
dashboards, and data applications.

1906
www/py-bokeh/pkg/PLIST Normal file

File diff suppressed because it is too large Load diff