SecBSD's official ports repository
This commit is contained in:
commit
2c0afcbbf3
64331 changed files with 5339189 additions and 0 deletions
26
textproc/luceneplusplus/patches/patch-CMakeLists_txt
Normal file
26
textproc/luceneplusplus/patches/patch-CMakeLists_txt
Normal file
|
@ -0,0 +1,26 @@
|
|||
disable cotire as it's deprecated and breaks the build with newer libc++
|
||||
|
||||
Index: CMakeLists.txt
|
||||
--- CMakeLists.txt.orig
|
||||
+++ CMakeLists.txt
|
||||
@@ -15,11 +15,6 @@ set(lucene++_VERSION
|
||||
# include specific modules
|
||||
set(CMAKE_MODULE_PATH "${CMAKE_SOURCE_DIR}/cmake")
|
||||
|
||||
-####################################
|
||||
-# pre-compiled headers support
|
||||
-####################################
|
||||
-include(cotire)
|
||||
-
|
||||
# if setup using the Toolchain-llvm.cmake file, then use llvm...
|
||||
if(ENABLE_LLVM)
|
||||
include(Toolchain-llvm)
|
||||
@@ -85,7 +80,7 @@ include(TestCXXAcceptsFlag)
|
||||
include(GNUInstallDirs)
|
||||
|
||||
set(LIB_DESTINATION
|
||||
- "${CMAKE_INSTALL_FULL_LIBDIR}" CACHE STRING "Define lib output directory name"
|
||||
+ "lib" CACHE STRING "Define lib output directory name"
|
||||
)
|
||||
|
||||
if(ENABLE_CYCLIC_CHECK)
|
Loading…
Add table
Add a link
Reference in a new issue