SecBSD's official ports repository
This commit is contained in:
commit
2c0afcbbf3
64331 changed files with 5339189 additions and 0 deletions
40
textproc/latex2html/patches/patch-config_install_pl
Normal file
40
textproc/latex2html/patches/patch-config_install_pl
Normal file
|
@ -0,0 +1,40 @@
|
|||
--- config/install.pl.orig Fri Nov 29 12:49:01 2002
|
||||
+++ config/install.pl Fri Apr 9 14:59:24 2010
|
||||
@@ -219,9 +219,7 @@ my %Install_items = (
|
||||
#'configure' => 'lib',
|
||||
#'configure.in' => 'lib',
|
||||
'cweb2html' => 'lib,recurse',
|
||||
- 'docs' => 'lib,recurse',
|
||||
'dot.latex2html-init' => 'lib',
|
||||
- 'example' => 'lib,recurse',
|
||||
'foilhtml' => 'lib,recurse',
|
||||
# icons are teated specially below
|
||||
# the local config is also installed
|
||||
@@ -371,12 +369,13 @@ foreach $item (sort keys %Install_items) {
|
||||
#-----------------------------------------------------------------------------
|
||||
|
||||
if($cfg{TEXPATH}) {
|
||||
- print "\nNote: trying to install LaTeX2HTML style files in TeX directory tree\n ($cfg{TEXPATH})\n";
|
||||
- unless(mkpath($cfg{TEXPATH})) {
|
||||
+ my $d = $ENV{'DESTDIR'} . $cfg{TEXPATH};
|
||||
+ print "\nNote: trying to install LaTeX2HTML style files in TeX directory tree\n ($d)\n";
|
||||
+ unless(mkpath($d)) {
|
||||
#my $testpath = $cfg{TEXPATH}; # to strip (latex2)html
|
||||
#$testpath =~ s/[$dd$dd][^$dd$dd]*$//;
|
||||
#if((-d $cfg{TEXPATH} && !-w _) || (-d $testpath && !-w _)) {
|
||||
- print STDERR "\nError: Cannot install LaTeX2HTML style files in $cfg{TEXPATH}\n";
|
||||
+ print STDERR "\nError: Cannot install LaTeX2HTML style files in $d\n";
|
||||
} else {
|
||||
my $dir = 'texinputs';
|
||||
my $dest = $cfg{TEXPATH};
|
||||
@@ -395,8 +394,8 @@ if($cfg{TEXPATH}) {
|
||||
}
|
||||
closedir(DIR);
|
||||
if($ok && $cfg{MKTEXLSR}) {
|
||||
- print "Info: Running $cfg{MKTEXLSR} to rebuild ls-R database...\n";
|
||||
- system($cfg{MKTEXLSR});
|
||||
+ #print "Info: Running $cfg{MKTEXLSR} to rebuild ls-R database...\n";
|
||||
+ #system($cfg{MKTEXLSR});
|
||||
}
|
||||
}
|
||||
}
|
Loading…
Add table
Add a link
Reference in a new issue