SecBSD's official ports repository

This commit is contained in:
purplerain 2023-08-16 22:26:55 +00:00
commit 2c0afcbbf3
Signed by: purplerain
GPG key ID: F42C07F07E2E35B7
64331 changed files with 5339189 additions and 0 deletions

View file

@ -0,0 +1,26 @@
--- src/Macros.mk.orig Fri Sep 14 18:17:05 2007
+++ src/Macros.mk Fri Sep 14 18:17:25 2007
@@ -4,12 +4,12 @@
LIBRARY = ../../lib/libshunt.a
-CC = gcc
+#CC = gcc
ifdef DEBUG
DCFLAGS += -g
else
- DCFLAGS += -O2 -DNDEBUG
+ DCFLAGS += -DNDEBUG
endif
ifdef PROFILE
@@ -17,7 +17,7 @@ ifdef PROFILE
endif
CPPFLAGS += -MMD
-CFLAGS = $(DCFLAGS) -Wall $(PROFILE_FLAGS)
+CFLAGS += $(DCFLAGS) -Wall $(PROFILE_FLAGS)
#STATIC += -static
LDFLAGS += $(STATIC) $(PROFILE_FLAGS)