SecBSD's official ports repository
This commit is contained in:
commit
2c0afcbbf3
64331 changed files with 5339189 additions and 0 deletions
28
security/ssh-askpass-fullscreen/Makefile
Normal file
28
security/ssh-askpass-fullscreen/Makefile
Normal file
|
@ -0,0 +1,28 @@
|
|||
COMMENT= good-looking ssh-agent pass-phrase dialog
|
||||
|
||||
DISTNAME = ssh-askpass-fullscreen-0.4
|
||||
REVISION= 7
|
||||
CATEGORIES= security
|
||||
|
||||
MASTER_SITES = http://www.cgabriel.org/download/ssh-askpass-fullscreen/
|
||||
|
||||
# GPLv2
|
||||
PERMIT_PACKAGE= Yes
|
||||
|
||||
LIB_DEPENDS = x11/gtk+2
|
||||
|
||||
WANTLIB = X11 Xcomposite Xcursor Xdamage Xext Xfixes Xi Xinerama Xrandr
|
||||
WANTLIB += Xrender atk-1.0 c cairo fontconfig freetype gdk-x11-2.0
|
||||
WANTLIB += gdk_pixbuf-2.0 gio-2.0 glib-2.0 gobject-2.0 gtk-x11-2.0
|
||||
WANTLIB += harfbuzz intl pango-1.0 pangocairo-1.0 pangoft2-1.0 pthread z
|
||||
|
||||
do-build:
|
||||
cd ${WRKBUILD} && \
|
||||
${CC} ${CFLAGS} -o ssh-askpass-fullscreen \
|
||||
${WRKSRC}/ssh-askpass-fullscreen.c `pkg-config --cflags gtk+-2.0` \
|
||||
`pkg-config --libs gtk+-2.0`
|
||||
|
||||
do-install:
|
||||
${INSTALL_PROGRAM} ${WRKBUILD}/ssh-askpass-fullscreen ${PREFIX}/bin
|
||||
|
||||
.include <bsd.port.mk>
|
2
security/ssh-askpass-fullscreen/distinfo
Normal file
2
security/ssh-askpass-fullscreen/distinfo
Normal file
|
@ -0,0 +1,2 @@
|
|||
SHA256 (ssh-askpass-fullscreen-0.4.tar.gz) = B0CcuBNogmGhUdGRhpCgJe63zMhx+T1DV5XRw4tPFKw=
|
||||
SIZE (ssh-askpass-fullscreen-0.4.tar.gz) = 10737
|
|
@ -0,0 +1,22 @@
|
|||
--- ssh-askpass-fullscreen.c.orig Mon Jan 16 13:49:38 2006
|
||||
+++ ssh-askpass-fullscreen.c Mon Apr 13 21:25:43 2009
|
||||
@@ -229,8 +229,9 @@ enter_callback(GtkWidget *widget,
|
||||
if (result == 0) /* result is always == 0, what this check is for? */
|
||||
puts(passphrase);
|
||||
|
||||
- memset((void*)passphrase, '\0', strlen(passphrase));
|
||||
+ memset((void*)passphrase, '\b', strlen(passphrase));
|
||||
gtk_entry_set_text(GTK_ENTRY(entry), passphrase);
|
||||
+ memset((void*)passphrase, '\0', strlen(passphrase));
|
||||
gtk_main_quit();
|
||||
|
||||
}
|
||||
@@ -247,7 +248,7 @@ passphrase_dialog(char *message)
|
||||
GdkColor color;
|
||||
gchar *str;
|
||||
GdkGrabStatus status;
|
||||
- int grab_tries;
|
||||
+ int grab_tries = 0;
|
||||
const char *failed;
|
||||
|
||||
grab_server = (getenv("GNOME_SSH_ASKPASS_GRAB_SERVER") != NULL);
|
2
security/ssh-askpass-fullscreen/pkg/DESCR
Normal file
2
security/ssh-askpass-fullscreen/pkg/DESCR
Normal file
|
@ -0,0 +1,2 @@
|
|||
A small SSH Askpass replacement written with GTK2. Features fullscreen
|
||||
dialog and translucent background.
|
2
security/ssh-askpass-fullscreen/pkg/MESSAGE
Normal file
2
security/ssh-askpass-fullscreen/pkg/MESSAGE
Normal file
|
@ -0,0 +1,2 @@
|
|||
If you want 'ssh-add </dev/null' to use this dialog, you have to set
|
||||
SSH_ASKPASS environment variable to ${PREFIX}/bin/ssh-askpass-fullscreen
|
1
security/ssh-askpass-fullscreen/pkg/PLIST
Normal file
1
security/ssh-askpass-fullscreen/pkg/PLIST
Normal file
|
@ -0,0 +1 @@
|
|||
@bin bin/ssh-askpass-fullscreen
|
Loading…
Add table
Add a link
Reference in a new issue