SecBSD's official ports repository

This commit is contained in:
purplerain 2023-08-16 22:26:55 +00:00
commit 2c0afcbbf3
Signed by: purplerain
GPG key ID: F42C07F07E2E35B7
64331 changed files with 5339189 additions and 0 deletions

View file

@ -0,0 +1,30 @@
COMMENT = sources of the Ruby OpenSSL gem for regression testing
# Follows HEAD
VERSION = 20230803
DISTNAME = openssl-ruby-tests-${VERSION}
GH_ACCOUNT = ruby
GH_PROJECT = openssl
GH_COMMIT = c5543a6aa0ff1487836c8da12fad5a11135482ed
CATEGORIES = security devel
MAINTAINER = Theo Buehler <tb@openbsd.org>
# BSD 2-Clause
PERMIT_PACKAGE = Yes
MODULES = lang/ruby
NO_BUILD = Yes
NO_TEST = Yes
OPENSSL_TESTS_DIR = ${PREFIX}/share/openssl-ruby-tests
do-install:
${INSTALL_DATA_DIR} ${OPENSSL_TESTS_DIR}
cd ${WRKSRC} && \
pax -rw -s '/^.*${PATCHORIG}$$//' BSDL ext lib test ${OPENSSL_TESTS_DIR}
.include <bsd.port.mk>

View file

@ -0,0 +1,2 @@
SHA256 (openssl-ruby-tests-20230803-c5543a6a.tar.gz) = baJcBqid+MnGTk6mRgLNFU2sSWuwi2FnyXOfi5G5b/s=
SIZE (openssl-ruby-tests-20230803-c5543a6a.tar.gz) = 319411

View file

@ -0,0 +1,18 @@
Remove a pend that hides missing support for SSL_CTX_set_client_cert_cb()
in the TLSv1.3 stack.
Index: test/openssl/test_ssl.rb
--- test/openssl/test_ssl.rb.orig
+++ test/openssl/test_ssl.rb
@@ -352,8 +352,9 @@ class OpenSSL::TestSSL < OpenSSL::SSLTestCase
end
def test_client_ca
- pend "LibreSSL 3.2 has broken client CA support" if libressl?(3, 2, 0)
-
+ if ENV['SKIP_EXPECTED_FAILURES']
+ pend "skip failing client CA test"
+ end
ctx_proc = Proc.new do |ctx|
ctx.client_ca = [@ca_cert]
end

View file

@ -0,0 +1 @@
Bundles the sources of the Ruby OpenSSL gem for regression testing.

View file

@ -0,0 +1,137 @@
share/openssl-ruby-tests/
share/openssl-ruby-tests/BSDL
share/openssl-ruby-tests/ext/
share/openssl-ruby-tests/ext/openssl/
share/openssl-ruby-tests/ext/openssl/extconf.rb
share/openssl-ruby-tests/ext/openssl/openssl_missing.c
share/openssl-ruby-tests/ext/openssl/openssl_missing.h
share/openssl-ruby-tests/ext/openssl/ossl.c
share/openssl-ruby-tests/ext/openssl/ossl.h
share/openssl-ruby-tests/ext/openssl/ossl_asn1.c
share/openssl-ruby-tests/ext/openssl/ossl_asn1.h
share/openssl-ruby-tests/ext/openssl/ossl_bio.c
share/openssl-ruby-tests/ext/openssl/ossl_bio.h
share/openssl-ruby-tests/ext/openssl/ossl_bn.c
share/openssl-ruby-tests/ext/openssl/ossl_bn.h
share/openssl-ruby-tests/ext/openssl/ossl_cipher.c
share/openssl-ruby-tests/ext/openssl/ossl_cipher.h
share/openssl-ruby-tests/ext/openssl/ossl_config.c
share/openssl-ruby-tests/ext/openssl/ossl_config.h
share/openssl-ruby-tests/ext/openssl/ossl_digest.c
share/openssl-ruby-tests/ext/openssl/ossl_digest.h
share/openssl-ruby-tests/ext/openssl/ossl_engine.c
share/openssl-ruby-tests/ext/openssl/ossl_engine.h
share/openssl-ruby-tests/ext/openssl/ossl_hmac.c
share/openssl-ruby-tests/ext/openssl/ossl_hmac.h
share/openssl-ruby-tests/ext/openssl/ossl_kdf.c
share/openssl-ruby-tests/ext/openssl/ossl_kdf.h
share/openssl-ruby-tests/ext/openssl/ossl_ns_spki.c
share/openssl-ruby-tests/ext/openssl/ossl_ns_spki.h
share/openssl-ruby-tests/ext/openssl/ossl_ocsp.c
share/openssl-ruby-tests/ext/openssl/ossl_ocsp.h
share/openssl-ruby-tests/ext/openssl/ossl_pkcs12.c
share/openssl-ruby-tests/ext/openssl/ossl_pkcs12.h
share/openssl-ruby-tests/ext/openssl/ossl_pkcs7.c
share/openssl-ruby-tests/ext/openssl/ossl_pkcs7.h
share/openssl-ruby-tests/ext/openssl/ossl_pkey.c
share/openssl-ruby-tests/ext/openssl/ossl_pkey.h
share/openssl-ruby-tests/ext/openssl/ossl_pkey_dh.c
share/openssl-ruby-tests/ext/openssl/ossl_pkey_dsa.c
share/openssl-ruby-tests/ext/openssl/ossl_pkey_ec.c
share/openssl-ruby-tests/ext/openssl/ossl_pkey_rsa.c
share/openssl-ruby-tests/ext/openssl/ossl_provider.c
share/openssl-ruby-tests/ext/openssl/ossl_provider.h
share/openssl-ruby-tests/ext/openssl/ossl_rand.c
share/openssl-ruby-tests/ext/openssl/ossl_rand.h
share/openssl-ruby-tests/ext/openssl/ossl_ssl.c
share/openssl-ruby-tests/ext/openssl/ossl_ssl.h
share/openssl-ruby-tests/ext/openssl/ossl_ssl_session.c
share/openssl-ruby-tests/ext/openssl/ossl_ts.c
share/openssl-ruby-tests/ext/openssl/ossl_ts.h
share/openssl-ruby-tests/ext/openssl/ossl_x509.c
share/openssl-ruby-tests/ext/openssl/ossl_x509.h
share/openssl-ruby-tests/ext/openssl/ossl_x509attr.c
share/openssl-ruby-tests/ext/openssl/ossl_x509cert.c
share/openssl-ruby-tests/ext/openssl/ossl_x509crl.c
share/openssl-ruby-tests/ext/openssl/ossl_x509ext.c
share/openssl-ruby-tests/ext/openssl/ossl_x509name.c
share/openssl-ruby-tests/ext/openssl/ossl_x509req.c
share/openssl-ruby-tests/ext/openssl/ossl_x509revoked.c
share/openssl-ruby-tests/ext/openssl/ossl_x509store.c
share/openssl-ruby-tests/lib/
share/openssl-ruby-tests/lib/openssl/
share/openssl-ruby-tests/lib/openssl.rb
share/openssl-ruby-tests/lib/openssl/bn.rb
share/openssl-ruby-tests/lib/openssl/buffering.rb
share/openssl-ruby-tests/lib/openssl/cipher.rb
share/openssl-ruby-tests/lib/openssl/digest.rb
share/openssl-ruby-tests/lib/openssl/hmac.rb
share/openssl-ruby-tests/lib/openssl/marshal.rb
share/openssl-ruby-tests/lib/openssl/pkcs5.rb
share/openssl-ruby-tests/lib/openssl/pkey.rb
share/openssl-ruby-tests/lib/openssl/ssl.rb
share/openssl-ruby-tests/lib/openssl/version.rb
share/openssl-ruby-tests/lib/openssl/x509.rb
share/openssl-ruby-tests/test/
share/openssl-ruby-tests/test/lib/
share/openssl-ruby-tests/test/lib/core_assertions.rb
share/openssl-ruby-tests/test/lib/envutil.rb
share/openssl-ruby-tests/test/lib/find_executable.rb
share/openssl-ruby-tests/test/openssl/
share/openssl-ruby-tests/test/openssl/fixtures/
share/openssl-ruby-tests/test/openssl/fixtures/pkey/
share/openssl-ruby-tests/test/openssl/fixtures/pkey/certificate.der
share/openssl-ruby-tests/test/openssl/fixtures/pkey/dh-1.pem
share/openssl-ruby-tests/test/openssl/fixtures/pkey/dh1024.pem
share/openssl-ruby-tests/test/openssl/fixtures/pkey/dsa1024.pem
share/openssl-ruby-tests/test/openssl/fixtures/pkey/dsa256.pem
share/openssl-ruby-tests/test/openssl/fixtures/pkey/dsa512.pem
share/openssl-ruby-tests/test/openssl/fixtures/pkey/empty.der
share/openssl-ruby-tests/test/openssl/fixtures/pkey/empty.pem
share/openssl-ruby-tests/test/openssl/fixtures/pkey/fullchain.pem
share/openssl-ruby-tests/test/openssl/fixtures/pkey/garbage.txt
share/openssl-ruby-tests/test/openssl/fixtures/pkey/p256.pem
share/openssl-ruby-tests/test/openssl/fixtures/pkey/p256_too_large.pem
share/openssl-ruby-tests/test/openssl/fixtures/pkey/p384_invalid.pem
share/openssl-ruby-tests/test/openssl/fixtures/pkey/rsa-1.pem
share/openssl-ruby-tests/test/openssl/fixtures/pkey/rsa-2.pem
share/openssl-ruby-tests/test/openssl/fixtures/pkey/rsa-3.pem
share/openssl-ruby-tests/test/openssl/fixtures/pkey/rsa1024.pem
share/openssl-ruby-tests/test/openssl/fixtures/pkey/rsa2048.pem
share/openssl-ruby-tests/test/openssl/fixtures/ssl/
share/openssl-ruby-tests/test/openssl/fixtures/ssl/openssl_fips.cnf.tmpl
share/openssl-ruby-tests/test/openssl/test_asn1.rb
share/openssl-ruby-tests/test/openssl/test_bn.rb
share/openssl-ruby-tests/test/openssl/test_buffering.rb
share/openssl-ruby-tests/test/openssl/test_cipher.rb
share/openssl-ruby-tests/test/openssl/test_config.rb
share/openssl-ruby-tests/test/openssl/test_digest.rb
share/openssl-ruby-tests/test/openssl/test_engine.rb
share/openssl-ruby-tests/test/openssl/test_fips.rb
share/openssl-ruby-tests/test/openssl/test_hmac.rb
share/openssl-ruby-tests/test/openssl/test_kdf.rb
share/openssl-ruby-tests/test/openssl/test_ns_spki.rb
share/openssl-ruby-tests/test/openssl/test_ocsp.rb
share/openssl-ruby-tests/test/openssl/test_ossl.rb
share/openssl-ruby-tests/test/openssl/test_pair.rb
share/openssl-ruby-tests/test/openssl/test_pkcs12.rb
share/openssl-ruby-tests/test/openssl/test_pkcs7.rb
share/openssl-ruby-tests/test/openssl/test_pkey.rb
share/openssl-ruby-tests/test/openssl/test_pkey_dh.rb
share/openssl-ruby-tests/test/openssl/test_pkey_dsa.rb
share/openssl-ruby-tests/test/openssl/test_pkey_ec.rb
share/openssl-ruby-tests/test/openssl/test_pkey_rsa.rb
share/openssl-ruby-tests/test/openssl/test_provider.rb
share/openssl-ruby-tests/test/openssl/test_random.rb
share/openssl-ruby-tests/test/openssl/test_ssl.rb
share/openssl-ruby-tests/test/openssl/test_ssl_session.rb
share/openssl-ruby-tests/test/openssl/test_ts.rb
share/openssl-ruby-tests/test/openssl/test_x509attr.rb
share/openssl-ruby-tests/test/openssl/test_x509cert.rb
share/openssl-ruby-tests/test/openssl/test_x509crl.rb
share/openssl-ruby-tests/test/openssl/test_x509ext.rb
share/openssl-ruby-tests/test/openssl/test_x509name.rb
share/openssl-ruby-tests/test/openssl/test_x509req.rb
share/openssl-ruby-tests/test/openssl/test_x509store.rb
share/openssl-ruby-tests/test/openssl/ut_eof.rb
share/openssl-ruby-tests/test/openssl/utils.rb