SecBSD's official ports repository

This commit is contained in:
purplerain 2023-08-16 22:26:55 +00:00
commit 2c0afcbbf3
Signed by: purplerain
GPG key ID: F42C07F07E2E35B7
64331 changed files with 5339189 additions and 0 deletions

View file

@ -0,0 +1,61 @@
COMMENT = library for creating DigiDoc signature files
V = 3.15.0
DISTNAME = libdigidocpp-${V}
CATEGORIES = security
SHARED_LIBS = digidocpp 2.0 # 0.0
DEBUG_PACKAGES = ${BUILD_PACKAGES}
# libdigidocpp: LGPL 2.1+
# minizip: zlib
PERMIT_PACKAGE = Yes
HOMEPAGE = https://www.id.ee/
MASTER_SITES = https://github.com/open-eid/libdigidocpp/releases/download/v${V}/
MAINTAINER = Klemens Nanni <kn@openbsd.org>
# -std=gnu++17
COMPILER = base-clang ports-gcc
WANTLIB += ${COMPILER_LIBCXX} c crypto m ssl
WANTLIB += xerces-c xml-security-c z
MODULES = devel/cmake
BUILD_DEPENDS = devel/boost \
devel/xsd>=4.0 \
editors/vim,-main
LIB_DEPENDS = security/xml-security-c \
textproc/xerces-c
RUN_DEPENDS = # empty
# move DIGIDOCPP_CONFIG_DIR out of /usr/local/ into /etc/ (PLIST @sample)
CONFIGURE_ARGS = -DCMAKE_INSTALL_SYSCONFDIR=share/examples
# pending "Treat dead Xalan-C as optional"
# https://github.com/open-eid/cmake/pull/38
CONFIGURE_ARGS += -DCMAKE_DISABLE_FIND_PACKAGE_XalanC=ON
# skip documentation and heavy dependency (for now)
CONFIGURE_ARGS += -DCMAKE_DISABLE_FIND_PACKAGE_Doxygen=ON
# no idea if/where JNI is packaged, just disable uneeded Java parts (for now)
#LIB_DEPENDS += devel/swig
CONFIGURE_ARGS += -DCMAKE_DISABLE_FIND_PACKAGE_JNI=ON \
-DCMAKE_DISABLE_FIND_PACKAGE_SWIG=ON
CONFIGURE_ENV += LDFLAGS=${LDFLAGS:Q}
# dlopen()'ed "opensc-pkcs11.so" in libdigidocpp.so
BUILD_DEPENDS += security/opensc
RUN_DEPENDS += security/opensc
# alternative to https://github.com/open-eid/cmake/pull/35
CONFIGURE_ARGS += -DCMAKE_SHARED_LINKER_FLAGS="${LDFLAGS} \
-Wl,-rpath,/usr/local/lib/pkcs11"
.include <bsd.port.mk>

View file

@ -0,0 +1,2 @@
SHA256 (libdigidocpp-3.15.0.tar.gz) = CNHBPeodU2EzvmQBa9KI+1vGuuD25gSwdU9dVhVG04Q=
SIZE (libdigidocpp-3.15.0.tar.gz) = 2496396

View file

@ -0,0 +1,15 @@
pending "Treat dead Xalan-C as optional"
https://github.com/open-eid/cmake/pull/38
Index: cmake/modules/FindXmlSecurityC.cmake
--- cmake/modules/FindXmlSecurityC.cmake.orig
+++ cmake/modules/FindXmlSecurityC.cmake
@@ -22,7 +22,7 @@ select_library_configurations(XmlSecurityC)
mark_as_advanced(XmlSecurityC_INCLUDE_DIR XmlSecurityC_LIBRARY_RELEASE XmlSecurityC_LIBRARY_DEBUG)
include(FindPackageHandleStandardArgs)
-FIND_PACKAGE_HANDLE_STANDARD_ARGS(XmlSecurityC DEFAULT_MSG XmlSecurityC_LIBRARY XmlSecurityC_INCLUDE_DIR XalanC_FOUND XercesC_FOUND OPENSSL_FOUND)
+FIND_PACKAGE_HANDLE_STANDARD_ARGS(XmlSecurityC DEFAULT_MSG XmlSecurityC_LIBRARY XmlSecurityC_INCLUDE_DIR XercesC_FOUND OPENSSL_FOUND)
if(XmlSecurityC_FOUND)
set(XmlSecurityC_INCLUDE_DIRS ${XmlSecurityC_INCLUDE_DIR} ${XercesC_INCLUDE_DIR} ${OPENSSL_INCLUDE_DIR})

View file

@ -0,0 +1,4 @@
libdigidocpp offers creating, signing and verification of digitally signed
documents, according to XAdES and XML-DSIG standards.
digidoc-tool(1) provides a simple CLI.

View file

@ -0,0 +1,50 @@
@bin bin/digidoc-tool
include/digidocpp/
include/digidocpp/Conf.h
include/digidocpp/Container.h
include/digidocpp/DataFile.h
include/digidocpp/Exception.h
include/digidocpp/Exports.h
include/digidocpp/Signature.h
include/digidocpp/XmlConf.h
include/digidocpp/crypto/
include/digidocpp/crypto/PKCS11Signer.h
include/digidocpp/crypto/PKCS12Signer.h
include/digidocpp/crypto/Signer.h
include/digidocpp/crypto/X509Cert.h
@lib lib/libdigidocpp.so.${LIBdigidocpp_VERSION}
lib/pkgconfig/libdigidocpp.pc
@man man/man1/digidoc-tool.1
share/examples/digidocpp/
@sample ${SYSCONFDIR}/digidocpp/
share/examples/digidocpp/798.p12
@sample ${SYSCONFDIR}/digidocpp/798.p12
share/examples/digidocpp/digidocpp.conf
@sample ${SYSCONFDIR}/digidocpp/digidocpp.conf
share/examples/digidocpp/schema/
@sample ${SYSCONFDIR}/digidocpp/schema/
share/examples/digidocpp/schema/OpenDocument_dsig.xsd
@sample ${SYSCONFDIR}/digidocpp/schema/OpenDocument_dsig.xsd
share/examples/digidocpp/schema/OpenDocument_manifest.xsd
@sample ${SYSCONFDIR}/digidocpp/schema/OpenDocument_manifest.xsd
share/examples/digidocpp/schema/OpenDocument_manifest_v1_2.xsd
share/examples/digidocpp/schema/XAdES01903v132-201601-relaxed.xsd
@sample ${SYSCONFDIR}/digidocpp/schema/XAdES01903v132-201601-relaxed.xsd
share/examples/digidocpp/schema/XAdES01903v132-201601.xsd
@sample ${SYSCONFDIR}/digidocpp/schema/XAdES01903v132-201601.xsd
share/examples/digidocpp/schema/XAdES01903v141-201601.xsd
@sample ${SYSCONFDIR}/digidocpp/schema/XAdES01903v141-201601.xsd
share/examples/digidocpp/schema/conf.xsd
@sample ${SYSCONFDIR}/digidocpp/schema/conf.xsd
share/examples/digidocpp/schema/en_31916201v010101.xsd
@sample ${SYSCONFDIR}/digidocpp/schema/en_31916201v010101.xsd
share/examples/digidocpp/schema/ts_119612v020101_additionaltypes_xsd.xsd
@sample ${SYSCONFDIR}/digidocpp/schema/ts_119612v020101_additionaltypes_xsd.xsd
share/examples/digidocpp/schema/ts_119612v020101_sie_xsd.xsd
@sample ${SYSCONFDIR}/digidocpp/schema/ts_119612v020101_sie_xsd.xsd
share/examples/digidocpp/schema/ts_119612v020201_201601xsd.xsd
@sample ${SYSCONFDIR}/digidocpp/schema/ts_119612v020201_201601xsd.xsd
share/examples/digidocpp/schema/xml.xsd
@sample ${SYSCONFDIR}/digidocpp/schema/xml.xsd
share/examples/digidocpp/schema/xmldsig-core-schema.xsd
@sample ${SYSCONFDIR}/digidocpp/schema/xmldsig-core-schema.xsd