SecBSD's official ports repository

This commit is contained in:
purplerain 2023-08-16 22:26:55 +00:00
commit 2c0afcbbf3
Signed by: purplerain
GPG key ID: F42C07F07E2E35B7
64331 changed files with 5339189 additions and 0 deletions

View file

@ -0,0 +1,27 @@
COMMENT= event-driven I/O for Ruby using the Reactor pattern
DISTNAME= eventmachine-1.2.7
CATEGORIES= net devel
HOMEPAGE= http://rubyeventmachine.com/
# ruby or gpl2
PERMIT_PACKAGE= Yes
MODULES= lang/ruby
WANTLIB= crypto ssl ${COMPILER_LIBCXX}
COMPILER = base-clang ports-gcc base-gcc
CONFIGURE_STYLE=ruby gem ext
MODRUBY_TEST = rake
TEST_DEPENDS = ${FULLPKGNAME}:${BUILD_PKGPATH}
do-test:
cd ${WRKSRC} && ${RUBY} -I tests \
-e 'ARGV.each{|f| require f}' -- ./tests/test_*.rb
.include <bsd.port.mk>

View file

@ -0,0 +1,2 @@
SHA256 (eventmachine-1.2.7.gem) = mUAW5CqgQUd7qc/0XL5Q3iBH8l3UGOugA+hPDRZWCXI=
SIZE (eventmachine-1.2.7.gem) = 247296

View file

@ -0,0 +1,27 @@
Index: ext/ed.cpp
--- ext/ed.cpp.orig
+++ ext/ed.cpp
@@ -1115,11 +1115,8 @@ void ConnectionDescriptor::_WriteOutboundData()
}
#endif
- // We should never have gotten here if there were no data to write,
- // so assert that as a sanity check.
- // Don't bother to make sure nbytes is less than output_buffer because
- // if it were we probably would have crashed already.
- assert (nbytes > 0);
+ if (nbytes <= 0)
+ return;
assert (GetSocket() != INVALID_SOCKET);
#ifdef HAVE_WRITEV
@@ -1862,6 +1859,9 @@ void DatagramDescriptor::Write()
EpollEvent.events |= EPOLLOUT;
assert (MyEventMachine);
MyEventMachine->Modify (this);
+ #endif
+ #ifdef HAVE_KQUEUE
+ MyEventMachine->ArmKqueueWriter (this);
#endif
#ifdef HAVE_KQUEUE
bKqueueArmWrite = SelectForWrite();

View file

@ -0,0 +1,48 @@
Index: ext/em.cpp
--- ext/em.cpp.orig
+++ ext/em.cpp
@@ -375,7 +375,7 @@ void EventMachine_t::_InitializeLoopBreaker()
for (i=0; i < 100; i++) {
int r = (rand() % 10000) + 20000;
LoopBreakerTarget.sin_port = htons (r);
- if (bind (sd, (struct sockaddr*)&LoopBreakerTarget, sizeof(LoopBreakerTarget)) == 0)
+ if (::bind (sd, (struct sockaddr*)&LoopBreakerTarget, sizeof(LoopBreakerTarget)) == 0)
break;
}
@@ -1239,7 +1239,7 @@ const uintptr_t EventMachine_t::ConnectToServer (const
snprintf (buf, sizeof(buf)-1, "invalid bind address: %s", gai_strerror(gai));
throw std::runtime_error (buf);
}
- if (bind (sd, (struct sockaddr *)&bind_to, bind_to_len) < 0) {
+ if (::bind (sd, (struct sockaddr *)&bind_to, bind_to_len) < 0) {
close (sd);
throw std::runtime_error ("couldn't bind to address");
}
@@ -1620,7 +1620,7 @@ const uintptr_t EventMachine_t::CreateTcpServer (const
}
- if (bind (sd_accept, (struct sockaddr *)&bind_here, bind_here_len)) {
+ if (::bind (sd_accept, (struct sockaddr *)&bind_here, bind_here_len)) {
//__warning ("binding failed");
goto fail;
}
@@ -1667,7 +1667,7 @@ const uintptr_t EventMachine_t::OpenDatagramSocket (co
if (!SetSocketNonblocking (sd))
goto fail;
- if (bind (sd, (struct sockaddr *)&bind_here, bind_here_len) != 0)
+ if (::bind (sd, (struct sockaddr *)&bind_here, bind_here_len) != 0)
goto fail;
{ // Looking good.
@@ -1953,7 +1953,7 @@ const uintptr_t EventMachine_t::CreateUnixDomainServer
#endif
}
- if (bind (sd_accept, (struct sockaddr*)&s_sun, sizeof(s_sun))) {
+ if (::bind (sd_accept, (struct sockaddr*)&s_sun, sizeof(s_sun))) {
//__warning ("binding failed");
goto fail;
}

View file

@ -0,0 +1,12 @@
Index: ext/extconf.rb
--- ext/extconf.rb.orig
+++ ext/extconf.rb
@@ -147,7 +147,7 @@ if RbConfig::CONFIG["host_os"] =~ /mingw/
add_define "FD_SETSIZE=32767" unless found
end
-# Main platform invariances:
+create_makefile "rubyeventmachine"
case RUBY_PLATFORM
when /mswin32/, /mingw32/, /bccwin32/

View file

@ -0,0 +1,18 @@
Skip test that crashes with SIGILL. This same code also crashes
previous versions, so it is not a regression, just a newly added
test. Details at:
https://github.com/eventmachine/eventmachine/issues/777
Index: tests/test_exc.rb
--- tests/test_exc.rb.orig
+++ tests/test_exc.rb
@@ -32,7 +32,7 @@ class TestSomeExceptions < Test::Unit::TestCase
}
end
- def test_exception_on_unbind
+ def skip_test_exception_on_unbind
assert_raises(DoomedConnectionError) {
EM.run {
EM.connect("localhost", 8888, DoomedConnection)

View file

@ -0,0 +1,14 @@
EventMachine is a Ruby library providing event-driven I/O using the
Reactor pattern. EventMachine is designed to simultaneously meet
two key needs:
* Extremely high scalability, performance and stability for the
most demanding production environments; and
* An API that eliminates the complexities of high-performance
threaded network programming, allowing engineers to
concentrate on their application logic.
This unique combination makes EventMachine a premier choice for
designers of critical networked applications, including web servers
and proxies, email and IM production systems,
authentication/authorization processors, and many more.

View file

@ -0,0 +1,158 @@
${GEM_LIB}/cache/${DISTNAME}.gem
${GEM_LIB}/gems/${DISTNAME}/
${GEM_LIB}/gems/${DISTNAME}/CHANGELOG.md
${GEM_LIB}/gems/${DISTNAME}/GNU
${GEM_LIB}/gems/${DISTNAME}/LICENSE
${GEM_LIB}/gems/${DISTNAME}/README.md
${GEM_LIB}/gems/${DISTNAME}/docs/
${GEM_LIB}/gems/${DISTNAME}/docs/DocumentationGuidesIndex.md
${GEM_LIB}/gems/${DISTNAME}/docs/GettingStarted.md
${GEM_LIB}/gems/${DISTNAME}/docs/old/
${GEM_LIB}/gems/${DISTNAME}/docs/old/ChangeLog
${GEM_LIB}/gems/${DISTNAME}/docs/old/DEFERRABLES
${GEM_LIB}/gems/${DISTNAME}/docs/old/EPOLL
${GEM_LIB}/gems/${DISTNAME}/docs/old/INSTALL
${GEM_LIB}/gems/${DISTNAME}/docs/old/KEYBOARD
${GEM_LIB}/gems/${DISTNAME}/docs/old/LEGAL
${GEM_LIB}/gems/${DISTNAME}/docs/old/LIGHTWEIGHT_CONCURRENCY
${GEM_LIB}/gems/${DISTNAME}/docs/old/PURE_RUBY
${GEM_LIB}/gems/${DISTNAME}/docs/old/RELEASE_NOTES
${GEM_LIB}/gems/${DISTNAME}/docs/old/SMTP
${GEM_LIB}/gems/${DISTNAME}/docs/old/SPAWNED_PROCESSES
${GEM_LIB}/gems/${DISTNAME}/docs/old/TODO
${GEM_LIB}/gems/${DISTNAME}/examples/
${GEM_LIB}/gems/${DISTNAME}/examples/guides/
${GEM_LIB}/gems/${DISTNAME}/examples/guides/getting_started/
${GEM_LIB}/gems/${DISTNAME}/examples/guides/getting_started/01_eventmachine_echo_server.rb
${GEM_LIB}/gems/${DISTNAME}/examples/guides/getting_started/02_eventmachine_echo_server_that_recognizes_exit_command.rb
${GEM_LIB}/gems/${DISTNAME}/examples/guides/getting_started/03_simple_chat_server.rb
${GEM_LIB}/gems/${DISTNAME}/examples/guides/getting_started/04_simple_chat_server_step_one.rb
${GEM_LIB}/gems/${DISTNAME}/examples/guides/getting_started/05_simple_chat_server_step_two.rb
${GEM_LIB}/gems/${DISTNAME}/examples/guides/getting_started/06_simple_chat_server_step_three.rb
${GEM_LIB}/gems/${DISTNAME}/examples/guides/getting_started/07_simple_chat_server_step_four.rb
${GEM_LIB}/gems/${DISTNAME}/examples/guides/getting_started/08_simple_chat_server_step_five.rb
${GEM_LIB}/gems/${DISTNAME}/examples/old/
${GEM_LIB}/gems/${DISTNAME}/examples/old/ex_channel.rb
${GEM_LIB}/gems/${DISTNAME}/examples/old/ex_queue.rb
${GEM_LIB}/gems/${DISTNAME}/examples/old/ex_tick_loop_array.rb
${GEM_LIB}/gems/${DISTNAME}/examples/old/ex_tick_loop_counter.rb
${GEM_LIB}/gems/${DISTNAME}/examples/old/helper.rb
${GEM_LIB}/gems/${DISTNAME}/lib/
${GEM_LIB}/gems/${DISTNAME}/lib/em/
${GEM_LIB}/gems/${DISTNAME}/lib/em/buftok.rb
${GEM_LIB}/gems/${DISTNAME}/lib/em/callback.rb
${GEM_LIB}/gems/${DISTNAME}/lib/em/channel.rb
${GEM_LIB}/gems/${DISTNAME}/lib/em/completion.rb
${GEM_LIB}/gems/${DISTNAME}/lib/em/connection.rb
${GEM_LIB}/gems/${DISTNAME}/lib/em/deferrable/
${GEM_LIB}/gems/${DISTNAME}/lib/em/deferrable.rb
${GEM_LIB}/gems/${DISTNAME}/lib/em/deferrable/pool.rb
${GEM_LIB}/gems/${DISTNAME}/lib/em/file_watch.rb
${GEM_LIB}/gems/${DISTNAME}/lib/em/future.rb
${GEM_LIB}/gems/${DISTNAME}/lib/em/iterator.rb
${GEM_LIB}/gems/${DISTNAME}/lib/em/messages.rb
${GEM_LIB}/gems/${DISTNAME}/lib/em/pool.rb
${GEM_LIB}/gems/${DISTNAME}/lib/em/process_watch.rb
${GEM_LIB}/gems/${DISTNAME}/lib/em/processes.rb
${GEM_LIB}/gems/${DISTNAME}/lib/em/protocols/
${GEM_LIB}/gems/${DISTNAME}/lib/em/protocols.rb
${GEM_LIB}/gems/${DISTNAME}/lib/em/protocols/header_and_content.rb
${GEM_LIB}/gems/${DISTNAME}/lib/em/protocols/httpclient.rb
${GEM_LIB}/gems/${DISTNAME}/lib/em/protocols/httpclient2.rb
${GEM_LIB}/gems/${DISTNAME}/lib/em/protocols/line_and_text.rb
${GEM_LIB}/gems/${DISTNAME}/lib/em/protocols/line_protocol.rb
${GEM_LIB}/gems/${DISTNAME}/lib/em/protocols/linetext2.rb
${GEM_LIB}/gems/${DISTNAME}/lib/em/protocols/memcache.rb
${GEM_LIB}/gems/${DISTNAME}/lib/em/protocols/object_protocol.rb
${GEM_LIB}/gems/${DISTNAME}/lib/em/protocols/postgres3.rb
${GEM_LIB}/gems/${DISTNAME}/lib/em/protocols/saslauth.rb
${GEM_LIB}/gems/${DISTNAME}/lib/em/protocols/smtpclient.rb
${GEM_LIB}/gems/${DISTNAME}/lib/em/protocols/smtpserver.rb
${GEM_LIB}/gems/${DISTNAME}/lib/em/protocols/socks4.rb
${GEM_LIB}/gems/${DISTNAME}/lib/em/protocols/stomp.rb
${GEM_LIB}/gems/${DISTNAME}/lib/em/protocols/tcptest.rb
${GEM_LIB}/gems/${DISTNAME}/lib/em/pure_ruby.rb
${GEM_LIB}/gems/${DISTNAME}/lib/em/queue.rb
${GEM_LIB}/gems/${DISTNAME}/lib/em/resolver.rb
${GEM_LIB}/gems/${DISTNAME}/lib/em/spawnable.rb
${GEM_LIB}/gems/${DISTNAME}/lib/em/streamer.rb
${GEM_LIB}/gems/${DISTNAME}/lib/em/threaded_resource.rb
${GEM_LIB}/gems/${DISTNAME}/lib/em/tick_loop.rb
${GEM_LIB}/gems/${DISTNAME}/lib/em/timers.rb
${GEM_LIB}/gems/${DISTNAME}/lib/em/version.rb
${GEM_LIB}/gems/${DISTNAME}/lib/eventmachine.rb
${GEM_LIB}/gems/${DISTNAME}/lib/fastfilereaderext.so
${GEM_LIB}/gems/${DISTNAME}/lib/jeventmachine.rb
${GEM_LIB}/gems/${DISTNAME}/lib/rubyeventmachine.so
${GEM_LIB}/gems/${DISTNAME}/rakelib/
${GEM_LIB}/gems/${DISTNAME}/rakelib/package.rake
${GEM_LIB}/gems/${DISTNAME}/rakelib/test.rake
${GEM_LIB}/gems/${DISTNAME}/rakelib/test_pure.rake
${GEM_LIB}/gems/${DISTNAME}/tests/
${GEM_LIB}/gems/${DISTNAME}/tests/client.crt
${GEM_LIB}/gems/${DISTNAME}/tests/client.key
${GEM_LIB}/gems/${DISTNAME}/tests/dhparam.pem
${GEM_LIB}/gems/${DISTNAME}/tests/em_test_helper.rb
${GEM_LIB}/gems/${DISTNAME}/tests/test_attach.rb
${GEM_LIB}/gems/${DISTNAME}/tests/test_basic.rb
${GEM_LIB}/gems/${DISTNAME}/tests/test_channel.rb
${GEM_LIB}/gems/${DISTNAME}/tests/test_completion.rb
${GEM_LIB}/gems/${DISTNAME}/tests/test_connection_count.rb
${GEM_LIB}/gems/${DISTNAME}/tests/test_connection_write.rb
${GEM_LIB}/gems/${DISTNAME}/tests/test_defer.rb
${GEM_LIB}/gems/${DISTNAME}/tests/test_deferrable.rb
${GEM_LIB}/gems/${DISTNAME}/tests/test_epoll.rb
${GEM_LIB}/gems/${DISTNAME}/tests/test_error_handler.rb
${GEM_LIB}/gems/${DISTNAME}/tests/test_exc.rb
${GEM_LIB}/gems/${DISTNAME}/tests/test_file_watch.rb
${GEM_LIB}/gems/${DISTNAME}/tests/test_fork.rb
${GEM_LIB}/gems/${DISTNAME}/tests/test_futures.rb
${GEM_LIB}/gems/${DISTNAME}/tests/test_handler_check.rb
${GEM_LIB}/gems/${DISTNAME}/tests/test_hc.rb
${GEM_LIB}/gems/${DISTNAME}/tests/test_httpclient.rb
${GEM_LIB}/gems/${DISTNAME}/tests/test_httpclient2.rb
${GEM_LIB}/gems/${DISTNAME}/tests/test_idle_connection.rb
${GEM_LIB}/gems/${DISTNAME}/tests/test_inactivity_timeout.rb
${GEM_LIB}/gems/${DISTNAME}/tests/test_ipv4.rb
${GEM_LIB}/gems/${DISTNAME}/tests/test_ipv6.rb
${GEM_LIB}/gems/${DISTNAME}/tests/test_iterator.rb
${GEM_LIB}/gems/${DISTNAME}/tests/test_kb.rb
${GEM_LIB}/gems/${DISTNAME}/tests/test_line_protocol.rb
${GEM_LIB}/gems/${DISTNAME}/tests/test_ltp.rb
${GEM_LIB}/gems/${DISTNAME}/tests/test_ltp2.rb
${GEM_LIB}/gems/${DISTNAME}/tests/test_many_fds.rb
${GEM_LIB}/gems/${DISTNAME}/tests/test_next_tick.rb
${GEM_LIB}/gems/${DISTNAME}/tests/test_object_protocol.rb
${GEM_LIB}/gems/${DISTNAME}/tests/test_pause.rb
${GEM_LIB}/gems/${DISTNAME}/tests/test_pending_connect_timeout.rb
${GEM_LIB}/gems/${DISTNAME}/tests/test_pool.rb
${GEM_LIB}/gems/${DISTNAME}/tests/test_process_watch.rb
${GEM_LIB}/gems/${DISTNAME}/tests/test_processes.rb
${GEM_LIB}/gems/${DISTNAME}/tests/test_proxy_connection.rb
${GEM_LIB}/gems/${DISTNAME}/tests/test_pure.rb
${GEM_LIB}/gems/${DISTNAME}/tests/test_queue.rb
${GEM_LIB}/gems/${DISTNAME}/tests/test_resolver.rb
${GEM_LIB}/gems/${DISTNAME}/tests/test_running.rb
${GEM_LIB}/gems/${DISTNAME}/tests/test_sasl.rb
${GEM_LIB}/gems/${DISTNAME}/tests/test_send_file.rb
${GEM_LIB}/gems/${DISTNAME}/tests/test_servers.rb
${GEM_LIB}/gems/${DISTNAME}/tests/test_shutdown_hooks.rb
${GEM_LIB}/gems/${DISTNAME}/tests/test_smtpclient.rb
${GEM_LIB}/gems/${DISTNAME}/tests/test_smtpserver.rb
${GEM_LIB}/gems/${DISTNAME}/tests/test_sock_opt.rb
${GEM_LIB}/gems/${DISTNAME}/tests/test_spawn.rb
${GEM_LIB}/gems/${DISTNAME}/tests/test_ssl_args.rb
${GEM_LIB}/gems/${DISTNAME}/tests/test_ssl_dhparam.rb
${GEM_LIB}/gems/${DISTNAME}/tests/test_ssl_ecdh_curve.rb
${GEM_LIB}/gems/${DISTNAME}/tests/test_ssl_extensions.rb
${GEM_LIB}/gems/${DISTNAME}/tests/test_ssl_methods.rb
${GEM_LIB}/gems/${DISTNAME}/tests/test_ssl_protocols.rb
${GEM_LIB}/gems/${DISTNAME}/tests/test_ssl_verify.rb
${GEM_LIB}/gems/${DISTNAME}/tests/test_stomp.rb
${GEM_LIB}/gems/${DISTNAME}/tests/test_system.rb
${GEM_LIB}/gems/${DISTNAME}/tests/test_threaded_resource.rb
${GEM_LIB}/gems/${DISTNAME}/tests/test_tick_loop.rb
${GEM_LIB}/gems/${DISTNAME}/tests/test_timers.rb
${GEM_LIB}/gems/${DISTNAME}/tests/test_ud.rb
${GEM_LIB}/gems/${DISTNAME}/tests/test_unbind_reason.rb
${GEM_LIB}/specifications/${DISTNAME}.gemspec