SecBSD's official ports repository
This commit is contained in:
commit
2c0afcbbf3
64331 changed files with 5339189 additions and 0 deletions
16
net/p5-Net-MySQL/Makefile
Normal file
16
net/p5-Net-MySQL/Makefile
Normal file
|
@ -0,0 +1,16 @@
|
|||
COMMENT= Pure Perl MySQL network protocol interface
|
||||
|
||||
VERSION= 0.11
|
||||
DISTNAME= Net-MySQL-${VERSION}
|
||||
CATEGORIES= net
|
||||
REVISION= 0
|
||||
|
||||
# GPL/Artistic License
|
||||
PERMIT_PACKAGE= Yes
|
||||
|
||||
RUN_DEPENDS= security/p5-Digest-SHA1
|
||||
|
||||
MODULES= cpan
|
||||
PKG_ARCH= *
|
||||
|
||||
.include <bsd.port.mk>
|
2
net/p5-Net-MySQL/distinfo
Normal file
2
net/p5-Net-MySQL/distinfo
Normal file
|
@ -0,0 +1,2 @@
|
|||
SHA256 (Net-MySQL-0.11.tar.gz) = YanV9BGbVDiEh8300bq+pzFTgUVsSz1ST8gIiRu8Omk=
|
||||
SIZE (Net-MySQL-0.11.tar.gz) = 10429
|
20
net/p5-Net-MySQL/patches/patch-MySQL_pm
Normal file
20
net/p5-Net-MySQL/patches/patch-MySQL_pm
Normal file
|
@ -0,0 +1,20 @@
|
|||
--- MySQL.pm.orig Wed Jul 24 08:49:56 2002
|
||||
+++ MySQL.pm Fri Aug 9 12:28:33 2002
|
||||
@@ -31,7 +31,7 @@ use constant COMMAND_CONNECT_OUT => "
|
||||
|
||||
use constant DEFAULT_PORT_NUMBER => 3306;
|
||||
use constant BUFFER_LENGTH => 1460;
|
||||
-use constant DEFAULT_UNIX_SOCKET => '/tmp/mysql.sock';
|
||||
+use constant DEFAULT_UNIX_SOCKET => '/var/run/mysql/mysql.sock';
|
||||
|
||||
|
||||
sub new {
|
||||
@@ -785,7 +785,7 @@ The constructor of Net::MySQL. Connectio
|
||||
|
||||
=item unixsocket
|
||||
|
||||
-Path of the UNIX socket where MySQL daemon. default is F</tmp/mysql.sock>.
|
||||
+Path of the UNIX socket where MySQL daemon. default is F</var/run/mysql/mysql.sock>.
|
||||
Supposing I<hostname> is omitted, it will connect by I<UNIX Socket>.
|
||||
|
||||
=item hostname
|
15
net/p5-Net-MySQL/patches/patch-script_mysql_pl
Normal file
15
net/p5-Net-MySQL/patches/patch-script_mysql_pl
Normal file
|
@ -0,0 +1,15 @@
|
|||
--- script/mysql.pl.orig Mon Jul 22 05:12:53 2002
|
||||
+++ script/mysql.pl Fri Aug 9 12:28:27 2002
|
||||
@@ -70,10 +70,10 @@ exit;
|
||||
sub show_usage
|
||||
{
|
||||
die <<__USAGE__;
|
||||
-Usage: mysq.pl [-?v] [-s /tmp/mysql.sock] [-h HOSTNAME] [-P PORT] [-u USER] DATABASE
|
||||
+Usage: mysq.pl [-?v] [-s /var/run/mysql/mysql.sock] [-h HOSTNAME] [-P PORT] [-u USER] DATABASE
|
||||
|
||||
-? Display this help and exit.
|
||||
- -s Path to Unix socket. (default /tmp/mysql.sock)
|
||||
+ -s Path to Unix socket. (default /var/run/mysql/mysql.sock)
|
||||
-h Connect to host.
|
||||
-P Port number to user for connection.(default 3306)
|
||||
-u User for login if not current user.
|
6
net/p5-Net-MySQL/pkg/DESCR
Normal file
6
net/p5-Net-MySQL/pkg/DESCR
Normal file
|
@ -0,0 +1,6 @@
|
|||
Net::MySQL is a Pure Perl client interface for the MySQL database.
|
||||
This module implements network protocol between server and client
|
||||
of MySQL, thus you don't need external MySQL client library like
|
||||
libmysqlclient for this module to work. It means this module enables
|
||||
you to connect to MySQL server from some operation systems which
|
||||
MySQL is not ported. How nifty!
|
3
net/p5-Net-MySQL/pkg/PLIST
Normal file
3
net/p5-Net-MySQL/pkg/PLIST
Normal file
|
@ -0,0 +1,3 @@
|
|||
${P5SITE}/Net/
|
||||
${P5SITE}/Net/MySQL.pm
|
||||
@man man/man3p/Net::MySQL.3p
|
Loading…
Add table
Add a link
Reference in a new issue