SecBSD's official ports repository

This commit is contained in:
purplerain 2023-08-16 22:26:55 +00:00
commit 2c0afcbbf3
Signed by: purplerain
GPG key ID: F42C07F07E2E35B7
64331 changed files with 5339189 additions and 0 deletions

View file

@ -0,0 +1,18 @@
COMMENT = simple irc bot baseclass
MODULES = cpan
PKG_ARCH = *
DISTNAME = Bot-BasicBot-0.93
CATEGORIES = net
REVISION = 0
# Perl
PERMIT_PACKAGE = Yes
RUN_DEPENDS = devel/p5-POE \
net/p5-POE-Component-IRC>=6.90 \
net/p5-IRC-Utils
MODCPAN_EXAMPLES= Yes
.include <bsd.port.mk>

View file

@ -0,0 +1,2 @@
SHA256 (Bot-BasicBot-0.93.tar.gz) = 8hA8/zxIIGpAMFWbzA2hBGpj9ExS2k6+X3iRLn/tBeQ=
SIZE (Bot-BasicBot-0.93.tar.gz) = 26420

View file

@ -0,0 +1,15 @@
Avoid live test!
--- t/connect.t.orig Mon Nov 15 21:05:12 2010
+++ t/connect.t Wed Mar 16 09:46:56 2011
@@ -7,6 +7,10 @@ plan skip_all => 'This test should use POE::Component:
use lib qw(lib t/lib);
+# not at all, no!
+plan skip_all => "test disabled by port maintainer";
+exit;
+
require IO::Socket;
my $s = IO::Socket::INET->new(
PeerAddr => "irc.perl.org:80",

View file

@ -0,0 +1,2 @@
Basic bot system designed to make it easy to do simple bots, optionally
forking longer processes (like searches) concurrently in the background.

View file

@ -0,0 +1,10 @@
${P5SITE}/Bot/
@comment ${P5SITE}/Bot/._BasicBot.pm
${P5SITE}/Bot/BasicBot.pm
@man man/man3p/Bot::BasicBot.3p
share/examples/p5-Bot-BasicBot/
share/examples/p5-Bot-BasicBot/countdownbot.pl
share/examples/p5-Bot-BasicBot/cpanbot.pl
share/examples/p5-Bot-BasicBot/namer.pl
share/examples/p5-Bot-BasicBot/tailbot.pl
share/examples/p5-Bot-BasicBot/tango.pl