SecBSD's official ports repository

This commit is contained in:
purplerain 2023-08-16 22:26:55 +00:00
commit 2c0afcbbf3
Signed by: purplerain
GPG key ID: F42C07F07E2E35B7
64331 changed files with 5339189 additions and 0 deletions

View file

@ -0,0 +1,17 @@
Index: configure.ac.in
--- configure.ac.in.orig
+++ configure.ac.in
@@ -432,10 +432,10 @@ fi
DATE=`date +"%Y-%m-%d"`
-if test -d "/usr/include/hiredis"; then
+if pkg-config --exists hiredis; then
AC_DEFINE_UNQUOTED(HAVE_HIREDIS, 1, [Local hiredis package present])
- HIREDIS_INC="`pkg-config --cflags hiredis` -I/usr/include/hiredis"
- HIREDIS_LIB="`pkg-config --libs hiredis` -lhiredis"
+ HIREDIS_INC="`pkg-config --cflags hiredis`"
+ HIREDIS_LIB="`pkg-config --libs hiredis`"
else
HIREDIS_INC="-I ${HERE}/third-party/hiredis"
fi