SecBSD's official ports repository

This commit is contained in:
purplerain 2023-08-16 22:26:55 +00:00
commit 2c0afcbbf3
Signed by: purplerain
GPG key ID: F42C07F07E2E35B7
64331 changed files with 5339189 additions and 0 deletions

View file

@ -0,0 +1,38 @@
--- configure.in.orig Tue Aug 7 00:22:01 2012
+++ configure.in Wed Apr 15 11:15:31 2015
@@ -73,7 +73,19 @@ fi
AM_CONDITIONAL(HAVE_OSS,test "$have_oss" = yes)
+dnl ================================================================
+dnl Check for sndio
+dnl ================================================================
+AC_CHECK_HEADER(sndio.h, have_sndio=yes, have_sndio=no)
+AM_CONDITIONAL(HAVE_SNDIO, test "$have_sndio" = yes)
+if test "$have_sndio" = yes; then
+ SNDIO_LIBS="-lsndio"
+ AC_DEFINE(HAVE_SNDIO,,[Define to enable sndio input module])
+fi
+
+AM_CONDITIONAL(HAVE_SNDIO,test "$have_sndio" = yes)
+
dnl ================================================================
dnl Check for Sun audio
dnl ================================================================
@@ -173,6 +185,7 @@ XIPH_VAR_PREPEND([XIPH_LIBS], [$VORBISENC_LIBS $VORBIS
dnl Make substitutions
AC_SUBST(ALSA_LIBS)
+AC_SUBST(SNDIO_LIBS)
AC_SUBST(ROARAUDIO_LIBS)
AC_SUBST(XML_LIBS)
AC_SUBST(XML_CFLAGS)
@@ -198,6 +211,7 @@ echo "
Build with alsa: $have_alsa
Build with OSS: $have_oss
+ Build with sndio: $have_sndio
Build with Sun audio: $have_sun_audio
Build with RoarAudio: $have_roaraudio