SecBSD's official ports repository
This commit is contained in:
commit
2c0afcbbf3
64331 changed files with 5339189 additions and 0 deletions
37
net/darkstat/patches/patch-configure_ac
Normal file
37
net/darkstat/patches/patch-configure_ac
Normal file
|
@ -0,0 +1,37 @@
|
|||
Re-instate the chroot by default code.
|
||||
|
||||
Index: configure.ac
|
||||
--- configure.ac.orig
|
||||
+++ configure.ac
|
||||
@@ -6,6 +6,31 @@ AC_CONFIG_HEADER([config.h])
|
||||
|
||||
RULE="------------------------------------------------------------"
|
||||
|
||||
+# Let user specify CHROOT_DIR, or else autodetect it, or else die.
|
||||
+AC_ARG_WITH(chroot-dir, AS_HELP_STRING([--with-chroot-dir],
|
||||
+ [specify the chroot directory (default: /var/empty)]),
|
||||
+ [if test "x$withval" = "xyes"; then
|
||||
+ AC_MSG_ERROR([please specify --with-chroot-dir=/path/to/darkstat/chroot])
|
||||
+ fi
|
||||
+ _chd="$withval"],
|
||||
+ [# Find an "empty" directory to serve as the chroot.
|
||||
+ _chd="/var/empty"
|
||||
+ AC_MSG_CHECKING([for $_chd])
|
||||
+ if test -d $_chd ; then
|
||||
+ AC_MSG_RESULT(found it)
|
||||
+ else
|
||||
+ AC_MSG_RESULT(not there)
|
||||
+ _chd="/var/lib/empty"
|
||||
+ AC_MSG_CHECKING([for $_chd])
|
||||
+ if test -d $_chd ; then
|
||||
+ AC_MSG_RESULT(found it)
|
||||
+ else
|
||||
+ AC_MSG_RESULT(not there either)
|
||||
+ AC_MSG_ERROR([please specify --with-chroot-dir=/path/to/darkstat/chroot])
|
||||
+ fi
|
||||
+ fi])
|
||||
+AC_DEFINE_UNQUOTED(CHROOT_DIR, "$_chd", [Default chroot directory.])
|
||||
+
|
||||
# Allow configure-time override of PRIVDROP_USER.
|
||||
AC_ARG_WITH(privdrop-user, AS_HELP_STRING([--with-privdrop-user],
|
||||
[specify which user to drop privileges to (default: nobody)]),
|
Loading…
Add table
Add a link
Reference in a new issue