SecBSD's official ports repository
This commit is contained in:
commit
2c0afcbbf3
64331 changed files with 5339189 additions and 0 deletions
83
net/curl/patches/patch-configure_ac
Normal file
83
net/curl/patches/patch-configure_ac
Normal file
|
@ -0,0 +1,83 @@
|
|||
Revert "ngtcp2: build with 0.17.0 and nghttp3 0.13.0"
|
||||
https://github.com/curl/curl/commit/e0093b4b732f6495b0fb1cd6747cbfedcdcf63ed
|
||||
|
||||
Index: configure.ac
|
||||
--- configure.ac.orig
|
||||
+++ configure.ac
|
||||
@@ -2947,42 +2947,42 @@ if test X"$want_tcp2" != Xno; then
|
||||
fi
|
||||
|
||||
if test "x$NGTCP2_ENABLED" = "x1" -a "x$OPENSSL_ENABLED" = "x1"; then
|
||||
- dnl backup the pre-ngtcp2_crypto_quictls variables
|
||||
+ dnl backup the pre-ngtcp2_crypto_openssl variables
|
||||
CLEANLDFLAGS="$LDFLAGS"
|
||||
CLEANCPPFLAGS="$CPPFLAGS"
|
||||
CLEANLIBS="$LIBS"
|
||||
|
||||
- CURL_CHECK_PKGCONFIG(libngtcp2_crypto_quictls, $want_tcp2_path)
|
||||
+ CURL_CHECK_PKGCONFIG(libngtcp2_crypto_openssl, $want_tcp2_path)
|
||||
|
||||
if test "$PKGCONFIG" != "no" ; then
|
||||
- LIB_NGTCP2_CRYPTO_QUICTLS=`CURL_EXPORT_PCDIR([$want_tcp2_path])
|
||||
- $PKGCONFIG --libs-only-l libngtcp2_crypto_quictls`
|
||||
- AC_MSG_NOTICE([-l is $LIB_NGTCP2_CRYPTO_QUICTLS])
|
||||
+ LIB_NGTCP2_CRYPTO_OPENSSL=`CURL_EXPORT_PCDIR([$want_tcp2_path])
|
||||
+ $PKGCONFIG --libs-only-l libngtcp2_crypto_openssl`
|
||||
+ AC_MSG_NOTICE([-l is $LIB_NGTCP2_CRYPTO_OPENSSL])
|
||||
|
||||
- CPP_NGTCP2_CRYPTO_QUICTLS=`CURL_EXPORT_PCDIR([$want_tcp2_path]) dnl
|
||||
- $PKGCONFIG --cflags-only-I libngtcp2_crypto_quictls`
|
||||
- AC_MSG_NOTICE([-I is $CPP_NGTCP2_CRYPTO_QUICTLS])
|
||||
+ CPP_NGTCP2_CRYPTO_OPENSSL=`CURL_EXPORT_PCDIR([$want_tcp2_path]) dnl
|
||||
+ $PKGCONFIG --cflags-only-I libngtcp2_crypto_openssl`
|
||||
+ AC_MSG_NOTICE([-I is $CPP_NGTCP2_CRYPTO_OPENSSL])
|
||||
|
||||
- LD_NGTCP2_CRYPTO_QUICTLS=`CURL_EXPORT_PCDIR([$want_tcp2_path])
|
||||
- $PKGCONFIG --libs-only-L libngtcp2_crypto_quictls`
|
||||
- AC_MSG_NOTICE([-L is $LD_NGTCP2_CRYPTO_QUICTLS])
|
||||
+ LD_NGTCP2_CRYPTO_OPENSSL=`CURL_EXPORT_PCDIR([$want_tcp2_path])
|
||||
+ $PKGCONFIG --libs-only-L libngtcp2_crypto_openssl`
|
||||
+ AC_MSG_NOTICE([-L is $LD_NGTCP2_CRYPTO_OPENSSL])
|
||||
|
||||
- LDFLAGS="$LDFLAGS $LD_NGTCP2_CRYPTO_QUICTLS"
|
||||
- CPPFLAGS="$CPPFLAGS $CPP_NGTCP2_CRYPTO_QUICTLS"
|
||||
- LIBS="$LIB_NGTCP2_CRYPTO_QUICTLS $LIBS"
|
||||
+ LDFLAGS="$LDFLAGS $LD_NGTCP2_CRYPTO_OPENSSL"
|
||||
+ CPPFLAGS="$CPPFLAGS $CPP_NGTCP2_CRYPTO_OPENSSL"
|
||||
+ LIBS="$LIB_NGTCP2_CRYPTO_OPENSSL $LIBS"
|
||||
|
||||
if test "x$cross_compiling" != "xyes"; then
|
||||
- DIR_NGTCP2_CRYPTO_QUICTLS=`echo $LD_NGTCP2_CRYPTO_QUICTLS | $SED -e 's/^-L//'`
|
||||
+ DIR_NGTCP2_CRYPTO_OPENSSL=`echo $LD_NGTCP2_CRYPTO_OPENSSL | $SED -e 's/^-L//'`
|
||||
fi
|
||||
- AC_CHECK_LIB(ngtcp2_crypto_quictls, ngtcp2_crypto_recv_client_initial_cb,
|
||||
+ AC_CHECK_LIB(ngtcp2_crypto_openssl, ngtcp2_crypto_recv_client_initial_cb,
|
||||
[
|
||||
AC_CHECK_HEADERS(ngtcp2/ngtcp2_crypto.h,
|
||||
NGTCP2_ENABLED=1
|
||||
- AC_DEFINE(USE_NGTCP2_CRYPTO_QUICTLS, 1, [if ngtcp2_crypto_quictls is in use])
|
||||
- AC_SUBST(USE_NGTCP2_CRYPTO_QUICTLS, [1])
|
||||
- CURL_LIBRARY_PATH="$CURL_LIBRARY_PATH:$DIR_NGTCP2_CRYPTO_QUICTLS"
|
||||
+ AC_DEFINE(USE_NGTCP2_CRYPTO_OPENSSL, 1, [if ngtcp2_crypto_openssl is in use])
|
||||
+ AC_SUBST(USE_NGTCP2_CRYPTO_OPENSSL, [1])
|
||||
+ CURL_LIBRARY_PATH="$CURL_LIBRARY_PATH:$DIR_NGTCP2_CRYPTO_OPENSSL"
|
||||
export CURL_LIBRARY_PATH
|
||||
- AC_MSG_NOTICE([Added $DIR_NGTCP2_CRYPTO_QUICTLS to CURL_LIBRARY_PATH])
|
||||
+ AC_MSG_NOTICE([Added $DIR_NGTCP2_CRYPTO_OPENSSL to CURL_LIBRARY_PATH])
|
||||
)
|
||||
],
|
||||
dnl not found, revert back to clean variables
|
||||
@@ -2992,11 +2992,11 @@ if test "x$NGTCP2_ENABLED" = "x1" -a "x$OPENSSL_ENABLE
|
||||
)
|
||||
|
||||
else
|
||||
- dnl no ngtcp2_crypto_quictls pkg-config found, deal with it
|
||||
+ dnl no ngtcp2_crypto_openssl pkg-config found, deal with it
|
||||
if test X"$want_tcp2" != Xdefault; then
|
||||
dnl To avoid link errors, we do not allow --with-ngtcp2 without
|
||||
dnl a pkgconfig file
|
||||
- AC_MSG_ERROR([--with-ngtcp2 was specified but could not find ngtcp2_crypto_quictls pkg-config file.])
|
||||
+ AC_MSG_ERROR([--with-ngtcp2 was specified but could not find ngtcp2_crypto_openssl pkg-config file.])
|
||||
fi
|
||||
fi
|
||||
fi
|
Loading…
Add table
Add a link
Reference in a new issue