SecBSD's official ports repository

This commit is contained in:
purplerain 2023-08-16 22:26:55 +00:00
commit 2c0afcbbf3
Signed by: purplerain
GPG key ID: F42C07F07E2E35B7
64331 changed files with 5339189 additions and 0 deletions

View file

@ -0,0 +1,20 @@
Use dependencies we already have in the ports tree.
Index: setup.py
--- setup.py.orig
+++ setup.py
@@ -17,11 +17,11 @@ deps = [
]
# for encrypted streams
-if environ.get("STREAMLINK_USE_PYCRYPTO"):
- deps.append("pycrypto")
-else:
+if environ.get("STREAMLINK_USE_PYCRYPTODOME"):
# this version of pycryptodome is known to work and has a Windows wheel for py2.7, py3.3-3.6
deps.append("pycryptodome>=3.4.3,<4")
+else:
+ deps.append("pycryptodome")
# for localization
if environ.get("STREAMLINK_USE_PYCOUNTRY"):