SecBSD's official ports repository
This commit is contained in:
commit
2c0afcbbf3
64331 changed files with 5339189 additions and 0 deletions
65
math/py-pandas/Makefile
Normal file
65
math/py-pandas/Makefile
Normal file
|
@ -0,0 +1,65 @@
|
|||
COMMENT = data analysis and manipulation library
|
||||
|
||||
MODPY_EGG_VERSION = 1.5.3
|
||||
DISTNAME = pandas-${MODPY_EGG_VERSION}
|
||||
PKGNAME = py-${DISTNAME}
|
||||
|
||||
CATEGORIES = math
|
||||
|
||||
HOMEPAGE = https://pandas.pydata.org/
|
||||
|
||||
# BSD 3-Clause
|
||||
PERMIT_PACKAGE = Yes
|
||||
|
||||
WANTLIB += ${COMPILER_LIBCXX} m ${MODPY_WANTLIB}
|
||||
|
||||
FLAVORS = python3
|
||||
FLAVOR = python3
|
||||
|
||||
MODULES = lang/python
|
||||
MODPY_PI = Yes
|
||||
MODPY_PYBUILD = setuptools
|
||||
# test_dst.py: ValueError: could not convert string to float: '2022.2.1'
|
||||
MODPY_PYTEST_ARGS = pandas \
|
||||
--ignore pandas/tests/tseries/offsets/test_dst.py
|
||||
|
||||
COMPILER = base-clang ports-gcc base-gcc
|
||||
|
||||
BUILD_DEPENDS += lang/cython${MODPY_FLAVOR}>=0.29.32 \
|
||||
math/py-numpy${MODPY_FLAVOR}>=1.15.4 \
|
||||
math/py-oldest-supported-numpy${MODPY_FLAVOR}
|
||||
|
||||
RUN_DEPENDS += devel/py-dateutil${MODPY_FLAVOR}>=2.7.3 \
|
||||
devel/py-tz${MODPY_FLAVOR}>=2017.2 \
|
||||
lang/cython${MODPY_FLAVOR}>=0.29.21 \
|
||||
math/py-numpy${MODPY_FLAVOR}>=1.15.4
|
||||
|
||||
TEST_DEPENDS += databases/py-mysqlclient${MODPY_FLAVOR} \
|
||||
databases/py-psycopg2${MODPY_FLAVOR} \
|
||||
databases/py-sqlalchemy${MODPY_FLAVOR} \
|
||||
devel/ipython${MODPY_FLAVOR} \
|
||||
devel/py-html5lib${MODPY_FLAVOR} \
|
||||
devel/py-hypothesis${MODPY_FLAVOR} \
|
||||
devel/py-ipykernel${MODPY_FLAVOR} \
|
||||
devel/py-xlsxwriter${MODPY_FLAVOR} \
|
||||
graphics/py-matplotlib${MODPY_FLAVOR} \
|
||||
math/py-bottleneck${MODPY_FLAVOR} \
|
||||
math/py-numexpr${MODPY_FLAVOR} \
|
||||
math/py-scipy${MODPY_FLAVOR} \
|
||||
textproc/py-lxml${MODPY_FLAVOR} \
|
||||
textproc/py-openpyxl${MODPY_FLAVOR} \
|
||||
www/py-beautifulsoup4${MODPY_FLAVOR} \
|
||||
www/py-httplib2${MODPY_FLAVOR} \
|
||||
www/py-jinja2${MODPY_FLAVOR} \
|
||||
x11/xclip
|
||||
|
||||
PORTHOME = ${WRKDIR}
|
||||
TEST_ENV += TZ=UTC
|
||||
|
||||
# XXX tarball does not include all files required for the test suite, as such
|
||||
# numerous tests fail.
|
||||
do-test:
|
||||
cd ${WRKSRC} && ${MODPY_CMD} build_ext --inplace
|
||||
@${MODPY_TEST_TARGET}
|
||||
|
||||
.include <bsd.port.mk>
|
2
math/py-pandas/distinfo
Normal file
2
math/py-pandas/distinfo
Normal file
|
@ -0,0 +1,2 @@
|
|||
SHA256 (pandas-1.5.3.tar.gz) = dKP9flp+wFLxgyc9x7Cs06hj7fdSD106F2XAT/2zsLE=
|
||||
SIZE (pandas-1.5.3.tar.gz) = 5203060
|
13
math/py-pandas/patches/patch-pyproject_toml
Normal file
13
math/py-pandas/patches/patch-pyproject_toml
Normal file
|
@ -0,0 +1,13 @@
|
|||
# needs pytest-asyncio?
|
||||
Index: pyproject.toml
|
||||
--- pyproject.toml.orig
|
||||
+++ pyproject.toml
|
||||
@@ -61,7 +61,7 @@ markers = [
|
||||
"arm_slow: mark a test as slow for arm64 architecture",
|
||||
"arraymanager: mark a test to run with ArrayManager enabled",
|
||||
]
|
||||
-asyncio_mode = "strict"
|
||||
+#asyncio_mode = "strict"
|
||||
|
||||
[tool.mypy]
|
||||
# Import discovery
|
3
math/py-pandas/pkg/DESCR
Normal file
3
math/py-pandas/pkg/DESCR
Normal file
|
@ -0,0 +1,3 @@
|
|||
Flexible and powerful data analysis / manipulation library for
|
||||
Python, providing labeled data structures similar to R data.frame
|
||||
objects, statistical functions, and much more.
|
4552
math/py-pandas/pkg/PLIST
Normal file
4552
math/py-pandas/pkg/PLIST
Normal file
File diff suppressed because it is too large
Load diff
Loading…
Add table
Add a link
Reference in a new issue