SecBSD's official ports repository
This commit is contained in:
commit
2c0afcbbf3
64331 changed files with 5339189 additions and 0 deletions
66
lang/python/3.10/patches/patch-configure_ac
Normal file
66
lang/python/3.10/patches/patch-configure_ac
Normal file
|
@ -0,0 +1,66 @@
|
|||
#1: Set ports library version
|
||||
#2: Don't pick up an installed linux/e2fsprogs libuuid.so
|
||||
#3: llvm-ar (used for LTO) is installed as ar
|
||||
#4: OpenBSD isn't multi-arch
|
||||
|
||||
Index: configure.ac
|
||||
--- configure.ac.orig
|
||||
+++ configure.ac
|
||||
@@ -126,7 +126,7 @@ VERSION=PYTHON_VERSION
|
||||
|
||||
# Version number of Python's own shared library file.
|
||||
AC_SUBST(SOVERSION)
|
||||
-SOVERSION=1.0
|
||||
+SOVERSION=${LIBpython3.10_VERSION}
|
||||
|
||||
# The later defininition of _XOPEN_SOURCE disables certain features
|
||||
# on Linux, so we need _GNU_SOURCE to re-enable them (makedev, tm_zone).
|
||||
@@ -876,6 +876,7 @@ AC_MSG_CHECKING([for multiarch])
|
||||
AS_CASE([$ac_sys_system],
|
||||
[Darwin*], [MULTIARCH=""],
|
||||
[FreeBSD*], [MULTIARCH=""],
|
||||
+ [OpenBSD*], [MULTIARCH=""],
|
||||
[MULTIARCH=$($CC --print-multiarch 2>/dev/null)]
|
||||
)
|
||||
AC_SUBST([MULTIARCH])
|
||||
@@ -1380,9 +1381,9 @@ fi],
|
||||
[AC_MSG_RESULT(no)])
|
||||
if test "$Py_LTO" = 'true' ; then
|
||||
case $CC in
|
||||
- *clang*)
|
||||
+ *clang*|cc)
|
||||
AC_SUBST(LLVM_AR)
|
||||
- AC_PATH_TOOL(LLVM_AR, llvm-ar, '', ${llvm_path})
|
||||
+ AC_PATH_TOOL(LLVM_AR, ar, '', ${llvm_path})
|
||||
AC_SUBST(LLVM_AR_FOUND)
|
||||
if test -n "${LLVM_AR}" -a -x "${LLVM_AR}"
|
||||
then
|
||||
@@ -1473,7 +1474,7 @@ then
|
||||
fi
|
||||
LLVM_PROF_ERR=no
|
||||
case $CC in
|
||||
- *clang*)
|
||||
+ *clang*|cc)
|
||||
# Any changes made here should be reflected in the GCC+Darwin case below
|
||||
PGO_PROF_GEN_FLAG="-fprofile-instr-generate"
|
||||
PGO_PROF_USE_FLAG="-fprofile-instr-use=code.profclangd"
|
||||
@@ -2905,18 +2906,7 @@ AC_CHECK_LIB(dl, dlopen) # Dynamic linking for SunOS/S
|
||||
AC_CHECK_LIB(dld, shl_load) # Dynamic linking for HP-UX
|
||||
|
||||
# checks for uuid.h location
|
||||
-AC_CHECK_HEADERS([uuid/uuid.h uuid.h])
|
||||
-
|
||||
-AC_MSG_CHECKING(for uuid_generate_time_safe)
|
||||
-AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[#include <uuid/uuid.h>]], [[
|
||||
-#ifndef uuid_generate_time_safe
|
||||
-void *x = uuid_generate_time_safe
|
||||
-#endif
|
||||
-]])],
|
||||
- [AC_DEFINE(HAVE_UUID_GENERATE_TIME_SAFE, 1, Define if uuid_generate_time_safe() exists.)
|
||||
- AC_MSG_RESULT(yes)],
|
||||
- [AC_MSG_RESULT(no)]
|
||||
-)
|
||||
+AC_CHECK_HEADERS([uuid.h])
|
||||
|
||||
# check for libuuid from util-linux
|
||||
save_LIBS=$LIBS
|
Loading…
Add table
Add a link
Reference in a new issue