SecBSD's official ports repository
This commit is contained in:
commit
2c0afcbbf3
64331 changed files with 5339189 additions and 0 deletions
20
inputmethods/fcitx-kkc/patches/patch-gui_CMakeLists_txt
Normal file
20
inputmethods/fcitx-kkc/patches/patch-gui_CMakeLists_txt
Normal file
|
@ -0,0 +1,20 @@
|
|||
Fix build with CMake 3.26:
|
||||
https://github.com/fcitx/fcitx5-kkc/commit/85b56d6289550174b15f108e355f39d7083f8c5c
|
||||
|
||||
Index: gui/CMakeLists.txt
|
||||
--- gui/CMakeLists.txt.orig
|
||||
+++ gui/CMakeLists.txt
|
||||
@@ -17,12 +17,11 @@ qt5_wrap_ui(KKC_CONFIG_SRCS dictwidget.ui adddictdialo
|
||||
add_library(fcitx5-kkc-config
|
||||
MODULE ${KKC_CONFIG_SRCS})
|
||||
|
||||
-add_definitions(-DQT_NO_KEYWORDS -std=c++11)
|
||||
+add_definitions(-DQT_NO_KEYWORDS)
|
||||
|
||||
target_include_directories(fcitx5-kkc-config PRIVATE ${PROJECT_BINARY_DIR} ${CMAKE_CURRENT_BINARY_DIR})
|
||||
|
||||
set_target_properties(fcitx5-kkc-config PROPERTIES
|
||||
- LINK_FLAGS "-Wl,--no-undefined"
|
||||
AUTOMOC TRUE
|
||||
AUTOUIC TRUE
|
||||
AUTOUIC_OPTIONS "-tr=fcitx::tr2fcitx;--include=fcitxqti18nhelper.h")
|
Loading…
Add table
Add a link
Reference in a new issue