SecBSD's official ports repository
This commit is contained in:
commit
2c0afcbbf3
64331 changed files with 5339189 additions and 0 deletions
47
inputmethods/fcitx-config-qt/Makefile
Normal file
47
inputmethods/fcitx-config-qt/Makefile
Normal file
|
@ -0,0 +1,47 @@
|
|||
COMMENT = GUI configure tool for fcitx5
|
||||
|
||||
V = 5.0.17
|
||||
DISTNAME = fcitx5-configtool-$V
|
||||
PKGNAME = fcitx-configtool-qt-$V
|
||||
|
||||
CATEGORIES = inputmethods
|
||||
|
||||
HOMEPAGE = https://github.com/fcitx/fcitx5-configtool
|
||||
|
||||
MAINTAINER = Yifei Zhan <openbsd@zhan.science>
|
||||
|
||||
# GPLv2.0+
|
||||
PERMIT_PACKAGE= Yes
|
||||
|
||||
WANTLIB += ${COMPILER_LIBCXX} Fcitx5Config Fcitx5Core Fcitx5Qt5DBusAddons
|
||||
WANTLIB += Fcitx5Qt5WidgetsAddons Fcitx5Utils KF5ConfigCore KF5CoreAddons
|
||||
WANTLIB += KF5I18n KF5IconThemes KF5ItemViews KF5Package KF5Plasma
|
||||
WANTLIB += KF5QuickAddons KF5Service KF5WidgetsAddons Qt5Core
|
||||
WANTLIB += Qt5DBus Qt5Gui Qt5Network Qt5Qml Qt5QmlModels Qt5Quick
|
||||
WANTLIB += Qt5Widgets Qt5X11Extras X11 c m xkbcommon xkbfile
|
||||
|
||||
MASTER_SITES = https://download.fcitx-im.org/fcitx5/fcitx5-configtool/
|
||||
DIST_SUBDIR = fcitx
|
||||
|
||||
MODULES = devel/kf5
|
||||
|
||||
BUILD_DEPENDS = devel/gettext,-tools \
|
||||
devel/kf5/kirigami2 \
|
||||
devel/kf5/kpackage \
|
||||
x11/qt5/qtquickcontrols2,-main \
|
||||
devel/iso-codes
|
||||
|
||||
RUN_DEPENDS = devel/desktop-file-utils \
|
||||
devel/kf5/kirigami2 \
|
||||
misc/shared-mime-info
|
||||
|
||||
LIB_DEPENDS = inputmethods/fcitx-qt \
|
||||
x11/qt5/qtx11extras \
|
||||
devel/kf5/plasma-framework \
|
||||
devel/kf5/kdeclarative \
|
||||
devel/kf5/ki18n \
|
||||
devel/kf5/kitemviews
|
||||
|
||||
CONFIGURE_ARGS = -DCMAKE_PREFIX_PATH=${LOCALBASE}/lib/qt5/cmake
|
||||
|
||||
.include <bsd.port.mk>
|
2
inputmethods/fcitx-config-qt/distinfo
Normal file
2
inputmethods/fcitx-config-qt/distinfo
Normal file
|
@ -0,0 +1,2 @@
|
|||
SHA256 (fcitx/fcitx5-configtool-5.0.17.tar.xz) = +LYZbSPRSmrMmis9vDdytuWy46UUe3i2SSOKPXdXhtU=
|
||||
SIZE (fcitx/fcitx5-configtool-5.0.17.tar.xz) = 113760
|
|
@ -0,0 +1,11 @@
|
|||
Index: src/CMakeLists.txt
|
||||
--- src/CMakeLists.txt.orig
|
||||
+++ src/CMakeLists.txt
|
||||
@@ -7,4 +7,6 @@ if (ENABLE_CONFIG_QT)
|
||||
add_subdirectory(configtool)
|
||||
endif()
|
||||
|
||||
-add_subdirectory(migrator)
|
||||
+if (ENABLE_MIGRATOR)
|
||||
+ add_subdirectory(migrator)
|
||||
+endif()
|
1
inputmethods/fcitx-config-qt/pkg/DESCR
Normal file
1
inputmethods/fcitx-config-qt/pkg/DESCR
Normal file
|
@ -0,0 +1 @@
|
|||
GUI configure tool for fcitx5, based on Qt5.
|
61
inputmethods/fcitx-config-qt/pkg/PLIST
Normal file
61
inputmethods/fcitx-config-qt/pkg/PLIST
Normal file
|
@ -0,0 +1,61 @@
|
|||
@bin bin/fcitx5-config-qt
|
||||
@bin bin/fcitx5-plasma-theme-generator
|
||||
@bin bin/kbd-layout-viewer5
|
||||
lib/qt5/plugins/kcms/
|
||||
@so lib/qt5/plugins/kcms/kcm_fcitx5.so
|
||||
share/applications/kbd-layout-viewer5.desktop
|
||||
share/applications/org.fcitx.fcitx5-config-qt.desktop
|
||||
share/kpackage/
|
||||
share/kpackage/kcms/
|
||||
share/kpackage/kcms/org.fcitx.fcitx5.kcm/
|
||||
share/kpackage/kcms/org.fcitx.fcitx5.kcm/contents/
|
||||
share/kpackage/kcms/org.fcitx.fcitx5.kcm/contents/ui/
|
||||
share/kpackage/kcms/org.fcitx.fcitx5.kcm/contents/ui/AddIMPage.qml
|
||||
share/kpackage/kcms/org.fcitx.fcitx5.kcm/contents/ui/AddonPage.qml
|
||||
share/kpackage/kcms/org.fcitx.fcitx5.kcm/contents/ui/BoolOption.qml
|
||||
share/kpackage/kcms/org.fcitx.fcitx5.kcm/contents/ui/ColorOption.qml
|
||||
share/kpackage/kcms/org.fcitx.fcitx5.kcm/contents/ui/ConfigGroup.qml
|
||||
share/kpackage/kcms/org.fcitx.fcitx5.kcm/contents/ui/ConfigPage.qml
|
||||
share/kpackage/kcms/org.fcitx.fcitx5.kcm/contents/ui/EnumOption.qml
|
||||
share/kpackage/kcms/org.fcitx.fcitx5.kcm/contents/ui/ExternalOption.qml
|
||||
share/kpackage/kcms/org.fcitx.fcitx5.kcm/contents/ui/FontOption.qml
|
||||
share/kpackage/kcms/org.fcitx.fcitx5.kcm/contents/ui/IntegerOption.qml
|
||||
share/kpackage/kcms/org.fcitx.fcitx5.kcm/contents/ui/KeyListOption.qml
|
||||
share/kpackage/kcms/org.fcitx.fcitx5.kcm/contents/ui/KeyOption.qml
|
||||
share/kpackage/kcms/org.fcitx.fcitx5.kcm/contents/ui/ListOption.qml
|
||||
share/kpackage/kcms/org.fcitx.fcitx5.kcm/contents/ui/OptionLoader.qml
|
||||
share/kpackage/kcms/org.fcitx.fcitx5.kcm/contents/ui/SaveWarningDialog.qml
|
||||
share/kpackage/kcms/org.fcitx.fcitx5.kcm/contents/ui/SelectLayoutSheet.qml
|
||||
share/kpackage/kcms/org.fcitx.fcitx5.kcm/contents/ui/StringOption.qml
|
||||
share/kpackage/kcms/org.fcitx.fcitx5.kcm/contents/ui/main.qml
|
||||
share/kpackage/kcms/org.fcitx.fcitx5.kcm/contents/ui/utils.js
|
||||
share/kpackage/kcms/org.fcitx.fcitx5.kcm/metadata.desktop
|
||||
share/kpackage/kcms/org.fcitx.fcitx5.kcm/metadata.json
|
||||
share/kservices5/kcm_fcitx5.desktop
|
||||
share/locale/ca/LC_MESSAGES/fcitx5-configtool.mo
|
||||
share/locale/ca/LC_MESSAGES/org.fcitx.fcitx5.kcm.mo
|
||||
share/locale/da/LC_MESSAGES/fcitx5-configtool.mo
|
||||
share/locale/da/LC_MESSAGES/org.fcitx.fcitx5.kcm.mo
|
||||
share/locale/de/LC_MESSAGES/fcitx5-configtool.mo
|
||||
share/locale/de/LC_MESSAGES/org.fcitx.fcitx5.kcm.mo
|
||||
share/locale/es/LC_MESSAGES/org.fcitx.fcitx5.kcm.mo
|
||||
share/locale/fr/LC_MESSAGES/fcitx5-configtool.mo
|
||||
share/locale/fr/LC_MESSAGES/org.fcitx.fcitx5.kcm.mo
|
||||
share/locale/he/LC_MESSAGES/fcitx5-configtool.mo
|
||||
share/locale/he/LC_MESSAGES/org.fcitx.fcitx5.kcm.mo
|
||||
share/locale/ja/LC_MESSAGES/fcitx5-configtool.mo
|
||||
share/locale/ja/LC_MESSAGES/org.fcitx.fcitx5.kcm.mo
|
||||
share/locale/ko/LC_MESSAGES/fcitx5-configtool.mo
|
||||
share/locale/ko/LC_MESSAGES/org.fcitx.fcitx5.kcm.mo
|
||||
share/locale/ru/LC_MESSAGES/fcitx5-configtool.mo
|
||||
share/locale/ru/LC_MESSAGES/org.fcitx.fcitx5.kcm.mo
|
||||
share/locale/tr/LC_MESSAGES/fcitx5-configtool.mo
|
||||
share/locale/tr/LC_MESSAGES/org.fcitx.fcitx5.kcm.mo
|
||||
share/locale/vi/LC_MESSAGES/fcitx5-configtool.mo
|
||||
share/locale/vi/LC_MESSAGES/org.fcitx.fcitx5.kcm.mo
|
||||
share/locale/zh_CN/LC_MESSAGES/fcitx5-configtool.mo
|
||||
share/locale/zh_CN/LC_MESSAGES/org.fcitx.fcitx5.kcm.mo
|
||||
share/locale/zh_TW/LC_MESSAGES/fcitx5-configtool.mo
|
||||
share/locale/zh_TW/LC_MESSAGES/org.fcitx.fcitx5.kcm.mo
|
||||
share/metainfo/org.fcitx.fcitx5.kcm.appdata.xml
|
||||
@tag update-desktop-database
|
Loading…
Add table
Add a link
Reference in a new issue