SecBSD's official ports repository

This commit is contained in:
purplerain 2023-08-16 22:26:55 +00:00
commit 2c0afcbbf3
Signed by: purplerain
GPG key ID: F42C07F07E2E35B7
64331 changed files with 5339189 additions and 0 deletions

View file

@ -0,0 +1,67 @@
COMMENT= Python charting and plotting API
MODPY_EGG_VERSION = 3.6.3
DISTNAME = matplotlib-${MODPY_EGG_VERSION}
PKGNAME = py-${DISTNAME}
CATEGORIES = graphics devel math
HOMEPAGE = https://matplotlib.org/
# BSD-like
PERMIT_PACKAGE = Yes
WANTLIB += ${COMPILER_LIBCXX} freetype m png qhull_r z
COMPILER = base-clang ports-gcc base-gcc
MODULES= lang/python
FLAVORS= python3
FLAVOR = python3
MODPY_PI = Yes
MODPY_PYBUILD = setuptools_scm
NO_TEST = Yes
BUILD_DEPENDS = devel/py-certifi${MODPY_FLAVOR}>=2020.06.20 \
math/qhull \
math/py-numpy${MODPY_FLAVOR}>=1.19 \
textproc/py-sphinx${MODPY_FLAVOR}
RUN_DEPENDS= devel/py-tz${MODPY_FLAVOR} \
devel/py-dateutil${MODPY_FLAVOR}>=2.7 \
devel/py-kiwisolver${MODPY_FLAVOR}>=1.0.1 \
devel/py-parsing${MODPY_FLAVOR}>=2.2.1 \
devel/py-gobject3${MODPY_FLAVOR} \
math/py-contourpy${MODPY_FLAVOR}>=1.0.1 \
math/py-numpy${MODPY_FLAVOR}>=1.19 \
graphics/py-Pillow${MODPY_FLAVOR}>=6.2.0 \
graphics/py-cairo${MODPY_FLAVOR} \
graphics/py-cycler${MODPY_FLAVOR}>=0.10 \
sysutils/py-packaging${MODPY_FLAVOR}>=20.0 \
${MODPY_TKINTER_DEPENDS}
# pygobject GTK3 introspection (not provided by indirect dependencies)
RUN_DEPENDS += x11/gtk+3
LIB_DEPENDS = graphics/png \
math/qhull
MAKE_ENV+= LDSHARED="${CC} -shared -fPIC"
EXAMPLESDIR= ${PREFIX}/share/examples/${MODPY_PY_PREFIX}matplotlib
post-patch:
cp ${WRKSRC}/mplsetup.cfg{.template,}
pre-configure:
@find ${WRKSRC}/examples -name \*.py -exec ${MODPY_BIN_ADJ} {} +
${SUBST_CMD} ${WRKSRC}/setupext.py
post-install:
${INSTALL_DATA_DIR} ${EXAMPLESDIR}
cd ${WRKSRC}/examples && pax -rw * ${EXAMPLESDIR}
.include <bsd.port.mk>

View file

@ -0,0 +1,2 @@
SHA256 (matplotlib-3.6.3.tar.gz) = H01pcHsWd1YM2VJUTuSWL2j/B5UvuQaf+MErVjU8uMk=
SIZE (matplotlib-3.6.3.tar.gz) = 35868590

View file

@ -0,0 +1,23 @@
Index: mplsetup.cfg.template
--- mplsetup.cfg.template.orig
+++ mplsetup.cfg.template
@@ -11,8 +11,8 @@
# FreeType/Qhull. As an exception, Matplotlib defaults to the system version
# of FreeType on AIX.
#
-#system_freetype = False
-#system_qhull = False
+system_freetype = True
+system_qhull = True
[packages]
# Some of Matplotlib's components are optional: the MacOSX backend (installed
@@ -22,7 +22,7 @@
# lines. Note that the MacOSX backend is never built on Linux or Windows,
# regardless of the config value.
#
-#tests = False
+tests = True
#macosx = True
[rc_options]

View file

@ -0,0 +1,19 @@
Index: setupext.py
--- setupext.py.orig
+++ setupext.py
@@ -435,6 +435,7 @@ class Matplotlib(SetupPackage):
ext = Extension(
"matplotlib._qhull", ["src/_qhull_wrapper.cpp"],
define_macros=[("MPL_DEVNULL", os.devnull)])
+ ext.include_dirs.extend(['${PREFIX}/include'])
add_numpy_flags(ext)
Qhull.add_flags(ext)
yield ext
@@ -448,6 +449,7 @@ class Matplotlib(SetupPackage):
libraries={"linux": ["dl"], "win32": ["comctl32", "psapi"],
"cygwin": ["comctl32", "psapi"]}.get(sys.platform, []),
extra_link_args={"win32": ["-mwindows"]}.get(sys.platform, []))
+ ext.include_dirs.extend(['${X11BASE}/include'])
add_numpy_flags(ext)
add_libagg_flags(ext)
yield ext

View file

@ -0,0 +1,5 @@
matplotlib is a python 2D plotting library which produces publication
quality figures using in a variety of hardcopy formats (PNG, JPG, PS,
SVG). matplotlib can be used in python scripts, interactively from the
python shell (ala matlab or mathematica), in web application servers
generating dynamic charts, or embedded in GUI applications.

File diff suppressed because it is too large Load diff