SecBSD's official ports repository

This commit is contained in:
purplerain 2023-08-16 22:26:55 +00:00
commit 2c0afcbbf3
Signed by: purplerain
GPG key ID: F42C07F07E2E35B7
64331 changed files with 5339189 additions and 0 deletions

View file

@ -0,0 +1,44 @@
Index: PostgreSQL/CMakeLists.txt
--- PostgreSQL/CMakeLists.txt.orig
+++ PostgreSQL/CMakeLists.txt
@@ -101,37 +101,17 @@ add_definitions(
)
set_target_properties(OrthancPostgreSQLStorage PROPERTIES
- VERSION ${ORTHANC_PLUGIN_VERSION}
- SOVERSION ${ORTHANC_PLUGIN_VERSION}
+ LINK_FLAGS "-Wl,-soname,libOrthancPostgreSQLStorage.so"
COMPILE_FLAGS -DORTHANC_ENABLE_LOGGING_PLUGIN=1
)
set_target_properties(OrthancPostgreSQLIndex PROPERTIES
- VERSION ${ORTHANC_PLUGIN_VERSION}
- SOVERSION ${ORTHANC_PLUGIN_VERSION}
+ LINK_FLAGS "-Wl,-soname,libOrthancPostgreSQLIndex.so"
COMPILE_FLAGS -DORTHANC_ENABLE_LOGGING_PLUGIN=1
)
install(
TARGETS OrthancPostgreSQLIndex OrthancPostgreSQLStorage
RUNTIME DESTINATION lib # Destination for Windows
- LIBRARY DESTINATION share/orthanc/plugins # Destination for Linux
- )
-
-
-add_executable(UnitTests
- Plugins/PostgreSQLIndex.cpp
- Plugins/PostgreSQLStorageArea.cpp
- UnitTests/PostgreSQLTests.cpp
- UnitTests/UnitTestsMain.cpp
- ${DATABASES_SOURCES}
- ${GOOGLE_TEST_SOURCES}
- ${AUTOGENERATED_SOURCES}
- )
-
-add_dependencies(UnitTests AutogeneratedTarget)
-
-target_link_libraries(UnitTests ${GOOGLE_TEST_LIBRARIES})
-set_target_properties(UnitTests PROPERTIES
- COMPILE_FLAGS -DORTHANC_ENABLE_LOGGING_PLUGIN=0
+ LIBRARY DESTINATION libexec/orthanc/plugins # Destination for Linux
)

View file

@ -0,0 +1,12 @@
Index: PostgreSQL/ThirdPartyDownloads/Orthanc-1.11.1/OrthancFramework/Resources/ThirdParty/minizip/ioapi.h
--- PostgreSQL/ThirdPartyDownloads/Orthanc-1.11.1/OrthancFramework/Resources/ThirdParty/minizip/ioapi.h.orig
+++ PostgreSQL/ThirdPartyDownloads/Orthanc-1.11.1/OrthancFramework/Resources/ThirdParty/minizip/ioapi.h
@@ -50,7 +50,7 @@
#define ftello64 ftell
#define fseeko64 fseek
#else
-#ifdef __FreeBSD__
+#if defined(__FreeBSD__) || defined(__OpenBSD__)
#define fopen64 fopen
#define ftello64 ftello
#define fseeko64 fseeko

View file

@ -0,0 +1,29 @@
Index: PostgreSQL/ThirdPartyDownloads/Orthanc-1.11.1/OrthancFramework/Sources/SystemToolbox.cpp
--- PostgreSQL/ThirdPartyDownloads/Orthanc-1.11.1/OrthancFramework/Sources/SystemToolbox.cpp.orig
+++ PostgreSQL/ThirdPartyDownloads/Orthanc-1.11.1/OrthancFramework/Sources/SystemToolbox.cpp
@@ -47,14 +47,14 @@
#endif
-#if (defined(__APPLE__) && defined(__MACH__)) || defined(__FreeBSD_kernel__) || defined(__FreeBSD__)
+#if (defined(__APPLE__) && defined(__MACH__)) || defined(__FreeBSD_kernel__) || defined(__FreeBSD__) || defined(__OpenBSD__)
# include <net/if_dl.h> // For GetMacAddresses()
# include <net/if_types.h> // For GetMacAddresses()
# include <sys/sysctl.h> // For GetMacAddresses()
#endif
-#if defined(__linux__) || defined(__FreeBSD_kernel__) || defined(__FreeBSD__)
+#if defined(__linux__) || defined(__FreeBSD_kernel__) || defined(__FreeBSD__) || defined(__OpenBSD__)
# include <limits.h> // PATH_MAX
# include <signal.h>
# include <unistd.h>
@@ -1095,7 +1095,7 @@ namespace Orthanc
while (!interfaces.IsDone())
{
-#if (defined(__APPLE__) && defined(__MACH__)) || defined(__FreeBSD_kernel__) || defined(__FreeBSD__)
+#if (defined(__APPLE__) && defined(__MACH__)) || defined(__FreeBSD_kernel__) || defined(__FreeBSD__) || defined(__OpenBSD__)
int mib[6];
mib[0] = CTL_NET;
mib[1] = AF_ROUTE;