SecBSD's official ports repository
This commit is contained in:
commit
2c0afcbbf3
64331 changed files with 5339189 additions and 0 deletions
27
editors/uemacs/Makefile
Normal file
27
editors/uemacs/Makefile
Normal file
|
@ -0,0 +1,27 @@
|
|||
COMMENT= full screen simple editor
|
||||
|
||||
DISTNAME= uemacs
|
||||
PKGNAME= uemacs-4.0
|
||||
CATEGORIES= editors
|
||||
REVISION= 2
|
||||
|
||||
HOMEPAGE= http://uemacs.tripod.com/
|
||||
|
||||
# see doc/readme
|
||||
PERMIT_PACKAGE= Yes
|
||||
|
||||
WANTLIB += c curses
|
||||
|
||||
MASTER_SITES= ftp://aquest.com/pub/uemacs400/disk2/
|
||||
DISTFILES= ue400dev.zip
|
||||
|
||||
EXTRACT_CASES= *.zip) ${UNZIP} -Laq ${FULLDISTDIR}/$$archive -d ${WRKDIR};;
|
||||
|
||||
WRKDIST= ${WRKDIR}
|
||||
|
||||
pre-patch:
|
||||
@cd ${WRKDIR} && cp -pR freebsd openbsd
|
||||
|
||||
NO_TEST= Yes
|
||||
|
||||
.include <bsd.port.mk>
|
2
editors/uemacs/distinfo
Normal file
2
editors/uemacs/distinfo
Normal file
|
@ -0,0 +1,2 @@
|
|||
SHA256 (ue400dev.zip) = VuGfFyjq0USOrFBZUvbCvEA+VaX+KLKP47mmK0nIp/o=
|
||||
SIZE (ue400dev.zip) = 1179949
|
15
editors/uemacs/patches/patch-Makefile
Normal file
15
editors/uemacs/patches/patch-Makefile
Normal file
|
@ -0,0 +1,15 @@
|
|||
--- Makefile.orig 2004-01-06 04:20:22.000000000 +0100
|
||||
+++ Makefile 2004-01-06 04:20:22.000000000 +0100
|
||||
@@ -0,0 +1,12 @@
|
||||
+#
|
||||
+# simple makefile for uemacs
|
||||
+#
|
||||
+
|
||||
+all:
|
||||
+ (cd openbsd; make emacs)
|
||||
+
|
||||
+install: all
|
||||
+ ${BSD_INSTALL_PROGRAM} openbsd/emacs ${PREFIX}/bin/uemacs
|
||||
+ mkdir -p ${PREFIX}/share/uemacs
|
||||
+ ${BSD_INSTALL_DATA} cmd/* ${PREFIX}/share/uemacs
|
||||
+ mv ${PREFIX}/share/uemacs/emacs.rc ${PREFIX}/share/uemacs/.emacsrc
|
1257
editors/uemacs/patches/patch-freebsd_estruct_h
Normal file
1257
editors/uemacs/patches/patch-freebsd_estruct_h
Normal file
File diff suppressed because it is too large
Load diff
13
editors/uemacs/patches/patch-freebsd_makefile
Normal file
13
editors/uemacs/patches/patch-freebsd_makefile
Normal file
|
@ -0,0 +1,13 @@
|
|||
--- freebsd/makefile.orig 1995-11-18 13:19:02.000000000 +0100
|
||||
+++ freebsd/makefile 2004-01-06 04:20:22.000000000 +0100
|
||||
@@ -14,8 +14,8 @@ HDIR = ../h
|
||||
|
||||
# options and arguments to the C compiler
|
||||
|
||||
-#CFLAGS += -I. -I$(HDIR)
|
||||
-CFLAGS = -O -I. -I$(HDIR)
|
||||
+CFLAGS += -I. -I$(HDIR)
|
||||
+#CFLAGS = -O -I. -I$(HDIR)
|
||||
|
||||
# list of header files
|
||||
|
20
editors/uemacs/patches/patch-h_ebind_h
Normal file
20
editors/uemacs/patches/patch-h_ebind_h
Normal file
|
@ -0,0 +1,20 @@
|
|||
--- h/ebind.h.orig 1995-12-31 15:04:34.000000000 +0100
|
||||
+++ h/ebind.h 2004-01-06 04:20:22.000000000 +0100
|
||||
@@ -93,7 +93,7 @@ NOSHARE KEYTAB keytab[NBINDS] = {
|
||||
{CTLX|'A', BINDFNC, setvar},
|
||||
{CTLX|'B', BINDFNC, usebuffer},
|
||||
{CTLX|'C', BINDFNC, spawncli},
|
||||
-#if BSD || FREEBSD || VMS || SUN || HPUX8 || HPUX9 || AVIION
|
||||
+#if BSD || FREEBSD || VMS || SUN || HPUX8 || HPUX9 || AVIION || OPENBSD
|
||||
{CTLX|'D', BINDFNC, bktoshell},
|
||||
#endif
|
||||
{CTLX|'E', BINDFNC, ctlxe},
|
||||
@@ -155,7 +155,7 @@ NOSHARE KEYTAB keytab[NBINDS] = {
|
||||
{META|'P', BINDFNC, gotobop},
|
||||
{META|'Q', BINDFNC, fillpara},
|
||||
{META|'R', BINDFNC, sreplace},
|
||||
-#if BSD || FREEBSD || HPUX8 || HPUX9 || VMS || SUN || AVIION
|
||||
+#if BSD || FREEBSD || HPUX8 || HPUX9 || VMS || SUN || AVIION || OPENBSD
|
||||
{META|'S', BINDFNC, bktoshell},
|
||||
#endif
|
||||
{META|'U', BINDFNC, upperword},
|
11
editors/uemacs/patches/patch-h_epath_h
Normal file
11
editors/uemacs/patches/patch-h_epath_h
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- h/epath.h.orig 2004-01-06 04:20:22.000000000 +0100
|
||||
+++ h/epath.h 2004-01-06 04:20:22.000000000 +0100
|
||||
@@ -64,7 +64,7 @@ NOSHARE CONST char *pathname[] =
|
||||
};
|
||||
#endif
|
||||
|
||||
-#if V7 | BSD | FREEBSD | USG | AIX | SMOS | HPUX8 | HPUX9 | XENIX | SUN | AVIION
|
||||
+#if V7 || BSD || FREEBSD || USG || AIX || SMOS || HPUX8 || HPUX9 || XENIX || SUN || AVIION || OPENBSD
|
||||
{
|
||||
".emacsrc",
|
||||
"emacs.hlp",
|
21
editors/uemacs/patches/patch-h_eproto_h
Normal file
21
editors/uemacs/patches/patch-h_eproto_h
Normal file
|
@ -0,0 +1,21 @@
|
|||
Index: h/eproto.h
|
||||
--- h/eproto.h.orig
|
||||
+++ h/eproto.h
|
||||
@@ -422,7 +422,7 @@ extern int PASCAL NEAR setfillcol(int f, int n);
|
||||
extern int PASCAL NEAR setgmode(int f, int n);
|
||||
extern int PASCAL NEAR setmark(int f, int n);
|
||||
extern int PASCAL NEAR setmod(int f, int n);
|
||||
-extern int PASCAL NEAR setwlist(char *wclist);
|
||||
+extern void PASCAL NEAR setwlist(char *wclist);
|
||||
extern int PASCAL NEAR shellprog(char *cmd);
|
||||
extern int PASCAL NEAR showcpos(int f, int n);
|
||||
extern int PASCAL NEAR showfiles(int f, int n);
|
||||
@@ -552,7 +552,7 @@ extern int PASCAL NEAR backtagword(int f, int n); /* r
|
||||
|
||||
char *strrev(char *);
|
||||
|
||||
-#if WINNT || WINDOW_MSWIN || (MSDOS && IC) || GCC || VMS
|
||||
+#if WINNT || WINDOW_MSWIN || (MSDOS && IC) || GCC || VMS || OPENBSD
|
||||
#include <stdlib.h>
|
||||
#include <string.h>
|
||||
#else
|
1258
editors/uemacs/patches/patch-openbsd_estruct_h
Normal file
1258
editors/uemacs/patches/patch-openbsd_estruct_h
Normal file
File diff suppressed because it is too large
Load diff
13
editors/uemacs/patches/patch-openbsd_makefile
Normal file
13
editors/uemacs/patches/patch-openbsd_makefile
Normal file
|
@ -0,0 +1,13 @@
|
|||
--- openbsd/makefile.orig 1995-11-18 13:19:02.000000000 +0100
|
||||
+++ openbsd/makefile 2004-01-06 04:20:22.000000000 +0100
|
||||
@@ -14,8 +14,8 @@ HDIR = ../h
|
||||
|
||||
# options and arguments to the C compiler
|
||||
|
||||
-#CFLAGS += -I. -I$(HDIR)
|
||||
-CFLAGS = -O -I. -I$(HDIR)
|
||||
+CFLAGS += -I. -I$(HDIR)
|
||||
+#CFLAGS = -O -I. -I$(HDIR)
|
||||
|
||||
# list of header files
|
||||
|
26
editors/uemacs/patches/patch-src_bind_c
Normal file
26
editors/uemacs/patches/patch-src_bind_c
Normal file
|
@ -0,0 +1,26 @@
|
|||
Index: src/bind.c
|
||||
--- src/bind.c.orig
|
||||
+++ src/bind.c
|
||||
@@ -634,7 +634,8 @@ int hflag; /* Look in the HOME environment variable fi
|
||||
register char *sp; /* pointer into path spec */
|
||||
register int i; /* index */
|
||||
static char fspec[NFILEN]; /* full path spec to search */
|
||||
-
|
||||
+ char patha[NFILEN];
|
||||
+
|
||||
/* if we have an absolute path.. check only there! */
|
||||
sp = fname;
|
||||
while (*sp) {
|
||||
@@ -689,9 +690,11 @@ int hflag; /* Look in the HOME environment variable fi
|
||||
#if OS2
|
||||
path = getenv("DPATH");
|
||||
#else
|
||||
- path = getenv("PATH");
|
||||
+ strncpy(patha, getenv("PATH"), NFILEN - 25);
|
||||
+ strcat(patha, ":/usr/local/share/uemacs");
|
||||
#endif
|
||||
#endif
|
||||
+ path = patha;
|
||||
if (path != NULL)
|
||||
while (*path) {
|
||||
|
20
editors/uemacs/patches/patch-src_char_c
Normal file
20
editors/uemacs/patches/patch-src_char_c
Normal file
|
@ -0,0 +1,20 @@
|
|||
Index: src/char.c
|
||||
--- src/char.c.orig
|
||||
+++ src/char.c
|
||||
@@ -142,14 +142,14 @@ VOID PASCAL NEAR initchars() /* initialize the charact
|
||||
lowcase[index] = index ^ DIFCASE;
|
||||
upcase[index ^ DIFCASE] = index;
|
||||
}
|
||||
-#if BSD || FREEBSD || USG || AIX || AUX || SMOS || HPUX8 || HPUX9 || SUN || XENIX || AVIION
|
||||
+#if BSD || FREEBSD || USG || AIX || AUX || SMOS || HPUX8 || HPUX9 || SUN || XENIX || AVIION || OPENBSD
|
||||
/* and for those international characters! */
|
||||
for (index = (unsigned char)'\340';
|
||||
index <= (unsigned char)'\375'; index++) {
|
||||
lowcase[index] = index ^ DIFCASE;
|
||||
upcase[index ^ DIFCASE] = index;
|
||||
}
|
||||
-#endif /* BSD || FREEBSD || USG || AIX || AUX || SMOS || HPUX8 || HPUX9 || SUN || XENIX || AVIION */
|
||||
+#endif /* BSD || FREEBSD || USG || AIX || AUX || SMOS || HPUX8 || HPUX9 || SUN || XENIX || AVIION || OPENBSD */
|
||||
|
||||
#if MSDOS
|
||||
/* setup various extended IBM-PC characters */
|
13
editors/uemacs/patches/patch-src_dolock_c
Normal file
13
editors/uemacs/patches/patch-src_dolock_c
Normal file
|
@ -0,0 +1,13 @@
|
|||
--- src/dolock.c.orig 1995-11-19 03:09:20.000000000 +0100
|
||||
+++ src/dolock.c 2004-01-06 04:20:22.000000000 +0100
|
||||
@@ -53,8 +53,8 @@ char *fname;
|
||||
}
|
||||
#endif
|
||||
|
||||
-#if FILOCK && (MSDOS || WINNT || OS2 || SUN || USG || AIX || AUX || AVIION || BSD || FREEBSD || HPUX8 || HPUX9 || AMIGA)
|
||||
-#if OS2 || ((MSDOS || WINNT) && MSC) || BSD || FREEBSD
|
||||
+#if FILOCK && (MSDOS || WINNT || OS2 || SUN || USG || AIX || AUX || AVIION || BSD || FREEBSD || HPUX8 || HPUX9 || AMIGA || OPENBSD)
|
||||
+#if OS2 || ((MSDOS || WINNT) && MSC) || BSD || FREEBSD || OPENBSD
|
||||
#include <sys/types.h>
|
||||
#endif
|
||||
#include <sys/stat.h>
|
12
editors/uemacs/patches/patch-src_eval_c
Normal file
12
editors/uemacs/patches/patch-src_eval_c
Normal file
|
@ -0,0 +1,12 @@
|
|||
Index: src/eval.c
|
||||
--- src/eval.c.orig
|
||||
+++ src/eval.c
|
||||
@@ -1470,7 +1470,7 @@ xnext: ++sp;
|
||||
/* setwlist: Set an alternative list of character to be
|
||||
considered "in a word */
|
||||
|
||||
-PASCAL NEAR setwlist(wclist)
|
||||
+void PASCAL NEAR setwlist(wclist)
|
||||
|
||||
char *wclist; /* list of characters to consider "in a word" */
|
||||
|
56
editors/uemacs/patches/patch-src_file_c
Normal file
56
editors/uemacs/patches/patch-src_file_c
Normal file
|
@ -0,0 +1,56 @@
|
|||
Index: src/file.c
|
||||
--- src/file.c.orig
|
||||
+++ src/file.c
|
||||
@@ -11,7 +11,7 @@
|
||||
#include "eproto.h"
|
||||
#include "edef.h"
|
||||
#include "elang.h"
|
||||
-#if BSD | FREEBSD | SUN | USG | AIX
|
||||
+#if BSD || FREEBSD || SUN || USG || AIX || OPENBSD
|
||||
#include <sys/types.h>
|
||||
#include <sys/stat.h>
|
||||
#endif
|
||||
@@ -323,7 +323,7 @@ int lockfl; /* check for file locks? */
|
||||
}
|
||||
ffclose(); /* Ignore errors. */
|
||||
|
||||
-#if BSD || FREEBSD || USG || AUX || SMOS || HPUX8 || HPUX9 || SUN || XENIX || AVION
|
||||
+#if BSD || FREEBSD || USG || AUX || SMOS || HPUX8 || HPUX9 || SUN || XENIX || AVION || OPENBSD
|
||||
/* if we don't have write priviledges, make this in VIEW mode */
|
||||
if (s !=FIOERR && s != FIOFNF) {
|
||||
if (access(fname, 2 /* W_OK*/) != 0)
|
||||
@@ -428,7 +428,7 @@ char *fname;
|
||||
while (cp1!=&fname[0] && cp1[-1]!=':' && cp1[-1]!='\\'&&cp1[-1]!='/')
|
||||
--cp1;
|
||||
#endif
|
||||
-#if USG | AIX | AUX | SMOS | HPUX8 | HPUX9 | BSD | FREEBSD | SUN | XENIX | AVIION
|
||||
+#if USG || AIX || AUX || SMOS || HPUX8 || HPUX9 || BSD || FREEBSD || SUN || XENIX || AVIION || OPENBSD
|
||||
while (cp1!=&fname[0] && cp1[-1]!='/')
|
||||
--cp1;
|
||||
#endif
|
||||
@@ -600,7 +600,7 @@ char *mode; /* mode to open file (w = write a = append
|
||||
int sflag; /* are we safe saving? */
|
||||
char tname[NSTRING]; /* temporary file name */
|
||||
char buf[NSTRING]; /* message buffer */
|
||||
-#if BSD | FREEBSD | SUN | XENIX | USG | AIX
|
||||
+#if BSD || FREEBSD || SUN || XENIX || USG || AIX || OPENBSD
|
||||
struct stat st; /* we need info about the file permisions */
|
||||
#endif
|
||||
|
||||
@@ -680,14 +680,14 @@ char *mode; /* mode to open file (w = write a = append
|
||||
strcat(buf, "s");
|
||||
|
||||
if (sflag) {
|
||||
-#if BSD | FREEBSD | SUN | XENIX | USG | AIX
|
||||
+#if BSD || FREEBSD || SUN || XENIX || USG || AIX || OPENBSD
|
||||
/* get the permisions on the original file */
|
||||
stat(fn, &st);
|
||||
#endif
|
||||
/* erase original file */
|
||||
/* rename temporary file to original name */
|
||||
if (unlink(fn) == 0 && rename(tname, fn) == 0) {
|
||||
-#if BSD | FREEBSD | SUN | XENIX | USG | AIX
|
||||
+#if BSD || FREEBSD || SUN || XENIX || USG || AIX || OPENBSD
|
||||
chown(fn, (int)st.st_uid, (int)st.st_gid);
|
||||
chmod(fn, (int)st.st_mode);
|
||||
#else
|
11
editors/uemacs/patches/patch-src_fileio_c
Normal file
11
editors/uemacs/patches/patch-src_fileio_c
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- src/fileio.c.orig 1995-11-19 03:09:22.000000000 +0100
|
||||
+++ src/fileio.c 2004-01-06 04:20:22.000000000 +0100
|
||||
@@ -106,7 +106,7 @@ PASCAL NEAR ffclose()
|
||||
putc(26, ffp); /* add a ^Z at the end of the file */
|
||||
#endif
|
||||
|
||||
-#if USG | AIX | AUX | SMOS | HPUX8 | HPUX9 | SUN | XENIX | BSD || FREEBSD | WMCS | VMS | (MSDOS & (LATTICE | MSC | TURBO | IC | ZTC)) | WINNT | OS2 | (TOS & MWC) | AVIION
|
||||
+#if USG || AIX || AUX || SMOS || HPUX8 || HPUX9 || SUN || XENIX || BSD || FREEBSD || OPENBSD || WMCS || VMS || (MSDOS && (LATTICE || MSC || TURBO || IC || ZTC)) || WINNT || OS2 || (TOS && MWC) || AVIION
|
||||
if (fclose(ffp) != FALSE) {
|
||||
mlwrite(TEXT156);
|
||||
/* "Error closing file" */
|
30
editors/uemacs/patches/patch-src_input_c
Normal file
30
editors/uemacs/patches/patch-src_input_c
Normal file
|
@ -0,0 +1,30 @@
|
|||
Index: src/input.c
|
||||
--- src/input.c.orig
|
||||
+++ src/input.c
|
||||
@@ -47,7 +47,7 @@
|
||||
#include "edef.h"
|
||||
#include "elang.h"
|
||||
|
||||
-#if USG | AIX | AUX | BSD | FREEBSD | SUN | HPUX8 | HPUX9
|
||||
+#if USG || AIX || AUX || BSD || FREEBSD || SUN || HPUX8 || HPUX9 || OPENBSD
|
||||
#include <pwd.h>
|
||||
extern struct passwd *getpwnam();
|
||||
#endif
|
||||
@@ -244,7 +244,7 @@ int maxlen; /* maximum length of input field */
|
||||
char *ptr; /* string pointer */
|
||||
char user_name[NSTRING]; /* user name for directory */
|
||||
static char buf[NSTRING];/* buffer to hold tentative name */
|
||||
-#if USG | AIX | AUX | BSD | FREEBSD | SUN | HPUX8 | HPUX9
|
||||
+#if USG || AIX || AUX || BSD || FREEBSD || SUN || HPUX8 || HPUX9 || OPENBSD
|
||||
struct passwd *pwd; /* password structure */
|
||||
#endif
|
||||
|
||||
@@ -353,7 +353,7 @@ int maxlen; /* maximum length of input field */
|
||||
--ttcol;
|
||||
}
|
||||
|
||||
-#if USG | AIX | AUX | BSD | FREEBSD | SUN | HPUX8 | HPUX9
|
||||
+#if USG || AIX || AUX || BSD || FREEBSD || SUN || HPUX8 || HPUX9 || OPENBSD
|
||||
/* lookup someone else's home directory! */
|
||||
if (user_name[0] != 0) {
|
||||
pwd = getpwnam(user_name);
|
12
editors/uemacs/patches/patch-src_keyboard_c
Normal file
12
editors/uemacs/patches/patch-src_keyboard_c
Normal file
|
@ -0,0 +1,12 @@
|
|||
Index: src/keyboard.c
|
||||
--- src/keyboard.c.orig
|
||||
+++ src/keyboard.c
|
||||
@@ -224,7 +224,7 @@ case 0x90: return(SPEC | CTRL | '+'); /* ctrl grey + *
|
||||
#endif
|
||||
#endif
|
||||
|
||||
-#if BSD || FREEBSD || USG || AIX || AUX || SMOS || HPUX8 || HPUX9 || SUN || XENIX || (AVVION || TERMIOS) || (VMS && SMG) || MPE
|
||||
+#if BSD || FREEBSD || USG || AIX || AUX || SMOS || HPUX8 || HPUX9 || SUN || XENIX || (AVVION || TERMIOS) || (VMS && SMG) || MPE || OPENBSD
|
||||
|
||||
#define NKEYSEQ 300 /* Number of keymap entries */
|
||||
|
21
editors/uemacs/patches/patch-src_lock_c
Normal file
21
editors/uemacs/patches/patch-src_lock_c
Normal file
|
@ -0,0 +1,21 @@
|
|||
Index: src/lock.c
|
||||
--- src/lock.c.orig
|
||||
+++ src/lock.c
|
||||
@@ -10,7 +10,7 @@
|
||||
|
||||
#if FILOCK
|
||||
|
||||
-#if BSD || FREEBSD || WMCS || SUN || XENIX || HPUX8 || HPUX9 || AVIION || USG || AIX || AUX
|
||||
+#if BSD || FREEBSD || WMCS || SUN || XENIX || HPUX8 || HPUX9 || AVIION || USG || AIX || AUX || OPENBSD
|
||||
#include <sys/errno.h>
|
||||
extern int sys_nerr; /* number of system error messages defined */
|
||||
extern char *sys_errlist[]; /* list of message texts */
|
||||
@@ -158,7 +158,7 @@ char *errstr; /* lock error string to print out */
|
||||
|
||||
strcpy(obuf, errstr);
|
||||
strcat(obuf, " - ");
|
||||
-#if BSD || FREEBSD || WMCS || SUN || XENIX || HPUX8 || HPUX9 || AVIION || USG || AIX || AUX
|
||||
+#if BSD || FREEBSD || WMCS || SUN || XENIX || HPUX8 || HPUX9 || AVIION || USG || AIX || AUX || OPENBSD
|
||||
if (errno < sys_nerr)
|
||||
strcat(obuf, sys_errlist[errno]);
|
||||
else
|
93
editors/uemacs/patches/patch-src_unix_c
Normal file
93
editors/uemacs/patches/patch-src_unix_c
Normal file
|
@ -0,0 +1,93 @@
|
|||
Index: src/unix.c
|
||||
--- src/unix.c.orig
|
||||
+++ src/unix.c
|
||||
@@ -81,7 +81,7 @@ int scnothing()
|
||||
}
|
||||
|
||||
/** Only compile for UNIX machines **/
|
||||
-#if BSD || FREEBSD || USG || AIX || AUX || SMOS || HPUX8 || HPUX9 || SUN || XENIX || (AVVION || TERMIOS)
|
||||
+#if BSD || FREEBSD || USG || AIX || AUX || SMOS || HPUX8 || HPUX9 || SUN || XENIX || (AVVION || TERMIOS) || OPENBSD
|
||||
|
||||
/** Include files **/
|
||||
#include "eproto.h" /* Function definitions */
|
||||
@@ -98,7 +98,7 @@ int scnothing()
|
||||
#include <sys/ioctl.h> /* I/O control definitions */
|
||||
|
||||
/** Additional include files **/
|
||||
-#if FREEBSD
|
||||
+#if FREEBSD || OPENBSD
|
||||
#define TERMIOS 1
|
||||
#include <sys/time.h>
|
||||
#undef BSD
|
||||
@@ -109,9 +109,9 @@ int scnothing()
|
||||
#if (BSD && !TERMIOS)
|
||||
#include <sys/time.h> /* Timer definitions */
|
||||
#endif /* (BSD && !TERMIOS) */
|
||||
-#if BSD || FREEBSD || SUN || HPUX8 || HPUX9 || (AVVION || TERMIOS) || AIX
|
||||
+#if BSD || FREEBSD || SUN || HPUX8 || HPUX9 || (AVVION || TERMIOS) || AIX || OPENBSD
|
||||
#include <signal.h> /* Signal definitions */
|
||||
-#endif /* BSD || FREEBSD || SUN || HPUX8 || HPUX9 || (AVVION || TERMIOS) */
|
||||
+#endif /* BSD || FREEBSD || SUN || HPUX8 || HPUX9 || (AVVION || TERMIOS) || OPENBSD */
|
||||
#if USG || AIX || AUX || SMOS || HPUX8 || HPUX9 || SUN || XENIX
|
||||
#include <termio.h> /* Terminal I/O definitions */
|
||||
#endif /* USG || AIX || AUX || SMOS || HPUX8 || HPUX9 || SUN || XENIX */
|
||||
@@ -126,7 +126,7 @@ int scnothing()
|
||||
|
||||
/** Completion include files **/
|
||||
/** Directory accessing: Try and figure this out... if you can! **/
|
||||
-#if ((BSD || FREEBSD) && !TERMIOS)
|
||||
+#if ((BSD || FREEBSD || OPENBSD) && !TERMIOS)
|
||||
#include <sys/dir.h> /* Directory entry definitions */
|
||||
#define DIRENTRY direct
|
||||
#endif /* (BSD && !TERMIOS) */
|
||||
@@ -485,7 +485,7 @@ int ttopen()
|
||||
/** Close terminal device **/
|
||||
int ttclose()
|
||||
{
|
||||
-#if ((AIX == 0) && (TERMIOS == 0)) || (FREEBSD == 1)
|
||||
+#if ((AIX == 0) && (TERMIOS == 0)) || FREEBSD || OPENBSD
|
||||
/* Restore original terminal modes */
|
||||
if (reset != (char*)NULL)
|
||||
write(1, reset, strlen(reset));
|
||||
@@ -1202,7 +1202,7 @@ char * cmd; /* Palette command */
|
||||
return(0);
|
||||
}
|
||||
|
||||
-#if BSD || FREEBSD || SUN || HPUX8 || HPUX9 || (AVVION || TERMIOS)
|
||||
+#if BSD || FREEBSD || SUN || HPUX8 || HPUX9 || (AVVION || TERMIOS) || OPENBSD
|
||||
/* Surely more than just BSD systems do this */
|
||||
|
||||
/** Perform a stop signal **/
|
||||
@@ -1225,12 +1225,12 @@ int bktoshell(f, n)
|
||||
return(0);
|
||||
}
|
||||
|
||||
-#endif /* BSD || FREEBSD || SUN || HPUX8 || HPUX9 || (AVVION || TERMIOS) */
|
||||
+#endif /* BSD || FREEBSD || SUN || HPUX8 || HPUX9 || (AVVION || TERMIOS) || OPENBSD */
|
||||
|
||||
/** Get time of day **/
|
||||
char * timeset()
|
||||
{
|
||||
- long int buf; /* Should be time_t */
|
||||
+ time_t buf;
|
||||
char * sp, * cp;
|
||||
|
||||
char * ctime();
|
||||
@@ -1327,9 +1327,9 @@ int n; /* Argument count */
|
||||
/* Get shell path */
|
||||
sh = getenv("SHELL");
|
||||
if (!sh)
|
||||
-#if BSD || FREEBSD || SUN
|
||||
+#if BSD || FREEBSD || SUN || OPENBSD
|
||||
sh = "/bin/csh";
|
||||
-#endif /* BSD || FREEBSD || SUN */
|
||||
+#endif /* BSD || FREEBSD || SUN || OPENBSD */
|
||||
#if USG || AIX || AUX || SMOS || HPUX8 || HPUX9 || XENIX || (AVVION || TERMIOS)
|
||||
sh = "/bin/sh";
|
||||
#endif /* USG || AIX || AUX || SMOS || HPUX8 || HPUX9 || XENIX || (AVVION || TERMIOS) */
|
||||
@@ -1726,4 +1726,4 @@ void winch_new_size()
|
||||
}
|
||||
#endif
|
||||
|
||||
-#endif /* BSD || FREEBSD || USG || AIX || AUX || SMOS || HPUX8 || HPUX9 || SUN || XENIX || (AVVION || TERMIOS) */
|
||||
+#endif /* BSD || FREEBSD || USG || AIX || AUX || SMOS || HPUX8 || HPUX9 || SUN || XENIX || (AVVION || TERMIOS) || OPENBSD */
|
17
editors/uemacs/pkg/DESCR
Normal file
17
editors/uemacs/pkg/DESCR
Normal file
|
@ -0,0 +1,17 @@
|
|||
MicroEMACS is a tool for creating and changing documents,
|
||||
programs, and other text files. It is both relatively easy for the
|
||||
novice to use, but also very powerful in the hands of an expert.
|
||||
MicroEMACS can be extensively customized for the needs of the individual
|
||||
user.
|
||||
|
||||
MicroEMACS allows several files to be edited at the same time.
|
||||
The screen can be split into different windows and screens, and text may
|
||||
be moved freely from one window on any screen to the next. Depending on
|
||||
the type of file being edited, MicroEMACS can change how it behaves to
|
||||
make editing simple. Editing standard text files, program files and
|
||||
word processing documents are all possible at the same time.
|
||||
|
||||
There are extensive capabilities to make word processing and
|
||||
editing easier. These include commands for string searching and
|
||||
replacing, paragraph reformatting and deleting, automatic word wrapping,
|
||||
word move and deletes, easy case controlling, and automatic word counts.
|
22
editors/uemacs/pkg/PLIST
Normal file
22
editors/uemacs/pkg/PLIST
Normal file
|
@ -0,0 +1,22 @@
|
|||
@bin bin/uemacs
|
||||
share/uemacs/
|
||||
share/uemacs/.emacsrc
|
||||
share/uemacs/bpage.cmd
|
||||
share/uemacs/chklist.ms
|
||||
share/uemacs/cpage.cmd
|
||||
share/uemacs/cua.cmd
|
||||
share/uemacs/dev.cmd
|
||||
share/uemacs/ehelp.cmd
|
||||
share/uemacs/ehelp1.txt
|
||||
share/uemacs/ehelp2.txt
|
||||
share/uemacs/epage.cmd
|
||||
share/uemacs/error.cmd
|
||||
share/uemacs/filter.cmd
|
||||
share/uemacs/lpage.cmd
|
||||
share/uemacs/mdi.cmd
|
||||
share/uemacs/mewin.cmd
|
||||
share/uemacs/newpage.cmd
|
||||
share/uemacs/opage.cmd
|
||||
share/uemacs/ppage.cmd
|
||||
share/uemacs/shell.cmd
|
||||
share/uemacs/wpage.cmd
|
Loading…
Add table
Add a link
Reference in a new issue