SecBSD's official ports repository
This commit is contained in:
commit
2c0afcbbf3
64331 changed files with 5339189 additions and 0 deletions
20
devel/xtensa-esp32s2-elf/binutils/Makefile
Normal file
20
devel/xtensa-esp32s2-elf/binutils/Makefile
Normal file
|
@ -0,0 +1,20 @@
|
|||
BROKEN-sparc64 = /tmp/testplug-3405d1.s:2847: Error: can't resolve `.L.str.48'
|
||||
|
||||
COMMENT = binutils for ${CONFIG} cross-development
|
||||
VERSION = 2.35.1.2020.1223
|
||||
PKGNAME = ${CONFIG}-binutils-${VERSION}
|
||||
REVISION = 0
|
||||
|
||||
GH_ACCOUNT = espressif
|
||||
GH_PROJECT = binutils-gdb
|
||||
GH_TAGNAME = esp-2021r2-binutils
|
||||
|
||||
WANTLIB += c z
|
||||
|
||||
CONFIGURE_ARGS += --disable-multilib \
|
||||
--with-gnu-as \
|
||||
--with-gnu-ld \
|
||||
--disable-werror \
|
||||
--disable-gdb
|
||||
|
||||
.include <bsd.port.mk>
|
2
devel/xtensa-esp32s2-elf/binutils/distinfo
Normal file
2
devel/xtensa-esp32s2-elf/binutils/distinfo
Normal file
|
@ -0,0 +1,2 @@
|
|||
SHA256 (binutils-gdb-esp-2021r2-binutils.tar.gz) = zsRv11iRKXZVSpMDVfg6iTkt4YO1nXXXRbj9qwFzDIk=
|
||||
SIZE (binutils-gdb-esp-2021r2-binutils.tar.gz) = 60652952
|
23334
devel/xtensa-esp32s2-elf/binutils/patches/patch-bfd_xtensa-modules_c
Normal file
23334
devel/xtensa-esp32s2-elf/binutils/patches/patch-bfd_xtensa-modules_c
Normal file
File diff suppressed because it is too large
Load diff
|
@ -0,0 +1,127 @@
|
|||
Index: include/xtensa-config.h
|
||||
--- include/xtensa-config.h.orig
|
||||
+++ include/xtensa-config.h
|
||||
@@ -1,5 +1,6 @@
|
||||
/* Xtensa configuration settings.
|
||||
- Copyright (C) 2001-2020 Free Software Foundation, Inc.
|
||||
+ Copyright (C) 2001, 2002, 2003, 2004, 2005, 2006, 2007, 2008
|
||||
+ Free Software Foundation, Inc.
|
||||
Contributed by Bob Wilson (bob.wilson@acm.org) at Tensilica.
|
||||
|
||||
This program is free software; you can redistribute it and/or modify
|
||||
@@ -25,7 +26,7 @@
|
||||
macros. */
|
||||
|
||||
#undef XCHAL_HAVE_BE
|
||||
-#define XCHAL_HAVE_BE 1
|
||||
+#define XCHAL_HAVE_BE 0
|
||||
|
||||
#undef XCHAL_HAVE_DENSITY
|
||||
#define XCHAL_HAVE_DENSITY 1
|
||||
@@ -58,7 +59,7 @@
|
||||
#define XCHAL_HAVE_MUL32 1
|
||||
|
||||
#undef XCHAL_HAVE_MUL32_HIGH
|
||||
-#define XCHAL_HAVE_MUL32_HIGH 0
|
||||
+#define XCHAL_HAVE_MUL32_HIGH 1
|
||||
|
||||
#undef XCHAL_HAVE_DIV32
|
||||
#define XCHAL_HAVE_DIV32 1
|
||||
@@ -73,7 +74,7 @@
|
||||
#define XCHAL_HAVE_SEXT 1
|
||||
|
||||
#undef XCHAL_HAVE_LOOPS
|
||||
-#define XCHAL_HAVE_LOOPS 1
|
||||
+#define XCHAL_HAVE_LOOPS 0
|
||||
|
||||
#undef XCHAL_HAVE_THREADPTR
|
||||
#define XCHAL_HAVE_THREADPTR 1
|
||||
@@ -82,7 +83,7 @@
|
||||
#define XCHAL_HAVE_RELEASE_SYNC 1
|
||||
|
||||
#undef XCHAL_HAVE_S32C1I
|
||||
-#define XCHAL_HAVE_S32C1I 1
|
||||
+#define XCHAL_HAVE_S32C1I 0
|
||||
|
||||
#undef XCHAL_HAVE_BOOLEANS
|
||||
#define XCHAL_HAVE_BOOLEANS 0
|
||||
@@ -102,13 +103,17 @@
|
||||
#undef XCHAL_HAVE_FP_RSQRT
|
||||
#define XCHAL_HAVE_FP_RSQRT 0
|
||||
|
||||
+#undef XCHAL_HAVE_DFP_ACCEL
|
||||
+#define XCHAL_HAVE_DFP_ACCEL 0
|
||||
+/* For backward compatibility */
|
||||
#undef XCHAL_HAVE_DFP_accel
|
||||
-#define XCHAL_HAVE_DFP_accel 0
|
||||
+#define XCHAL_HAVE_DFP_accel XCHAL_HAVE_DFP_ACCEL
|
||||
+
|
||||
#undef XCHAL_HAVE_WINDOWED
|
||||
#define XCHAL_HAVE_WINDOWED 1
|
||||
|
||||
#undef XCHAL_NUM_AREGS
|
||||
-#define XCHAL_NUM_AREGS 32
|
||||
+#define XCHAL_NUM_AREGS 64
|
||||
|
||||
#undef XCHAL_HAVE_WIDE_BRANCHES
|
||||
#define XCHAL_HAVE_WIDE_BRANCHES 0
|
||||
@@ -118,34 +123,31 @@
|
||||
|
||||
|
||||
#undef XCHAL_ICACHE_SIZE
|
||||
-#define XCHAL_ICACHE_SIZE 16384
|
||||
+#define XCHAL_ICACHE_SIZE 0
|
||||
|
||||
#undef XCHAL_DCACHE_SIZE
|
||||
-#define XCHAL_DCACHE_SIZE 16384
|
||||
+#define XCHAL_DCACHE_SIZE 0
|
||||
|
||||
#undef XCHAL_ICACHE_LINESIZE
|
||||
-#define XCHAL_ICACHE_LINESIZE 32
|
||||
+#define XCHAL_ICACHE_LINESIZE 16
|
||||
|
||||
#undef XCHAL_DCACHE_LINESIZE
|
||||
-#define XCHAL_DCACHE_LINESIZE 32
|
||||
+#define XCHAL_DCACHE_LINESIZE 16
|
||||
|
||||
#undef XCHAL_ICACHE_LINEWIDTH
|
||||
-#define XCHAL_ICACHE_LINEWIDTH 5
|
||||
+#define XCHAL_ICACHE_LINEWIDTH 4
|
||||
|
||||
#undef XCHAL_DCACHE_LINEWIDTH
|
||||
-#define XCHAL_DCACHE_LINEWIDTH 5
|
||||
+#define XCHAL_DCACHE_LINEWIDTH 4
|
||||
|
||||
#undef XCHAL_DCACHE_IS_WRITEBACK
|
||||
-#define XCHAL_DCACHE_IS_WRITEBACK 1
|
||||
+#define XCHAL_DCACHE_IS_WRITEBACK 0
|
||||
|
||||
|
||||
#undef XCHAL_HAVE_MMU
|
||||
-#define XCHAL_HAVE_MMU 1
|
||||
+#define XCHAL_HAVE_MMU 0
|
||||
|
||||
-#undef XCHAL_MMU_MIN_PTE_PAGE_SIZE
|
||||
-#define XCHAL_MMU_MIN_PTE_PAGE_SIZE 12
|
||||
|
||||
-
|
||||
#undef XCHAL_HAVE_DEBUG
|
||||
#define XCHAL_HAVE_DEBUG 1
|
||||
|
||||
@@ -172,5 +174,16 @@
|
||||
#define XSHAL_ABI XTHAL_ABI_WINDOWED
|
||||
#define XTHAL_ABI_WINDOWED 0
|
||||
#define XTHAL_ABI_CALL0 1
|
||||
+
|
||||
+
|
||||
+#undef XCHAL_M_STAGE
|
||||
+#define XCHAL_M_STAGE 3
|
||||
+
|
||||
+#undef XTENSA_MARCH_LATEST
|
||||
+#define XTENSA_MARCH_LATEST 270009
|
||||
+
|
||||
+#undef XTENSA_MARCH_EARLIEST
|
||||
+#define XTENSA_MARCH_EARLIEST 270009
|
||||
+
|
||||
|
||||
#endif /* !XTENSA_CONFIG_H */
|
24
devel/xtensa-esp32s2-elf/binutils/pkg/DESCR
Normal file
24
devel/xtensa-esp32s2-elf/binutils/pkg/DESCR
Normal file
|
@ -0,0 +1,24 @@
|
|||
GNU Binutils collection, configured for the xtensa-esp32s2-elf target.
|
||||
* ld - the GNU linker.
|
||||
* as - the GNU assembler.
|
||||
|
||||
But they also include:
|
||||
* addr2line - Converts addresses into filenames and line numbers.
|
||||
* ar - A utility for creating, modifying and extracting from
|
||||
archives.
|
||||
* c++filt - Filter to demangle encoded C++ symbols.
|
||||
* gprof - Displays profiling information.
|
||||
* nlmconv - Converts object code into an NLM.
|
||||
* nm - Lists symbols from object files.
|
||||
* objcopy - Copys and translates object files.
|
||||
* objdump - Displays information from object files.
|
||||
* ranlib - Generates an index to the contents of an archive.
|
||||
* readelf - Displays information from any ELF format object file.
|
||||
* size - Lists the section sizes of an object or archive file.
|
||||
* strings - Lists printable strings from files.
|
||||
* strip - Discards symbols.
|
||||
* windres - A compiler for Windows resource files.
|
||||
|
||||
Most of these programs use BFD, the Binary File Descriptor library, to
|
||||
do low-level manipulation. Many of them also use the opcodes library
|
||||
to assemble and disassemble machine instructions.
|
81
devel/xtensa-esp32s2-elf/binutils/pkg/PLIST
Normal file
81
devel/xtensa-esp32s2-elf/binutils/pkg/PLIST
Normal file
|
@ -0,0 +1,81 @@
|
|||
xtensa-esp32s2-elf/
|
||||
xtensa-esp32s2-elf/bin/
|
||||
@bin xtensa-esp32s2-elf/bin/xtensa-esp32s2-elf-addr2line
|
||||
@bin xtensa-esp32s2-elf/bin/xtensa-esp32s2-elf-ar
|
||||
@bin xtensa-esp32s2-elf/bin/xtensa-esp32s2-elf-as
|
||||
@bin xtensa-esp32s2-elf/bin/xtensa-esp32s2-elf-c++filt
|
||||
@bin xtensa-esp32s2-elf/bin/xtensa-esp32s2-elf-elfedit
|
||||
@bin xtensa-esp32s2-elf/bin/xtensa-esp32s2-elf-gprof
|
||||
@bin xtensa-esp32s2-elf/bin/xtensa-esp32s2-elf-ld
|
||||
@bin xtensa-esp32s2-elf/bin/xtensa-esp32s2-elf-ld.bfd
|
||||
@bin xtensa-esp32s2-elf/bin/xtensa-esp32s2-elf-nm
|
||||
@bin xtensa-esp32s2-elf/bin/xtensa-esp32s2-elf-objcopy
|
||||
@bin xtensa-esp32s2-elf/bin/xtensa-esp32s2-elf-objdump
|
||||
@bin xtensa-esp32s2-elf/bin/xtensa-esp32s2-elf-ranlib
|
||||
@bin xtensa-esp32s2-elf/bin/xtensa-esp32s2-elf-readelf
|
||||
@bin xtensa-esp32s2-elf/bin/xtensa-esp32s2-elf-size
|
||||
@bin xtensa-esp32s2-elf/bin/xtensa-esp32s2-elf-strings
|
||||
@bin xtensa-esp32s2-elf/bin/xtensa-esp32s2-elf-strip
|
||||
xtensa-esp32s2-elf/lib/
|
||||
xtensa-esp32s2-elf/lib/ldscripts/
|
||||
xtensa-esp32s2-elf/lib/ldscripts/elf32xtensa.x
|
||||
xtensa-esp32s2-elf/lib/ldscripts/elf32xtensa.xbn
|
||||
xtensa-esp32s2-elf/lib/ldscripts/elf32xtensa.xc
|
||||
xtensa-esp32s2-elf/lib/ldscripts/elf32xtensa.xce
|
||||
xtensa-esp32s2-elf/lib/ldscripts/elf32xtensa.xd
|
||||
xtensa-esp32s2-elf/lib/ldscripts/elf32xtensa.xdc
|
||||
xtensa-esp32s2-elf/lib/ldscripts/elf32xtensa.xdce
|
||||
xtensa-esp32s2-elf/lib/ldscripts/elf32xtensa.xde
|
||||
xtensa-esp32s2-elf/lib/ldscripts/elf32xtensa.xdw
|
||||
xtensa-esp32s2-elf/lib/ldscripts/elf32xtensa.xdwe
|
||||
xtensa-esp32s2-elf/lib/ldscripts/elf32xtensa.xe
|
||||
xtensa-esp32s2-elf/lib/ldscripts/elf32xtensa.xn
|
||||
xtensa-esp32s2-elf/lib/ldscripts/elf32xtensa.xr
|
||||
xtensa-esp32s2-elf/lib/ldscripts/elf32xtensa.xs
|
||||
xtensa-esp32s2-elf/lib/ldscripts/elf32xtensa.xsc
|
||||
xtensa-esp32s2-elf/lib/ldscripts/elf32xtensa.xsce
|
||||
xtensa-esp32s2-elf/lib/ldscripts/elf32xtensa.xse
|
||||
xtensa-esp32s2-elf/lib/ldscripts/elf32xtensa.xsw
|
||||
xtensa-esp32s2-elf/lib/ldscripts/elf32xtensa.xswe
|
||||
xtensa-esp32s2-elf/lib/ldscripts/elf32xtensa.xu
|
||||
xtensa-esp32s2-elf/lib/ldscripts/elf32xtensa.xw
|
||||
xtensa-esp32s2-elf/lib/ldscripts/elf32xtensa.xwe
|
||||
xtensa-esp32s2-elf/share/
|
||||
@info xtensa-esp32s2-elf/share/info/
|
||||
@info xtensa-esp32s2-elf/share/info/as.info
|
||||
@info xtensa-esp32s2-elf/share/info/bfd.info
|
||||
@info xtensa-esp32s2-elf/share/info/binutils.info
|
||||
@info xtensa-esp32s2-elf/share/info/gprof.info
|
||||
@info xtensa-esp32s2-elf/share/info/ld.info
|
||||
@mandir xtensa-esp32s2-elf/share/man/
|
||||
xtensa-esp32s2-elf/share/man/man1/
|
||||
@man xtensa-esp32s2-elf/share/man/man1/xtensa-esp32s2-elf-addr2line.1
|
||||
@man xtensa-esp32s2-elf/share/man/man1/xtensa-esp32s2-elf-ar.1
|
||||
@man xtensa-esp32s2-elf/share/man/man1/xtensa-esp32s2-elf-as.1
|
||||
@man xtensa-esp32s2-elf/share/man/man1/xtensa-esp32s2-elf-c++filt.1
|
||||
@man xtensa-esp32s2-elf/share/man/man1/xtensa-esp32s2-elf-dlltool.1
|
||||
@man xtensa-esp32s2-elf/share/man/man1/xtensa-esp32s2-elf-elfedit.1
|
||||
@man xtensa-esp32s2-elf/share/man/man1/xtensa-esp32s2-elf-gprof.1
|
||||
@man xtensa-esp32s2-elf/share/man/man1/xtensa-esp32s2-elf-ld.1
|
||||
@man xtensa-esp32s2-elf/share/man/man1/xtensa-esp32s2-elf-nm.1
|
||||
@man xtensa-esp32s2-elf/share/man/man1/xtensa-esp32s2-elf-objcopy.1
|
||||
@man xtensa-esp32s2-elf/share/man/man1/xtensa-esp32s2-elf-objdump.1
|
||||
@man xtensa-esp32s2-elf/share/man/man1/xtensa-esp32s2-elf-ranlib.1
|
||||
@man xtensa-esp32s2-elf/share/man/man1/xtensa-esp32s2-elf-readelf.1
|
||||
@man xtensa-esp32s2-elf/share/man/man1/xtensa-esp32s2-elf-size.1
|
||||
@man xtensa-esp32s2-elf/share/man/man1/xtensa-esp32s2-elf-strings.1
|
||||
@man xtensa-esp32s2-elf/share/man/man1/xtensa-esp32s2-elf-strip.1
|
||||
@man xtensa-esp32s2-elf/share/man/man1/xtensa-esp32s2-elf-windmc.1
|
||||
@man xtensa-esp32s2-elf/share/man/man1/xtensa-esp32s2-elf-windres.1
|
||||
xtensa-esp32s2-elf/xtensa-esp32s2-elf/
|
||||
xtensa-esp32s2-elf/xtensa-esp32s2-elf/bin/
|
||||
@bin xtensa-esp32s2-elf/xtensa-esp32s2-elf/bin/ar
|
||||
@bin xtensa-esp32s2-elf/xtensa-esp32s2-elf/bin/as
|
||||
@bin xtensa-esp32s2-elf/xtensa-esp32s2-elf/bin/ld
|
||||
@bin xtensa-esp32s2-elf/xtensa-esp32s2-elf/bin/ld.bfd
|
||||
@bin xtensa-esp32s2-elf/xtensa-esp32s2-elf/bin/nm
|
||||
@bin xtensa-esp32s2-elf/xtensa-esp32s2-elf/bin/objcopy
|
||||
@bin xtensa-esp32s2-elf/xtensa-esp32s2-elf/bin/objdump
|
||||
@bin xtensa-esp32s2-elf/xtensa-esp32s2-elf/bin/ranlib
|
||||
@bin xtensa-esp32s2-elf/xtensa-esp32s2-elf/bin/readelf
|
||||
@bin xtensa-esp32s2-elf/xtensa-esp32s2-elf/bin/strip
|
Loading…
Add table
Add a link
Reference in a new issue