SecBSD's official ports repository
This commit is contained in:
commit
2c0afcbbf3
64331 changed files with 5339189 additions and 0 deletions
44
devel/tclcl/Makefile
Normal file
44
devel/tclcl/Makefile
Normal file
|
@ -0,0 +1,44 @@
|
|||
COMMENT= Tcl/C++ interface used by ns and nam
|
||||
|
||||
V= 1.20
|
||||
DISTNAME= tclcl-src-$V
|
||||
PKGNAME= tclcl-$V
|
||||
REVISION = 3
|
||||
CATEGORIES= devel
|
||||
MAINTAINER = Stuart Cassoff <stwo@users.sourceforge.net>
|
||||
|
||||
HOMEPAGE= http://otcl-tclcl.sourceforge.net/tclcl/
|
||||
|
||||
# BSD
|
||||
PERMIT_PACKAGE= Yes
|
||||
|
||||
MODULES += x11/tk
|
||||
WANTLIB= c m ${COMPILER_LIBCXX} otcl>=1
|
||||
|
||||
COMPILER = base-clang ports-gcc base-gcc
|
||||
|
||||
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE:=otcl-tclcl/}
|
||||
WRKDIST= ${WRKDIR}/tclcl-$V
|
||||
|
||||
LIB_DEPENDS= lang/otcl
|
||||
|
||||
CONFIGURE_STYLE= gnu
|
||||
CONFIGURE_ARGS= --with-tcl-ver=${MODTCL_VERSION} \
|
||||
--with-tk-ver=${MODTK_VERSION} \
|
||||
--with-tcl=${LOCALBASE} \
|
||||
--with-tk=${LOCALBASE}
|
||||
|
||||
pre-configure:
|
||||
@${MODTCL_TCLSH_ADJ} ${WRKSRC}/otcldoc
|
||||
|
||||
do-install:
|
||||
${INSTALL_PROGRAM} ${WRKSRC}/tcl2c++ ${PREFIX}/bin
|
||||
${INSTALL_SCRIPT} ${WRKSRC}/otcldoc ${PREFIX}/bin
|
||||
${INSTALL_DATA_DIR} ${PREFIX}/include/tclcl
|
||||
${INSTALL_DATA} ${WRKSRC}/*.h ${PREFIX}/include/tclcl
|
||||
${INSTALL_DATA} ${WRKSRC}/libtclcl.a ${PREFIX}/lib
|
||||
@ln -sf ${TRUEPREFIX}/lib/libtclcl.a ${PREFIX}/lib/libTcl.a
|
||||
|
||||
NO_TEST= Yes
|
||||
|
||||
.include <bsd.port.mk>
|
2
devel/tclcl/distinfo
Normal file
2
devel/tclcl/distinfo
Normal file
|
@ -0,0 +1,2 @@
|
|||
SHA256 (tclcl-src-1.20.tar.gz) = ZP0exLHRwTIp5Yp+EL+EItgExdPwAiERfq/Cr/MG3Hg=
|
||||
SIZE (tclcl-src-1.20.tar.gz) = 171728
|
11
devel/tclcl/patches/patch-Makefile_in
Normal file
11
devel/tclcl/patches/patch-Makefile_in
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- Makefile.in.orig 2003-08-20 02:26:41.000000000 -0400
|
||||
+++ Makefile.in 2003-08-20 02:38:21.000000000 -0400
|
||||
@@ -66,7 +66,7 @@ INCLUDES = \
|
||||
LIB = \
|
||||
@V_LIBS@
|
||||
|
||||
-CFLAGS = $(CCOPT) $(DEFINE)
|
||||
+CFLAGS = @CFLAGS@ $(DEFINE)
|
||||
|
||||
# Explicitly define compilation rules since SunOS 4's make doesn't like gcc.
|
||||
# Also, gcc does not remove the .o before forking 'as', which can be a
|
18
devel/tclcl/patches/patch-configure
Normal file
18
devel/tclcl/patches/patch-configure
Normal file
|
@ -0,0 +1,18 @@
|
|||
--- configure.orig Sun Sep 5 00:33:14 2010
|
||||
+++ configure Mon Apr 23 11:38:38 2012
|
||||
@@ -5937,6 +5937,7 @@ TCL_OLD_ALT_VERS=`echo $TCL_OLD_VERS | sed 's/\.//'`
|
||||
|
||||
TCL_TCL_PLACES_D="$d \
|
||||
|
||||
+ $d/lib/tcl/tcl$TCL_VERS \
|
||||
$d/lib64/tcl$TCL_HI_VERS \
|
||||
$d/lib64/tcl$TCL_VERS \
|
||||
$d/lib64/tcl$TCL_ALT_VERS \
|
||||
@@ -6552,6 +6553,7 @@ TK_OLD_VERS=8.4
|
||||
TK_OLD_ALT_VERS=`echo $TK_OLD_VERS | sed 's/\.//'`
|
||||
|
||||
TK_TCL_PLACES_D="$d \
|
||||
+ $d/lib/tcl/tk$TK_VERS \
|
||||
$d/lib64/tk$TK_VERS \
|
||||
$d/lib64/tk$TK_ALT_VERS \
|
||||
$d/lib64/tk$TK_HI_VERS \
|
14
devel/tclcl/patches/patch-tclcl_h
Normal file
14
devel/tclcl/patches/patch-tclcl_h
Normal file
|
@ -0,0 +1,14 @@
|
|||
error: invalid suffix on literal; C++11 requires a space between literal and identifier
|
||||
|
||||
Index: tclcl.h
|
||||
--- tclcl.h.orig
|
||||
+++ tclcl.h
|
||||
@@ -190,7 +190,7 @@ class TclObject {
|
||||
/* give an error message and exit if the old variable
|
||||
name is used either for read or write */
|
||||
#define _RENAMED(oldname, newname) \
|
||||
- bind_error(oldname, "variable "oldname" is renamed to "newname)
|
||||
+ bind_error(oldname, "variable " oldname " is renamed to " newname)
|
||||
|
||||
|
||||
virtual int init(int /*argc*/, const char*const* /*argv*/) {
|
1
devel/tclcl/pkg/DESCR
Normal file
1
devel/tclcl/pkg/DESCR
Normal file
|
@ -0,0 +1 @@
|
|||
Tcl/C++ interface used by ns and nam
|
15
devel/tclcl/pkg/PLIST
Normal file
15
devel/tclcl/pkg/PLIST
Normal file
|
@ -0,0 +1,15 @@
|
|||
bin/otcldoc
|
||||
@bin bin/tcl2c++
|
||||
include/tclcl/
|
||||
include/tclcl/config.h
|
||||
include/tclcl/idlecallback.h
|
||||
include/tclcl/iohandler.h
|
||||
include/tclcl/rate-variable.h
|
||||
include/tclcl/tclcl-config.h
|
||||
include/tclcl/tclcl-internal.h
|
||||
include/tclcl/tclcl-mappings.h
|
||||
include/tclcl/tclcl.h
|
||||
include/tclcl/timer.h
|
||||
include/tclcl/tracedvar.h
|
||||
lib/libTcl.a
|
||||
lib/libtclcl.a
|
Loading…
Add table
Add a link
Reference in a new issue