SecBSD's official ports repository
This commit is contained in:
commit
2c0afcbbf3
64331 changed files with 5339189 additions and 0 deletions
22
devel/spidermonkey102/patches/patch-js_src_old-configure_in
Normal file
22
devel/spidermonkey102/patches/patch-js_src_old-configure_in
Normal file
|
@ -0,0 +1,22 @@
|
|||
Index: js/src/old-configure.in
|
||||
--- js/src/old-configure.in.orig
|
||||
+++ js/src/old-configure.in
|
||||
@@ -509,11 +509,18 @@ case "$target" in
|
||||
;;
|
||||
|
||||
*-openbsd*)
|
||||
+ DLL_SUFFIX=".so.$SO_VERSION"
|
||||
DSO_PIC_CFLAGS='-fPIC'
|
||||
DSO_LDOPTS='-shared -fPIC'
|
||||
if test "$LIBRUNPATH"; then
|
||||
DSO_LDOPTS="-R$LIBRUNPATH $DSO_LDOPTS"
|
||||
fi
|
||||
+ if test "$GNU_LD"; then
|
||||
+ # Don't allow undefined symbols in libraries
|
||||
+ DSO_LDOPTS="$DSO_LDOPTS -Wl,-z,defs"
|
||||
+ fi
|
||||
+ MKSHLIB='$(CXX) $(CXXFLAGS) $(DSO_PIC_CFLAGS) $(DSO_LDOPTS) -o $@'
|
||||
+ MKCSHLIB='$(CC) $(CFLAGS) $(DSO_PIC_CFLAGS) $(DSO_LDOPTS) -o $@'
|
||||
;;
|
||||
|
||||
*-solaris*)
|
Loading…
Add table
Add a link
Reference in a new issue