SecBSD's official ports repository
This commit is contained in:
commit
2c0afcbbf3
64331 changed files with 5339189 additions and 0 deletions
33
devel/sdl2-gfx/Makefile
Normal file
33
devel/sdl2-gfx/Makefile
Normal file
|
@ -0,0 +1,33 @@
|
|||
V = 1.0.4
|
||||
COMMENT = primitives drawing/other support functions for SDL2
|
||||
DISTNAME = SDL2_gfx-${V}
|
||||
PKGNAME = sdl2-gfx-${V}
|
||||
CATEGORIES = devel graphics x11
|
||||
REVISION = 0
|
||||
|
||||
SHARED_LIBS += SDL2_gfx 1.0 # 0.1
|
||||
SHARED_LIBS += SDL2_gfx-1.0 1.0 # 0.1
|
||||
|
||||
HOMEPAGE = http://www.ferzkopp.net/joomla/content/view/19/14/
|
||||
|
||||
# zlib
|
||||
PERMIT_PACKAGE = Yes
|
||||
|
||||
WANTLIB += SDL2 m pthread sndio usbhid
|
||||
WANTLIB += X11 Xcursor Xext Xfixes Xi Xinerama Xrandr Xrender Xss
|
||||
WANTLIB += Xxf86vm samplerate xcb
|
||||
|
||||
MASTER_SITES = ${MASTER_SITE_SOURCEFORGE:=sdl2gfx/}
|
||||
|
||||
LIB_DEPENDS = devel/sdl2
|
||||
|
||||
CONFIGURE_STYLE = autoreconf
|
||||
|
||||
.if ${MACHINE_ARCH} != "amd64" && ${MACHINE_ARCH} != "i386"
|
||||
CONFIGURE_ARGS += --disable-mmx
|
||||
.endif
|
||||
|
||||
AUTOCONF_VERSION = 2.65
|
||||
AUTOMAKE_VERSION = 1.11
|
||||
|
||||
.include <bsd.port.mk>
|
2
devel/sdl2-gfx/distinfo
Normal file
2
devel/sdl2-gfx/distinfo
Normal file
|
@ -0,0 +1,2 @@
|
|||
SHA256 (SDL2_gfx-1.0.4.tar.gz) = Y+DgGt3tyd8vhbk6JI8G6KBK/6AUqDXC6jS/405XYmI=
|
||||
SIZE (SDL2_gfx-1.0.4.tar.gz) = 1230588
|
14
devel/sdl2-gfx/patches/patch-Makefile_in
Normal file
14
devel/sdl2-gfx/patches/patch-Makefile_in
Normal file
|
@ -0,0 +1,14 @@
|
|||
We don't need a version number in the library name itself, on top of the SO
|
||||
number.
|
||||
|
||||
Index: Makefile.in
|
||||
--- Makefile.in.orig
|
||||
+++ Makefile.in
|
||||
@@ -306,7 +306,6 @@ EXTRA_DIST = \
|
||||
|
||||
libSDL2_gfx_la_LDFLAGS = \
|
||||
-no-undefined \
|
||||
- -release $(LT_RELEASE) \
|
||||
-version-info $(LT_CURRENT):$(LT_REVISION):$(LT_AGE)
|
||||
|
||||
pkgconfigdir = $(libdir)/pkgconfig
|
6
devel/sdl2-gfx/pkg/DESCR
Normal file
6
devel/sdl2-gfx/pkg/DESCR
Normal file
|
@ -0,0 +1,6 @@
|
|||
SDL2_gfx is a port of SDL_gfx to SDL2.
|
||||
|
||||
The SDL_gfx library evolved out of the SDL_gfxPrimitives code which
|
||||
provided basic drawing routines such as lines, circles or polygons, and
|
||||
SDL_rotozoom which implemented a interpolating rotozoomer for SDL
|
||||
surfaces.
|
9
devel/sdl2-gfx/pkg/PLIST
Normal file
9
devel/sdl2-gfx/pkg/PLIST
Normal file
|
@ -0,0 +1,9 @@
|
|||
include/SDL2/SDL2_framerate.h
|
||||
include/SDL2/SDL2_gfxPrimitives.h
|
||||
include/SDL2/SDL2_imageFilter.h
|
||||
include/SDL2/SDL2_rotozoom.h
|
||||
@lib lib/libSDL2_gfx-1.0.so.${LIBSDL2_gfx-1.0_VERSION}
|
||||
@static-lib lib/libSDL2_gfx.a
|
||||
lib/libSDL2_gfx.la
|
||||
@lib lib/libSDL2_gfx.so.${LIBSDL2_gfx_VERSION}
|
||||
lib/pkgconfig/SDL2_gfx.pc
|
Loading…
Add table
Add a link
Reference in a new issue