SecBSD's official ports repository

This commit is contained in:
purplerain 2023-08-16 22:26:55 +00:00
commit 2c0afcbbf3
Signed by: purplerain
GPG key ID: F42C07F07E2E35B7
64331 changed files with 5339189 additions and 0 deletions

34
devel/sdl-image/Makefile Normal file
View file

@ -0,0 +1,34 @@
COMMENT= SDL image library
DISTNAME= SDL_image-1.2.12
PKGNAME= ${DISTNAME:L:S/_/-/}
REVISION= 5
CATEGORIES= devel graphics
MASTER_SITES= ${HOMEPAGE}release/
SHARED_LIBS= SDL_image 3.1
HOMEPAGE= https://www.libsdl.org/projects/SDL_image/
# Zlib
PERMIT_PACKAGE= Yes
WANTLIB= SDL iconv jpeg lzma m png pthread sndio tiff usbhid webp z
WANTLIB+= zstd
LIB_DEPENDS= devel/sdl \
graphics/jpeg \
graphics/libwebp \
graphics/png \
graphics/tiff
CONFIGURE_STYLE=gnu
CONFIGURE_ARGS+=--disable-jpg-shared \
--disable-png-shared \
--disable-tif-shared \
--disable-webp-shared
CONFIGURE_ENV+= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib" \
OBJC="${CC}"
.include <bsd.port.mk>

2
devel/sdl-image/distinfo Normal file
View file

@ -0,0 +1,2 @@
SHA256 (SDL_image-1.2.12.tar.gz) = C5ByKYRWEATehIR3RNVmgJ27na9zKp5QO5GhtahOVpk=
SIZE (SDL_image-1.2.12.tar.gz) = 2231074

View file

@ -0,0 +1,15 @@
--- Makefile.in.orig Fri Jan 20 20:51:33 2012
+++ Makefile.in Sat Mar 17 12:45:49 2012
@@ -303,12 +303,10 @@ EXTRA_DIST = \
@USE_VERSION_RC_FALSE@libSDL_image_la_LDFLAGS = \
@USE_VERSION_RC_FALSE@ -no-undefined \
-@USE_VERSION_RC_FALSE@ -release $(LT_RELEASE) \
@USE_VERSION_RC_FALSE@ -version-info $(LT_CURRENT):$(LT_REVISION):$(LT_AGE)
@USE_VERSION_RC_TRUE@libSDL_image_la_LDFLAGS = \
@USE_VERSION_RC_TRUE@ -no-undefined \
-@USE_VERSION_RC_TRUE@ -release $(LT_RELEASE) \
@USE_VERSION_RC_TRUE@ -version-info $(LT_CURRENT):$(LT_REVISION):$(LT_AGE) -Wl,version.o
@USE_VERSION_RC_FALSE@libSDL_image_la_LIBADD = $(IMG_LIBS)

View file

@ -0,0 +1,9 @@
--- SDL_image.pc.in.orig Fri Jan 20 20:51:33 2012
+++ SDL_image.pc.in Sun Sep 2 22:47:17 2012
@@ -8,5 +8,6 @@ Description: image loading library for Simple DirectMe
Version: @VERSION@
Requires: sdl >= @SDL_VERSION@
Libs: -L${libdir} -lSDL_image
+Libs.private: @IMG_LIBS@
Cflags: -I${includedir}/SDL

View file

@ -0,0 +1,20 @@
--- configure.orig Fri Jan 20 20:51:33 2012
+++ configure Sat Mar 17 12:45:49 2012
@@ -14313,7 +14313,7 @@ if test "${ac_cv_lib_tiff_TIFFClientOpen+set}" = set;
echo $ECHO_N "(cached) $ECHO_C" >&6
else
ac_check_lib_save_LIBS=$LIBS
-LIBS="-ltiff -lz $LIBS"
+LIBS="-ltiff -ljpeg -lz $LIBS"
cat >conftest.$ac_ext <<_ACEOF
/* confdefs.h. */
_ACEOF
@@ -14986,7 +14986,7 @@ _ACEOF
# Disable dynamic jpeg since we're linking it explicitly
jpg_lib=''
fi
- IMG_LIBS="-ltiff -lz $IMG_LIBS"
+ IMG_LIBS="-ltiff -ljpeg -lz $IMG_LIBS"
fi
fi
if test x$enable_jpg = xyes -a x$have_jpg_hdr = xyes -a x$have_jpg_lib = xyes; then

14
devel/sdl-image/pkg/DESCR Normal file
View file

@ -0,0 +1,14 @@
This is a simple library to load images of various formats as SDL surfaces.
This library supports BMP, PPM, PCX, GIF, JPEG, PNG, TGA, and TIFF formats.
API:
#include "SDL_image.h"
SDL_Surface *IMG_Load(const char *file);
or
SDL_Surface *IMG_Load_RW(SDL_RWops *src, int freesrc);
or
SDL_Surface *IMG_Load_RW(SDL_RWops *src, int freesrc, char *type);
where type is a string specifying the format (i.e. "PNG" or "pcx").
Note that IMG_Load_RW cannot load TGA images.

View file

@ -0,0 +1,6 @@
include/SDL/
include/SDL/SDL_image.h
lib/libSDL_image.a
lib/libSDL_image.la
@lib lib/libSDL_image.so.${LIBSDL_image_VERSION}
lib/pkgconfig/SDL_image.pc