SecBSD's official ports repository
This commit is contained in:
commit
2c0afcbbf3
64331 changed files with 5339189 additions and 0 deletions
15
devel/ruby-isolate/Makefile
Normal file
15
devel/ruby-isolate/Makefile
Normal file
|
@ -0,0 +1,15 @@
|
|||
COMMENT = very simple RubyGems sandbox
|
||||
|
||||
DISTNAME = isolate-3.2.1
|
||||
REVISION = 4
|
||||
CATEGORIES = devel
|
||||
|
||||
HOMEPAGE= https://github.com/jbarnette/isolate
|
||||
|
||||
# MIT License
|
||||
PERMIT_PACKAGE = Yes
|
||||
|
||||
MODULES = lang/ruby
|
||||
CONFIGURE_STYLE = ruby gem
|
||||
|
||||
.include <bsd.port.mk>
|
2
devel/ruby-isolate/distinfo
Normal file
2
devel/ruby-isolate/distinfo
Normal file
|
@ -0,0 +1,2 @@
|
|||
SHA256 (isolate-3.2.1.gem) = F3VncfM2ew5FxLV9baOpMHoLBJl2YumlbgbVCXlA9qo=
|
||||
SIZE (isolate-3.2.1.gem) = 27136
|
24
devel/ruby-isolate/patches/patch-lib_isolate_entry_rb
Normal file
24
devel/ruby-isolate/patches/patch-lib_isolate_entry_rb
Normal file
|
@ -0,0 +1,24 @@
|
|||
Add user-install option so that you don't need to have root access
|
||||
to use isolate with gems with C extensions.
|
||||
|
||||
--- lib/isolate/entry.rb.orig Mon Nov 14 19:51:12 2011
|
||||
+++ lib/isolate/entry.rb Mon Nov 14 19:52:10 2011
|
||||
@@ -67,9 +67,7 @@ module Isolate
|
||||
|
||||
def activate
|
||||
fire :activating, :activated do
|
||||
- spec = self.specification
|
||||
- raise Gem::LoadError, "Couldn't resolve: #{self}" unless spec
|
||||
- spec.activate
|
||||
+ Gem::Specification.find_by_name(name, requirement).activate
|
||||
end
|
||||
end
|
||||
|
||||
@@ -86,6 +84,7 @@ module Isolate
|
||||
Gem::DependencyInstaller.new(:development => false,
|
||||
:generate_rdoc => false,
|
||||
:generate_ri => false,
|
||||
+ :user_install => true,
|
||||
:install_dir => @sandbox.path)
|
||||
|
||||
Gem::Command.build_args = Array(options[:args]) if options[:args]
|
2
devel/ruby-isolate/pkg/DESCR
Normal file
2
devel/ruby-isolate/pkg/DESCR
Normal file
|
@ -0,0 +1,2 @@
|
|||
Isolate is a very simple RubyGems sandbox. It provides a way to express
|
||||
and automatically install your project's Gem dependencies.
|
43
devel/ruby-isolate/pkg/PLIST
Normal file
43
devel/ruby-isolate/pkg/PLIST
Normal file
|
@ -0,0 +1,43 @@
|
|||
${GEM_LIB}/cache/${DISTNAME}.gem
|
||||
${GEM_LIB}/gems/${DISTNAME}/
|
||||
${GEM_LIB}/gems/${DISTNAME}/.autotest
|
||||
${GEM_LIB}/gems/${DISTNAME}/.gemtest
|
||||
${GEM_LIB}/gems/${DISTNAME}/CHANGELOG.rdoc
|
||||
${GEM_LIB}/gems/${DISTNAME}/Manifest.txt
|
||||
${GEM_LIB}/gems/${DISTNAME}/README.rdoc
|
||||
${GEM_LIB}/gems/${DISTNAME}/Rakefile
|
||||
${GEM_LIB}/gems/${DISTNAME}/lib/
|
||||
${GEM_LIB}/gems/${DISTNAME}/lib/hoe/
|
||||
${GEM_LIB}/gems/${DISTNAME}/lib/hoe/isolate.rb
|
||||
${GEM_LIB}/gems/${DISTNAME}/lib/isolate/
|
||||
${GEM_LIB}/gems/${DISTNAME}/lib/isolate.rb
|
||||
${GEM_LIB}/gems/${DISTNAME}/lib/isolate/entry.rb
|
||||
${GEM_LIB}/gems/${DISTNAME}/lib/isolate/events.rb
|
||||
${GEM_LIB}/gems/${DISTNAME}/lib/isolate/now.rb
|
||||
${GEM_LIB}/gems/${DISTNAME}/lib/isolate/rake.rb
|
||||
${GEM_LIB}/gems/${DISTNAME}/lib/isolate/sandbox.rb
|
||||
${GEM_LIB}/gems/${DISTNAME}/test/
|
||||
${GEM_LIB}/gems/${DISTNAME}/test/fixtures/
|
||||
${GEM_LIB}/gems/${DISTNAME}/test/fixtures/blort-0.0.gem
|
||||
${GEM_LIB}/gems/${DISTNAME}/test/fixtures/isolate.rb
|
||||
${GEM_LIB}/gems/${DISTNAME}/test/fixtures/override.rb
|
||||
${GEM_LIB}/gems/${DISTNAME}/test/fixtures/override.rb.local
|
||||
${GEM_LIB}/gems/${DISTNAME}/test/fixtures/system/
|
||||
${GEM_LIB}/gems/${DISTNAME}/test/fixtures/system/specifications/
|
||||
${GEM_LIB}/gems/${DISTNAME}/test/fixtures/system/specifications/rcov-0.9.9.gemspec
|
||||
${GEM_LIB}/gems/${DISTNAME}/test/fixtures/system_redundant/
|
||||
${GEM_LIB}/gems/${DISTNAME}/test/fixtures/system_redundant/specifications/
|
||||
${GEM_LIB}/gems/${DISTNAME}/test/fixtures/system_redundant/specifications/rake-0.8.7.gemspec
|
||||
${GEM_LIB}/gems/${DISTNAME}/test/fixtures/system_redundant/specifications/rcov-0.9.9.gemspec
|
||||
${GEM_LIB}/gems/${DISTNAME}/test/fixtures/with-hoe/
|
||||
${GEM_LIB}/gems/${DISTNAME}/test/fixtures/with-hoe/specifications/
|
||||
${GEM_LIB}/gems/${DISTNAME}/test/fixtures/with-hoe/specifications/hoe-2.3.3.gemspec
|
||||
${GEM_LIB}/gems/${DISTNAME}/test/fixtures/with-hoe/specifications/rake-0.8.7.gemspec
|
||||
${GEM_LIB}/gems/${DISTNAME}/test/fixtures/with-hoe/specifications/rubyforge-1.0.4.gemspec
|
||||
${GEM_LIB}/gems/${DISTNAME}/test/isolate/
|
||||
${GEM_LIB}/gems/${DISTNAME}/test/isolate/test.rb
|
||||
${GEM_LIB}/gems/${DISTNAME}/test/test_isolate.rb
|
||||
${GEM_LIB}/gems/${DISTNAME}/test/test_isolate_entry.rb
|
||||
${GEM_LIB}/gems/${DISTNAME}/test/test_isolate_events.rb
|
||||
${GEM_LIB}/gems/${DISTNAME}/test/test_isolate_sandbox.rb
|
||||
${GEM_LIB}/specifications/${DISTNAME}.gemspec
|
Loading…
Add table
Add a link
Reference in a new issue