SecBSD's official ports repository

This commit is contained in:
purplerain 2023-08-16 22:26:55 +00:00
commit 2c0afcbbf3
Signed by: purplerain
GPG key ID: F42C07F07E2E35B7
64331 changed files with 5339189 additions and 0 deletions

View file

@ -0,0 +1,24 @@
COMMENT= binutils for riscv-elf cross-development
V= 2.40
REVISION= 1
DISTNAME= binutils-${V}
HOMEPAGE= https://www.gnu.org/software/binutils/
WANTLIB= c
MASTER_SITES= ${MASTER_SITE_GNU:=binutils/}
DIST_SUBDIR= binutils
USE_GMAKE= Yes
USE_LIBTOOL= No
CONFIGURE_ARGS+=--enable-commonbfdlib=no \
--enable-interwork \
--enable-multilib \
--without-zstd
SUBST_VARS += CONFIG
.include <bsd.port.mk>

View file

@ -0,0 +1,2 @@
SHA256 (binutils/binutils-2.40.tar.xz) = D4pMJy1/F/Np3tEKSsoouOMEgo6VUm2kgrDMxN/J2OE=
SIZE (binutils/binutils-2.40.tar.xz) = 25241484

View file

@ -0,0 +1,12 @@
Index: bfd/Makefile.in
--- bfd/Makefile.in.orig
+++ bfd/Makefile.in
@@ -266,7 +266,7 @@ am__v_texidevnull_ = $(am__v_texidevnull_@AM_DEFAULT_V
am__v_texidevnull_0 = > /dev/null
am__v_texidevnull_1 =
am__dirstamp = $(am__leading_dot)dirstamp
-INFO_DEPS = doc/bfd.info
+INFO_DEPS =
am__TEXINFO_TEX_DIR = $(srcdir)
DVIS = doc/bfd.dvi
PDFS = doc/bfd.pdf

View file

@ -0,0 +1,12 @@
Index: binutils/Makefile.in
--- binutils/Makefile.in.orig
+++ binutils/Makefile.in
@@ -404,7 +404,7 @@ AM_V_texidevnull = $(am__v_texidevnull_@AM_V@)
am__v_texidevnull_ = $(am__v_texidevnull_@AM_DEFAULT_V@)
am__v_texidevnull_0 = > /dev/null
am__v_texidevnull_1 =
-INFO_DEPS = doc/binutils.info
+INFO_DEPS =
am__TEXINFO_TEX_DIR = $(srcdir)
DVIS = doc/binutils.dvi
PDFS = doc/binutils.pdf

View file

@ -0,0 +1,12 @@
Index: gas/Makefile.in
--- gas/Makefile.in.orig
+++ gas/Makefile.in
@@ -270,7 +270,7 @@ AM_V_texidevnull = $(am__v_texidevnull_@AM_V@)
am__v_texidevnull_ = $(am__v_texidevnull_@AM_DEFAULT_V@)
am__v_texidevnull_0 = > /dev/null
am__v_texidevnull_1 =
-INFO_DEPS = doc/as.info
+INFO_DEPS =
TEXINFO_TEX = $(top_srcdir)/../texinfo.tex
am__TEXINFO_TEX_DIR = $(top_srcdir)/..
DVIS = doc/as.dvi

View file

@ -0,0 +1,12 @@
Index: gprof/Makefile.in
--- gprof/Makefile.in.orig
+++ gprof/Makefile.in
@@ -217,7 +217,7 @@ AM_V_texidevnull = $(am__v_texidevnull_@AM_V@)
am__v_texidevnull_ = $(am__v_texidevnull_@AM_DEFAULT_V@)
am__v_texidevnull_0 = > /dev/null
am__v_texidevnull_1 =
-INFO_DEPS = gprof.info
+INFO_DEPS =
am__TEXINFO_TEX_DIR = $(srcdir)/../texinfo
DVIS = gprof.dvi
PDFS = gprof.pdf

View file

@ -0,0 +1,21 @@
Index: ld/Makefile.in
--- ld/Makefile.in.orig
+++ ld/Makefile.in
@@ -301,7 +301,7 @@ AM_V_texidevnull = $(am__v_texidevnull_@AM_V@)
am__v_texidevnull_ = $(am__v_texidevnull_@AM_DEFAULT_V@)
am__v_texidevnull_0 = > /dev/null
am__v_texidevnull_1 =
-INFO_DEPS = ld.info
+INFO_DEPS =
am__TEXINFO_TEX_DIR = $(srcdir)/../texinfo
DVIS = ld.dvi
PDFS = ld.pdf
@@ -1042,7 +1042,7 @@ libldtestplug4_la_SOURCES = testplug4.c
libldtestplug4_la_CFLAGS = -g -O2
libldtestplug4_la_LDFLAGS = -no-undefined -rpath /nowhere
bfdplugindir = $(libdir)/bfd-plugins
-bfdplugin_LTLIBRARIES = libdep.la
+bfdplugin_LTLIBRARIES =
libdep_la_SOURCES = libdep_plugin.c
libdep_la_LDFLAGS = -no-undefined -rpath /nowhere -module -avoid-version
libdep_la_LINK = $(LIBTOOL) $(AM_V_lt) --tag=CC $(AM_LIBTOOLFLAGS) \

View file

@ -0,0 +1,23 @@
enable -shared for U-Boot
Index: ld/emulparams/elf32lriscv-defs.sh
--- ld/emulparams/elf32lriscv-defs.sh.orig
+++ ld/emulparams/elf32lriscv-defs.sh
@@ -16,15 +16,8 @@ if test `echo "$host" | sed -e s/64//` = `echo "$targe
esac
fi
-# Enable shared library support for everything except an embedded elf target.
-case "$target" in
- riscv*-elf)
- ;;
- *)
- GENERATE_SHLIB_SCRIPT=yes
- GENERATE_PIE_SCRIPT=yes
- ;;
-esac
+GENERATE_SHLIB_SCRIPT=yes
+GENERATE_PIE_SCRIPT=yes
IREL_IN_PLT=
TEXT_START_ADDR=0x10000

View file

@ -0,0 +1,12 @@
Index: libctf/Makefile.in
--- libctf/Makefile.in.orig
+++ libctf/Makefile.in
@@ -306,7 +306,7 @@ am__v_texidevnull_ = $(am__v_texidevnull_@AM_DEFAULT_V
am__v_texidevnull_0 = > /dev/null
am__v_texidevnull_1 =
am__dirstamp = $(am__leading_dot)dirstamp
-INFO_DEPS = doc/ctf-spec.info
+INFO_DEPS =
am__TEXINFO_TEX_DIR = $(srcdir)
DVIS = doc/ctf-spec.dvi
PDFS = doc/ctf-spec.pdf

View file

@ -0,0 +1,12 @@
Index: libiberty/Makefile.in
--- libiberty/Makefile.in.orig
+++ libiberty/Makefile.in
@@ -376,7 +376,7 @@ libiberty.html : $(srcdir)/libiberty.texi $(TEXISRC)
@MAINT@ echo stamp > stamp-functions
INSTALL_DEST = @INSTALL_DEST@
-install: install_to_$(INSTALL_DEST) install-subdir
+install:
install-strip: install
.PHONY: install install-strip

View file

@ -0,0 +1,12 @@
Index: libsframe/Makefile.in
--- libsframe/Makefile.in.orig
+++ libsframe/Makefile.in
@@ -276,7 +276,7 @@ AM_V_texidevnull = $(am__v_texidevnull_@AM_V@)
am__v_texidevnull_ = $(am__v_texidevnull_@AM_DEFAULT_V@)
am__v_texidevnull_0 = > /dev/null
am__v_texidevnull_1 =
-INFO_DEPS = doc/sframe-spec.info
+INFO_DEPS =
am__TEXINFO_TEX_DIR = $(srcdir)
DVIS = doc/sframe-spec.dvi
PDFS = doc/sframe-spec.pdf

View file

@ -0,0 +1,24 @@
GNU Binutils collection, configured for the ${CONFIG} target.
* ld - the GNU linker.
* as - the GNU assembler.
But they also include:
* addr2line - Converts addresses into filenames and line numbers.
* ar - A utility for creating, modifying and extracting from
archives.
* c++filt - Filter to demangle encoded C++ symbols.
* gprof - Displays profiling information.
* nlmconv - Converts object code into an NLM.
* nm - Lists symbols from object files.
* objcopy - Copys and translates object files.
* objdump - Displays information from object files.
* ranlib - Generates an index to the contents of an archive.
* readelf - Displays information from any ELF format object file.
* size - Lists the section sizes of an object or archive file.
* strings - Lists printable strings from files.
* strip - Discards symbols.
* windres - A compiler for Windows resource files.
Most of these programs use BFD, the Binary File Descriptor library, to
do low-level manipulation. Many of them also use the opcodes library
to assemble and disassemble machine instructions.

View file

@ -0,0 +1,136 @@
@bin bin/${CONFIG}-addr2line
@bin bin/${CONFIG}-ar
@bin bin/${CONFIG}-as
@bin bin/${CONFIG}-c++filt
@bin bin/${CONFIG}-elfedit
@bin bin/${CONFIG}-gprof
@bin bin/${CONFIG}-ld
@bin bin/${CONFIG}-ld.bfd
@bin bin/${CONFIG}-nm
@bin bin/${CONFIG}-objcopy
@bin bin/${CONFIG}-objdump
@bin bin/${CONFIG}-ranlib
@bin bin/${CONFIG}-readelf
@bin bin/${CONFIG}-size
@bin bin/${CONFIG}-strings
@bin bin/${CONFIG}-strip
@man man/man1/${CONFIG}-addr2line.1
@man man/man1/${CONFIG}-ar.1
@man man/man1/${CONFIG}-as.1
@man man/man1/${CONFIG}-c++filt.1
@man man/man1/${CONFIG}-dlltool.1
@man man/man1/${CONFIG}-elfedit.1
@man man/man1/${CONFIG}-gprof.1
@man man/man1/${CONFIG}-ld.1
@man man/man1/${CONFIG}-nm.1
@man man/man1/${CONFIG}-objcopy.1
@man man/man1/${CONFIG}-objdump.1
@man man/man1/${CONFIG}-ranlib.1
@man man/man1/${CONFIG}-readelf.1
@man man/man1/${CONFIG}-size.1
@man man/man1/${CONFIG}-strings.1
@man man/man1/${CONFIG}-strip.1
@man man/man1/${CONFIG}-windmc.1
@man man/man1/${CONFIG}-windres.1
${CONFIG}/
${CONFIG}/bin/
@bin ${CONFIG}/bin/ar
@bin ${CONFIG}/bin/as
@bin ${CONFIG}/bin/ld
@bin ${CONFIG}/bin/ld.bfd
@bin ${CONFIG}/bin/nm
@bin ${CONFIG}/bin/objcopy
@bin ${CONFIG}/bin/objdump
@bin ${CONFIG}/bin/ranlib
@bin ${CONFIG}/bin/readelf
@bin ${CONFIG}/bin/strip
${CONFIG}/lib/
${CONFIG}/lib/ldscripts/
${CONFIG}/lib/ldscripts/elf32briscv.x
${CONFIG}/lib/ldscripts/elf32briscv.xbn
${CONFIG}/lib/ldscripts/elf32briscv.xc
${CONFIG}/lib/ldscripts/elf32briscv.xce
${CONFIG}/lib/ldscripts/elf32briscv.xd
${CONFIG}/lib/ldscripts/elf32briscv.xdc
${CONFIG}/lib/ldscripts/elf32briscv.xdce
${CONFIG}/lib/ldscripts/elf32briscv.xde
${CONFIG}/lib/ldscripts/elf32briscv.xdw
${CONFIG}/lib/ldscripts/elf32briscv.xdwe
${CONFIG}/lib/ldscripts/elf32briscv.xe
${CONFIG}/lib/ldscripts/elf32briscv.xn
${CONFIG}/lib/ldscripts/elf32briscv.xr
${CONFIG}/lib/ldscripts/elf32briscv.xs
${CONFIG}/lib/ldscripts/elf32briscv.xsc
${CONFIG}/lib/ldscripts/elf32briscv.xsce
${CONFIG}/lib/ldscripts/elf32briscv.xse
${CONFIG}/lib/ldscripts/elf32briscv.xsw
${CONFIG}/lib/ldscripts/elf32briscv.xswe
${CONFIG}/lib/ldscripts/elf32briscv.xu
${CONFIG}/lib/ldscripts/elf32briscv.xw
${CONFIG}/lib/ldscripts/elf32briscv.xwe
${CONFIG}/lib/ldscripts/elf32lriscv.x
${CONFIG}/lib/ldscripts/elf32lriscv.xbn
${CONFIG}/lib/ldscripts/elf32lriscv.xc
${CONFIG}/lib/ldscripts/elf32lriscv.xce
${CONFIG}/lib/ldscripts/elf32lriscv.xd
${CONFIG}/lib/ldscripts/elf32lriscv.xdc
${CONFIG}/lib/ldscripts/elf32lriscv.xdce
${CONFIG}/lib/ldscripts/elf32lriscv.xde
${CONFIG}/lib/ldscripts/elf32lriscv.xdw
${CONFIG}/lib/ldscripts/elf32lriscv.xdwe
${CONFIG}/lib/ldscripts/elf32lriscv.xe
${CONFIG}/lib/ldscripts/elf32lriscv.xn
${CONFIG}/lib/ldscripts/elf32lriscv.xr
${CONFIG}/lib/ldscripts/elf32lriscv.xs
${CONFIG}/lib/ldscripts/elf32lriscv.xsc
${CONFIG}/lib/ldscripts/elf32lriscv.xsce
${CONFIG}/lib/ldscripts/elf32lriscv.xse
${CONFIG}/lib/ldscripts/elf32lriscv.xsw
${CONFIG}/lib/ldscripts/elf32lriscv.xswe
${CONFIG}/lib/ldscripts/elf32lriscv.xu
${CONFIG}/lib/ldscripts/elf32lriscv.xw
${CONFIG}/lib/ldscripts/elf32lriscv.xwe
${CONFIG}/lib/ldscripts/elf64briscv.x
${CONFIG}/lib/ldscripts/elf64briscv.xbn
${CONFIG}/lib/ldscripts/elf64briscv.xc
${CONFIG}/lib/ldscripts/elf64briscv.xce
${CONFIG}/lib/ldscripts/elf64briscv.xd
${CONFIG}/lib/ldscripts/elf64briscv.xdc
${CONFIG}/lib/ldscripts/elf64briscv.xdce
${CONFIG}/lib/ldscripts/elf64briscv.xde
${CONFIG}/lib/ldscripts/elf64briscv.xdw
${CONFIG}/lib/ldscripts/elf64briscv.xdwe
${CONFIG}/lib/ldscripts/elf64briscv.xe
${CONFIG}/lib/ldscripts/elf64briscv.xn
${CONFIG}/lib/ldscripts/elf64briscv.xr
${CONFIG}/lib/ldscripts/elf64briscv.xs
${CONFIG}/lib/ldscripts/elf64briscv.xsc
${CONFIG}/lib/ldscripts/elf64briscv.xsce
${CONFIG}/lib/ldscripts/elf64briscv.xse
${CONFIG}/lib/ldscripts/elf64briscv.xsw
${CONFIG}/lib/ldscripts/elf64briscv.xswe
${CONFIG}/lib/ldscripts/elf64briscv.xu
${CONFIG}/lib/ldscripts/elf64briscv.xw
${CONFIG}/lib/ldscripts/elf64briscv.xwe
${CONFIG}/lib/ldscripts/elf64lriscv.x
${CONFIG}/lib/ldscripts/elf64lriscv.xbn
${CONFIG}/lib/ldscripts/elf64lriscv.xc
${CONFIG}/lib/ldscripts/elf64lriscv.xce
${CONFIG}/lib/ldscripts/elf64lriscv.xd
${CONFIG}/lib/ldscripts/elf64lriscv.xdc
${CONFIG}/lib/ldscripts/elf64lriscv.xdce
${CONFIG}/lib/ldscripts/elf64lriscv.xde
${CONFIG}/lib/ldscripts/elf64lriscv.xdw
${CONFIG}/lib/ldscripts/elf64lriscv.xdwe
${CONFIG}/lib/ldscripts/elf64lriscv.xe
${CONFIG}/lib/ldscripts/elf64lriscv.xn
${CONFIG}/lib/ldscripts/elf64lriscv.xr
${CONFIG}/lib/ldscripts/elf64lriscv.xs
${CONFIG}/lib/ldscripts/elf64lriscv.xsc
${CONFIG}/lib/ldscripts/elf64lriscv.xsce
${CONFIG}/lib/ldscripts/elf64lriscv.xse
${CONFIG}/lib/ldscripts/elf64lriscv.xsw
${CONFIG}/lib/ldscripts/elf64lriscv.xswe
${CONFIG}/lib/ldscripts/elf64lriscv.xu
${CONFIG}/lib/ldscripts/elf64lriscv.xw
${CONFIG}/lib/ldscripts/elf64lriscv.xwe