SecBSD's official ports repository
This commit is contained in:
commit
2c0afcbbf3
64331 changed files with 5339189 additions and 0 deletions
29
devel/pycdc/Makefile
Normal file
29
devel/pycdc/Makefile
Normal file
|
@ -0,0 +1,29 @@
|
|||
COMMENT = python bytecode disassembler and decompiler
|
||||
|
||||
DISTNAME = pycdc-0.0.20180428
|
||||
REVISION = 5
|
||||
|
||||
GH_ACCOUNT = zrax
|
||||
GH_PROJECT = pycdc
|
||||
GH_COMMIT = 1c01ca7ee626f6794b879c5690eb741a64711625
|
||||
|
||||
CATEGORIES = devel
|
||||
|
||||
MAINTAINER = Remi Pointel <rpointel@openbsd.org>
|
||||
|
||||
# GPLv3
|
||||
PERMIT_PACKAGE = Yes
|
||||
|
||||
MODULES = devel/cmake \
|
||||
lang/python
|
||||
|
||||
WANTLIB += ${COMPILER_LIBCXX} c m
|
||||
|
||||
COMPILER = base-clang ports-gcc base-gcc
|
||||
|
||||
pre-test:
|
||||
sed -i "s|#!/bin/bash|#!\${LOCALBASE}/bin/bash|" ${WRKSRC}/pycdc_test.sh
|
||||
|
||||
TEST_DEPENDS = shells/bash
|
||||
|
||||
.include <bsd.port.mk>
|
2
devel/pycdc/distinfo
Normal file
2
devel/pycdc/distinfo
Normal file
|
@ -0,0 +1,2 @@
|
|||
SHA256 (pycdc-0.0.20180428-1c01ca7e.tar.gz) = jaE47BJfmKKd4DsuaaNprVCK2zcdYffaBxH+29cs87E=
|
||||
SIZE (pycdc-0.0.20180428-1c01ca7e.tar.gz) = 327068
|
15
devel/pycdc/patches/patch-CMakeLists_txt
Normal file
15
devel/pycdc/patches/patch-CMakeLists_txt
Normal file
|
@ -0,0 +1,15 @@
|
|||
Fix for ports-gcc, the code generates warnings that triggers a
|
||||
build failure
|
||||
|
||||
Index: CMakeLists.txt
|
||||
--- CMakeLists.txt.orig
|
||||
+++ CMakeLists.txt
|
||||
@@ -5,7 +5,7 @@ cmake_minimum_required(VERSION 2.8)
|
||||
find_package(PythonInterp REQUIRED)
|
||||
|
||||
if(CMAKE_COMPILER_IS_GNUCXX OR "${CMAKE_CXX_COMPILER_ID}" STREQUAL "Clang")
|
||||
- set(CMAKE_CXX_FLAGS "-Wall -Wextra -Werror ${CMAKE_CXX_FLAGS}")
|
||||
+ set(CMAKE_CXX_FLAGS "-Wall -Wextra ${CMAKE_CXX_FLAGS}")
|
||||
endif()
|
||||
|
||||
set(PYTHON_VERSIONS
|
4
devel/pycdc/pkg/DESCR
Normal file
4
devel/pycdc/pkg/DESCR
Normal file
|
@ -0,0 +1,4 @@
|
|||
Decompyle++ aims to translate compiled Python byte-code back into valid and
|
||||
human-readable Python source code. It seeks to support byte-code from any
|
||||
version of Python. Decompyle++ includes both a byte-code disassembler (pycdas)
|
||||
and a decompiler (pycdc).
|
2
devel/pycdc/pkg/PLIST
Normal file
2
devel/pycdc/pkg/PLIST
Normal file
|
@ -0,0 +1,2 @@
|
|||
@bin bin/pycdas
|
||||
@bin bin/pycdc
|
Loading…
Add table
Add a link
Reference in a new issue