SecBSD's official ports repository
This commit is contained in:
commit
2c0afcbbf3
64331 changed files with 5339189 additions and 0 deletions
30
devel/py3c/Makefile
Normal file
30
devel/py3c/Makefile
Normal file
|
@ -0,0 +1,30 @@
|
|||
COMMENT = python 2/3 compatibility layer for C extensions
|
||||
|
||||
GH_ACCOUNT = encukou
|
||||
GH_PROJECT = py3c
|
||||
GH_TAGNAME = v1.1
|
||||
|
||||
CATEGORIES = devel
|
||||
|
||||
HOMEPAGE = https://py3c.readthedocs.io/
|
||||
|
||||
MAINTAINER = Stefan Sperling <stsp@openbsd.org>
|
||||
|
||||
# MIT
|
||||
PERMIT_PACKAGE = Yes
|
||||
|
||||
MODULES = lang/python
|
||||
MODPY_VERSION = ${MODPY_DEFAULT_VERSION_2}
|
||||
MODPY_BUILDDEP = No
|
||||
MODPY_RUNDEP = No
|
||||
TEST_DEPENDS = lang/python/${MODPY_DEFAULT_VERSION_2} \
|
||||
lang/python/${MODPY_DEFAULT_VERSION_3}
|
||||
|
||||
CONFIGURE_STYLE = none
|
||||
|
||||
ALL_TARGET = py3c.pc
|
||||
MAKE_FLAGS = prefix=${PREFIX}
|
||||
|
||||
USE_GMAKE = Yes
|
||||
|
||||
.include <bsd.port.mk>
|
2
devel/py3c/distinfo
Normal file
2
devel/py3c/distinfo
Normal file
|
@ -0,0 +1,2 @@
|
|||
SHA256 (py3c-1.1.tar.gz) = x//CK8kt3tDKhZ21PvOgtGb4mp+KrSk1nJ/k/xjr3SA=
|
||||
SIZE (py3c-1.1.tar.gz) = 45835
|
24
devel/py3c/patches/patch-Makefile
Normal file
24
devel/py3c/patches/patch-Makefile
Normal file
|
@ -0,0 +1,24 @@
|
|||
Honor DESTDIR
|
||||
https://github.com/encukou/py3c/pull/29
|
||||
|
||||
Index: Makefile
|
||||
--- Makefile.orig
|
||||
+++ Makefile
|
||||
@@ -42,12 +42,12 @@ py3c.pc: py3c.pc.in $(includedir)
|
||||
sed -e's:@includedir@:$(realpath $(includedir)):' $< > $@
|
||||
|
||||
install: py3c.pc
|
||||
- mkdir -p -m 0755 $(includedir)/py3c
|
||||
- install -m 0644 include/py3c.h $(includedir)/py3c.h
|
||||
- install -m 0644 $(wildcard include/py3c/*.h) $(includedir)/py3c/
|
||||
+ mkdir -p -m 0755 $(DESTDIR)$(includedir)/py3c
|
||||
+ install -m 0644 include/py3c.h $(DESTDIR)$(includedir)/py3c.h
|
||||
+ install -m 0644 $(wildcard include/py3c/*.h) $(DESTDIR)$(includedir)/py3c/
|
||||
|
||||
- mkdir -p -m 0755 $(pkgconfigdir)
|
||||
- install -m 0644 py3c.pc $(pkgconfigdir)/
|
||||
+ mkdir -p -m 0755 $(DESTDIR)$(pkgconfigdir)
|
||||
+ install -m 0644 py3c.pc $(DESTDIR)$(pkgconfigdir)/
|
||||
|
||||
clean:
|
||||
rm py3c.pc ||:
|
13
devel/py3c/pkg/DESCR
Normal file
13
devel/py3c/pkg/DESCR
Normal file
|
@ -0,0 +1,13 @@
|
|||
py3c helps you port C extensions to Python 3.
|
||||
|
||||
It provides a detailed guide, and a set of macros to make porting easy
|
||||
and reduce boilerplate.
|
||||
|
||||
Design principles
|
||||
- Reduce chances of accidental subtle errors
|
||||
- Minimize boilerplate
|
||||
- Prefer the Python 3 way of doing things
|
||||
- Minimize semantic changes under Python 2
|
||||
|
||||
Versions
|
||||
Projects using py3c will be compatible with CPython 2.6, 2.7, and 3.3+.
|
9
devel/py3c/pkg/PLIST
Normal file
9
devel/py3c/pkg/PLIST
Normal file
|
@ -0,0 +1,9 @@
|
|||
include/py3c/
|
||||
include/py3c.h
|
||||
include/py3c/capsulethunk.h
|
||||
include/py3c/comparison.h
|
||||
include/py3c/compat.h
|
||||
include/py3c/fileshim.h
|
||||
include/py3c/py3shims.h
|
||||
include/py3c/tpflags.h
|
||||
share/pkgconfig/py3c.pc
|
Loading…
Add table
Add a link
Reference in a new issue