SecBSD's official ports repository
This commit is contained in:
commit
2c0afcbbf3
64331 changed files with 5339189 additions and 0 deletions
17
devel/py-unicorn/patches/patch-src_Makefile
Normal file
17
devel/py-unicorn/patches/patch-src_Makefile
Normal file
|
@ -0,0 +1,17 @@
|
|||
-Bsymbolic-functions is not supported by ld.bfd
|
||||
|
||||
Index: src/Makefile
|
||||
--- src/Makefile.orig
|
||||
+++ src/Makefile
|
||||
@@ -218,7 +218,11 @@ else
|
||||
EXT = so
|
||||
VERSION_EXT = $(EXT).$(API_MAJOR)
|
||||
AR_EXT = a
|
||||
+ifeq ($(LD_IS_LLD),1)
|
||||
$(LIBNAME)_LDFLAGS += -Wl,-Bsymbolic-functions,-soname,lib$(LIBNAME).$(VERSION_EXT)
|
||||
+else
|
||||
+$(LIBNAME)_LDFLAGS += -Wl,-soname,lib$(LIBNAME).$(VERSION_EXT)
|
||||
+endif
|
||||
UNICORN_CFLAGS += -fvisibility=hidden
|
||||
endif
|
||||
|
Loading…
Add table
Add a link
Reference in a new issue