SecBSD's official ports repository

This commit is contained in:
purplerain 2023-08-16 22:26:55 +00:00
commit 2c0afcbbf3
Signed by: purplerain
GPG key ID: F42C07F07E2E35B7
64331 changed files with 5339189 additions and 0 deletions

View file

@ -0,0 +1,22 @@
Avoid cython due to build error:
ValueError: 'rencode/rencode.pyx' doesn't match any files
Remove platform specific optimizations.
Index: setup.py
--- setup.py.orig
+++ setup.py
@@ -36,12 +36,12 @@ except ImportError as ex:
from setuptools.command.build_ext import build_ext
cythonize = False
+cythonize = False
source_ext = ".pyx" if cythonize else ".c"
ext_modules = [
Extension(
"rencode._rencode",
- extra_compile_args=["-O3"],
sources=["rencode/rencode" + source_ext],
),
]